summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-02-29 16:44:30 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2016-02-29 16:44:30 -0600
commit1457583300f126ec3756ee369bf6af9c5c9d1d62 (patch)
tree9855239c9ec1c79a2642e99b059d433995ba86b8 /www-apps
parentdev-perl/IMAP-BodyStructure: Remove old (diff)
downloadgentoo-1457583300f126ec3756ee369bf6af9c5c9d1d62.tar.gz
gentoo-1457583300f126ec3756ee369bf6af9c5c9d1d62.tar.bz2
gentoo-1457583300f126ec3756ee369bf6af9c5c9d1d62.zip
www-apps/icingaweb2: bup
Package-Manager: portage-2.2.26
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/icingaweb2/Manifest1
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.2.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/www-apps/icingaweb2/Manifest b/www-apps/icingaweb2/Manifest
index 00a6c24c25f4..ec131548c4c2 100644
--- a/www-apps/icingaweb2/Manifest
+++ b/www-apps/icingaweb2/Manifest
@@ -1,2 +1,3 @@
DIST icingaweb2-2.1.0.tar.gz 9957758 SHA256 1fa15efe4056eca4012358d009da1b90c4b4dd3e18d446de33eeaa48728389fd SHA512 fa694bdaba51b82c33b8fd726807df4c626cd944f1d2949cc8768df3e9bbebdb78888f6aaeba2e88f1f843dab8608d69e1b69f6630e438ab9854d3c8b99f4502 WHIRLPOOL 6b3cba5a701757000909c664d115755efaf3564a77a34a71bc4baa96b058efe1d682867fbaedae22e6a1126aa3dfb47389f8474c42f5a45fbffebc77529a7261
DIST icingaweb2-2.1.2.tar.gz 9800997 SHA256 869a4d0cf72506d098418f3c6bfd642b459dc5e68b5bf349b1e59fb20c3ee73d SHA512 00755ea4dff7084d7fb91cfb36ff14632f18f75231eeecbb09afb293a6a143d84df86dc36d5f4fe47cc36c633857d0897c62278d0fa0c95bd60972b43dd500c7 WHIRLPOOL a4c1662258337d747662e0d3d73f54324a981b595c319e88e094df85dff5d226f925010bbcd64f0cc5639c1ceb606bc7eeca89829faf2115278086295700e5cc
+DIST icingaweb2-2.2.0.tar.gz 9803668 SHA256 f240b35a4082b4835127608d0b11a27a4bf53bb0c88857344255225ce9611201 SHA512 e07948e284e59ac16f94191607d9da88b06e9e311af9f79b3fb19e1a7d943144515d4122dae4b01d09927b586ae4ccf15cce54e47e0e784882a422d6eb434f59 WHIRLPOOL 32734309b65e4ed0d04b060fadeef617ec9f7da7c227c563d76ede12e5839305b3a384f0b355aa8bc6a62d1220f4bf78f2299cddcbedcc7a9f2c1b1972dc5059
diff --git a/www-apps/icingaweb2/icingaweb2-2.2.0.ebuild b/www-apps/icingaweb2/icingaweb2-2.2.0.ebuild
new file mode 100644
index 000000000000..81d827688cc8
--- /dev/null
+++ b/www-apps/icingaweb2/icingaweb2-2.2.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit depend.apache eutils multilib user
+
+DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
+HOMEPAGE="http://www.icinga.org/"
+SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apache2 ldap mysql nginx postgres"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ dev-lang/php:5.6[apache2?,cli,gd,json,intl,ldap?,mysql?,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-php/pecl-imagick
+ apache2? ( >=www-servers/apache-2.4.0 )
+ nginx? ( >=www-servers/nginx-1.7.0:* )"
+RDEPEND="${DEPEND}"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+
+ enewgroup icingaweb2
+ enewgroup icingacmd
+ use nginx && usermod -a -G icingacmd,icingaweb2 nginx
+ use apache2 && usermod -a -G icingacmd,icingaweb2 apache2
+}
+
+pkg_config() {
+ if [[ -d /etc/icingaweb2 ]] ; then
+ einfo "Updating existing installation ..."
+ else
+ einfo "Running first time setup ..."
+ einfo "Creating configuration directory ..."
+ /usr/share/${PN}/bin/icingacli setup config directory
+ einfo "Creating authentication token for web setup ..."
+ /usr/share/${PN}/bin/icingacli setup token create
+ if use apache2 ; then
+ einfo "The following might be useful for your Apache2 configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
+ fi
+ if use nginx ; then
+ einfo "The following might be useful for your NGinx configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
+ fi
+ fi
+ einfo "All done."
+}
+
+src_install() {
+ mkdir -p "${D}/usr/share/${PN}"
+ cp -R "${S}"/* "${D}/usr/share/${PN}"
+ chmod -R a+rX "${D}/usr/share/${PN}/public"
+}
+
+pkg_postinst() {
+ einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
+}