summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-22 01:03:53 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-22 01:03:53 +0200
commit1c70c67f63e73575835a9c6c7b2576d13373e3f0 (patch)
tree3ef8a33566043851115b444042d57d9ef4fe672f /www-apps
parentsys-kernel/vanilla-kernel: Remove old (diff)
downloadgentoo-1c70c67f63e73575835a9c6c7b2576d13373e3f0.tar.gz
gentoo-1c70c67f63e73575835a9c6c7b2576d13373e3f0.tar.bz2
gentoo-1c70c67f63e73575835a9c6c7b2576d13373e3f0.zip
www-apps/phpsysinfo: bump to version 3.3.4
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/phpsysinfo/Manifest1
-rw-r--r--www-apps/phpsysinfo/phpsysinfo-3.3.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/www-apps/phpsysinfo/Manifest b/www-apps/phpsysinfo/Manifest
index f11e46204e17..c76c4e5ec6bb 100644
--- a/www-apps/phpsysinfo/Manifest
+++ b/www-apps/phpsysinfo/Manifest
@@ -1 +1,2 @@
DIST phpsysinfo-3.3.2.tar.gz 891158 BLAKE2B 40428647a502f9861f89a490a10e95bef0fdf306d2ee27507b4f396ee7371ca3d75b7259db53b8501b127fb525dce283cb8c73e50172b5b2a78fc490fc7f658a SHA512 33f76436d6ba1aa76a4c7e7dba84f5d4bf458b505df47d65ff9f1ffecc4db48a853c9cdb8583019e70c4d0b54c184ae6d48968f3ed820a711804095a5fc31b07
+DIST phpsysinfo-3.3.4.tar.gz 946436 BLAKE2B bdfb731ac8e60e436f915b0ac72f3c327b08dfccee0d1cedc4ddc89700c4dc76bdd73d9e37ab82fad25e096a62a9a4d31442939558ab593ba5b97520d428a6c1 SHA512 6bcbf78edfa3af441ee6768cce559635f7aed6ce0e357379a7ad1158dab21b860c82845d746f66074c84cdc92e4a21fb4710f61b69ee8cfa1e457d098d642bf2
diff --git a/www-apps/phpsysinfo/phpsysinfo-3.3.4.ebuild b/www-apps/phpsysinfo/phpsysinfo-3.3.4.ebuild
new file mode 100644
index 000000000000..98bf2ace46fa
--- /dev/null
+++ b/www-apps/phpsysinfo/phpsysinfo-3.3.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature webapp
+
+DESCRIPTION="A customizable PHP script that displays information about your system nicely"
+HOMEPAGE="https://rk4an.github.com/phpsysinfo/"
+SRC_URI="https://github.com/rk4an/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+RDEPEND="
+ dev-lang/php[simplexml,xml,xsl(+),xslt(+),unicode]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG.md README*
+ rm CHANGELOG.md COPYING README* .gitignore .travis.yml || die
+
+ mv phpsysinfo.ini{.new,} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/phpsysinfo.ini
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ optfeature "showing disk temperatures." app-admin/hddtemp
+ optfeature "showing system uptime." app-misc/uptimed
+ optfeature "showing snmp statistics." net-analyzer/net-snmp
+ optfeature "showing iptables rules." net-firewall/iptables
+ optfeature "showing ipmi sensors." sys-apps/ipmitool
+ optfeature "showing ipmi sensors." sys-apps/ipmiutil
+ optfeature "showing system sensors." sys-apps/lm-sensors
+ optfeature "showing s.m.a.r.t. health." sys-apps/smartmontools
+ optfeature "showing lsi raid controller health." sys-block/megactl
+ optfeature "showing fake raid statistics." sys-fs/dmraid
+ optfeature "showing software raid statistics." sys-fs/mdadm
+ optfeature "showing quota information." sys-fs/quota
+ optfeature "showing ipmi sensors." sys-libs/freeipmi
+ optfeature "showing apc ups statistics." sys-power/apcupsd
+ optfeature "showing ups statistics." sys-power/nut
+}