summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2021-06-13 15:09:09 +0200
committerPatrice Clement <monsieurp@gentoo.org>2021-06-13 15:10:06 +0200
commit2a2e25733ee98482ac1b210bdc6a2dd49a2c3029 (patch)
tree3257f46eb7c94360b2f8389e7d5901b39b2d4db6 /www-apps
parentacct-user/zeppelin: initial import. (diff)
downloadgentoo-2a2e25733ee98482ac1b210bdc6a2dd49a2c3029.tar.gz
gentoo-2a2e25733ee98482ac1b210bdc6a2dd49a2c3029.tar.bz2
gentoo-2a2e25733ee98482ac1b210bdc6a2dd49a2c3029.zip
www-apps/zeppelin-bin: migrate to GLEP 81.
Closes: https://bugs.gentoo.org/781533 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/zeppelin-bin/zeppelin-bin-0.8.2-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/www-apps/zeppelin-bin/zeppelin-bin-0.8.2-r1.ebuild b/www-apps/zeppelin-bin/zeppelin-bin-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..a6da6911f3e1
--- /dev/null
+++ b/www-apps/zeppelin-bin/zeppelin-bin-0.8.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit java-pkg-2 user
+
+MY_PN="zeppelin"
+MY_P="${MY_PN}-${PV}-bin-all"
+
+DESCRIPTION="Web-based interactive data analytics notebook launcher"
+HOMEPAGE="https://zeppelin.apache.org"
+SRC_URI="mirror://apache/zeppelin/${MY_PN}-${PV}/${MY_P}.tgz -> ${P}.tgz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ acct-group/zeppelin
+ acct-user/zeppelin
+ >=virtual/jdk-1.8"
+
+RDEPEND="
+ >=virtual/jre-1.8"
+
+S="${WORKDIR}/${MY_P}"
+
+INSTALL_DIR="/opt/${P}"
+
+src_install() {
+ keepdir /var/log/zeppelin
+ fowners -R zeppelin:zeppelin /var/log/zeppelin
+
+ newinitd "${FILESDIR}/zeppelin.init.d" zeppelin
+
+ dodir "${INSTALL_DIR}"
+ cp -pRP * "${ED}/${INSTALL_DIR}" || die
+ dosym "${P}" /opt/zeppelin
+ fowners -R zeppelin:zeppelin "${INSTALL_DIR}"
+}