summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-11-18 18:23:00 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-11-18 18:23:41 +0100
commit3ed8a5a27c7a52824b12cd9bc386542cf139a3ee (patch)
tree73e95ee592248f32ab9835ca127d45c5efe7ddf7 /www-apps
parentdev-go/go-bindata: update upstream remote id (diff)
downloadgentoo-3ed8a5a27c7a52824b12cd9bc386542cf139a3ee.tar.gz
gentoo-3ed8a5a27c7a52824b12cd9bc386542cf139a3ee.tar.bz2
gentoo-3ed8a5a27c7a52824b12cd9bc386542cf139a3ee.zip
www-apps/nikola: bump to v8.1.2
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/nikola/Manifest1
-rw-r--r--www-apps/nikola/nikola-8.1.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/www-apps/nikola/Manifest b/www-apps/nikola/Manifest
index 6adbeb4c7ed1..ed28ce8e9ebe 100644
--- a/www-apps/nikola/Manifest
+++ b/www-apps/nikola/Manifest
@@ -2,3 +2,4 @@ DIST Nikola-7.8.15.tar.gz 4131518 BLAKE2B ea3dca9340852a68b668de82e5deeaa0ecf7bb
DIST Nikola-8.0.4.tar.gz 4137494 BLAKE2B 04db8b83f34ca9b3cee785c5eed9d0421d27acf750c4f17dc3bec0df6fd4f462af52a65c0c97a07777922da3bf3fa855d58d546479b19bfb152e8190d2f74524 SHA512 eb6774d11be4eab81fbe41115d80e5d0d38694b734431d5d6355fcd3e3d8ae5ff4a02114c5dd0dbbc9e1ea5a625e9ac2b6b91e82f6e017b4376e4ca8d56cfec7
DIST Nikola-8.1.0.tar.gz 4298799 BLAKE2B 568b6b39506ab78c84bdb5fc1bf66829a714d41e1c88afe40236e915a801ce8214e7913ecfda7816d11af17beb9bdb54a0c60a88ef72ce53f7bdac91d057489d SHA512 b88fdf4848314e6428b7f3c4a891aefe682f1ae6a2cdc8da25de1d6af839f5d6f3410e23d90b76094f082aebe15d7e51b2c9cd079d017960bb979503d62a4b68
DIST Nikola-8.1.1.tar.gz 4299903 BLAKE2B 75997604e21484bcaab26afa056c3c82f5d19c810e8a388af07aa3c10f8bd341e912c089af5d3aeda51748b6ec17ee07a7c577d5df1a801b032b0bd100188a9a SHA512 a833cb7687077266a20f7043f99b03391f350b48ceea71250158e760b0e44b603de1d6e398a03ec848483775501ad248b6ac45a23ceb250d120a63f110d482b5
+DIST Nikola-8.1.2.tar.gz 4351283 BLAKE2B 28b4a9905a92ba2714e05aec5854ffbd9bf136e9d31218e032d6697f54b3b2711256b83e74ef6ebd0411fdeb0ac17d6454c52473cb396c029af5086cc085728e SHA512 5f53f4939dddececfaf75922147b18fd08434242373d3f4a54e300475adf274b716cdc6e485e6703bdb17fe038656a8c4ac9b260b4ddd47c252a645c3d26a30a
diff --git a/www-apps/nikola/nikola-8.1.2.ebuild b/www-apps/nikola/nikola-8.1.2.ebuild
new file mode 100644
index 000000000000..8abf4ceff6cf
--- /dev/null
+++ b/www-apps/nikola/nikola-8.1.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+MY_PN="Nikola"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A static website and blog generator"
+HOMEPAGE="https://getnikola.com/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT Apache-2.0 CC0-1.0 public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="assets charts hyphenation ipython jinja server watchdog webmedia"
+REQUIRED_USE="server? ( watchdog )"
+RESTRICT="test" # needs coveralls
+
+DEPEND=">=dev-python/docutils-0.13[${PYTHON_USEDEP}]" # needs rst2man to build manpage
+RDEPEND="${DEPEND}
+ >=dev-python/Babel-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/blinker-1.3[${PYTHON_USEDEP}]
+ >=dev-python/doit-0.32[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.3.5[${PYTHON_USEDEP}]
+ >=dev-python/mako-1.0[${PYTHON_USEDEP}]
+ >=dev-python/markdown-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/natsort-3.5.2[${PYTHON_USEDEP}]
+ >=dev-python/piexif-1.0.3[${PYTHON_USEDEP}]
+ >=dev-python/pygments-1.6[${PYTHON_USEDEP}]
+ >=dev-python/PyRSS2Gen-1.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/unidecode-0.04.16[${PYTHON_USEDEP}]
+ >=dev-python/yapsy-1.11.223[${PYTHON_USEDEP}]
+ dev-python/pillow[jpeg,${PYTHON_USEDEP}]
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ assets? ( >=dev-python/webassets-0.10.1[${PYTHON_USEDEP}] )
+ charts? ( >=dev-python/pygal-2.0.1[${PYTHON_USEDEP}] )
+ hyphenation? ( >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}] )
+ ipython? ( >=dev-python/ipython-2.0.0[notebook,${PYTHON_USEDEP}] )
+ jinja? ( >=dev-python/jinja-2.7.2[${PYTHON_USEDEP}] )
+ server? ( dev-python/aiohttp[${PYTHON_USEDEP}] )
+ watchdog? ( >=dev-python/watchdog-0.8.3[${PYTHON_USEDEP}] )
+ webmedia? ( >=dev-python/micawber-0.3.0[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ distutils-r1_src_install
+
+ # hackish way to remove docs that ended up in the wrong place
+ rm -rv "${ED}/usr/share/doc/${PN}" || die
+
+ dodoc AUTHORS.txt CHANGES.txt README.rst docs/*.rst
+ gunzip "${ED}/usr/share/man/man1/${PN}.1.gz" || die
+}