summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2021-06-03 08:55:35 +0200
committerSam James <sam@gentoo.org>2021-06-21 23:30:01 +0100
commit414ae1cb1a4f9159bc0af30d9e106655f900c8ae (patch)
tree11bba6d5ff2c1497030ded2b668b1d487d4b7f35 /www-apps
parentmedia-fonts/cascadia-code: Version bump 2105.24 (diff)
downloadgentoo-414ae1cb1a4f9159bc0af30d9e106655f900c8ae.tar.gz
gentoo-414ae1cb1a4f9159bc0af30d9e106655f900c8ae.tar.bz2
gentoo-414ae1cb1a4f9159bc0af30d9e106655f900c8ae.zip
www-apps/gitea: update service file for newer postgresql
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Pierre-Olivier Mercier <nemunaire@nemunai.re> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gitea/files/gitea.service-r334
-rw-r--r--www-apps/gitea/gitea-9999.ebuild4
2 files changed, 36 insertions, 2 deletions
diff --git a/www-apps/gitea/files/gitea.service-r3 b/www-apps/gitea/files/gitea.service-r3
new file mode 100644
index 000000000000..0867ba637824
--- /dev/null
+++ b/www-apps/gitea/files/gitea.service-r3
@@ -0,0 +1,34 @@
+[Unit]
+Description=Gitea service
+Documentation=https://docs.gitea.io/
+
+AssertPathIsDirectory=/var/lib/gitea
+AssertPathIsReadWrite=/var/lib/gitea
+
+After=network.target
+Requires=network.target
+After=mysqld.service
+After=postgresql-9.5.service
+After=postgresql-9.6.service
+After=postgresql-10.service
+After=postgresql-11.service
+After=postgresql-12.service
+After=postgresql-13.service
+After=postgresql-14.service
+After=memcached.service
+After=redis.service
+
+[Service]
+User=git
+Group=git
+
+Environment="GITEA_WORK_DIR=/var/lib/gitea" "GITEA_CUSTOM=/var/lib/gitea/custom"
+WorkingDirectory=/var/lib/gitea
+ExecStart=/usr/bin/gitea web --config /etc/gitea/app.ini
+
+Restart=always
+PrivateTmp=true
+Nice=5
+
+[Install]
+WantedBy=multi-user.target
diff --git a/www-apps/gitea/gitea-9999.ebuild b/www-apps/gitea/gitea-9999.ebuild
index b975338d0ffb..6a4eaea9959b 100644
--- a/www-apps/gitea/gitea-9999.ebuild
+++ b/www-apps/gitea/gitea-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -101,7 +101,7 @@ src_install() {
newtmpfiles - gitea.conf <<-EOF
d /run/gitea 0755 git git
EOF
- systemd_newunit "${FILESDIR}"/gitea.service-r2 gitea.service
+ systemd_newunit "${FILESDIR}"/gitea.service-r3 gitea.service
insinto /etc/gitea
newins custom/conf/app.example.ini app.ini