summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2018-09-27 14:46:22 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-09-27 15:14:08 +0200
commit49fdb254666ba1719b9a1ccd1b2641d23b3a2d01 (patch)
treea0832c2b298636bc7684f4f3fe8c04593b45fc95 /www-apps
parentprofiles: remove dev-python/scrapy obsolete last-rites mask (diff)
downloadgentoo-49fdb254666ba1719b9a1ccd1b2641d23b3a2d01.tar.gz
gentoo-49fdb254666ba1719b9a1ccd1b2641d23b3a2d01.tar.bz2
gentoo-49fdb254666ba1719b9a1ccd1b2641d23b3a2d01.zip
www-apps/nextcloud: 14.0.1 bump
Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/nextcloud/Manifest1
-rw-r--r--www-apps/nextcloud/nextcloud-14.0.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/www-apps/nextcloud/Manifest b/www-apps/nextcloud/Manifest
index 2e6739f8e9a3..dc12f0b9ee81 100644
--- a/www-apps/nextcloud/Manifest
+++ b/www-apps/nextcloud/Manifest
@@ -3,3 +3,4 @@ DIST nextcloud-12.0.11.tar.bz2 45123785 BLAKE2B 3d1f9131ff89d348dd18c0f7de284b13
DIST nextcloud-13.0.5.tar.bz2 44792418 BLAKE2B 0582b36a078ccea7a2b482e8be213f0102fff2d60f0b92736d7c488498cf8ae4b75ea6a9e5c14cd0d71f2b3ad9d0ff9b6a2fba7b809bcc89e2287c7801e26a49 SHA512 5456f95d3835e0c9fcf015453e1f6e75ba6f5c0266d8951596fad7d3bf06230199a22e5869bc616581410db0ed831a5cdec123a9d2955898a837614a2bfff32c
DIST nextcloud-13.0.6.tar.bz2 44769940 BLAKE2B e9c227d64a23dbd677326f528cc268842403c6d51514e8b0d5d446ca5e91fd49910777b6cc7d7bbf0e7f6e1c422fed390cd38506edde019dc5a1955d94757102 SHA512 cbecd5dc98c96f28cbefe6b25e51f4be4583004841eb38d32a3261ed01f906590e16053dd7d8e31589a2288eafd368a47e280d511ee8c994886b4ea892f535ff
DIST nextcloud-14.0.0.tar.bz2 49762528 BLAKE2B 4c5bbddda0d93504b3530ac0a69511b66faba5d64014a372cd411b9807ca931de484f0db74823534fe97ad5beee25d8c3a0eb001e25a208983b7f13545bd1af4 SHA512 8028f46a6b45834f411ff0942dfc41b72d41d356d01136c74c82fabe1247cd5e62e3b57a298b706a02eb27fabc03790a6ec6a8618b70f2016ae756cf8b523014
+DIST nextcloud-14.0.1.tar.bz2 49761953 BLAKE2B bd7886defeee82d28cbe28548a015cd64bac7d15a3f4d1a6c458f25b87d07370537c26a432c3abf32c574f6b202f15a2cd6a5f1fbbb40bd50b4bd94132154619 SHA512 2d74ac3806372f86020f586f33bde6e4b7694f6dca38a49eaba8955c2108b034e62042e4fa166b3b8e2ecf979c4130674408c4500c461637037a9d4a55fc5465
diff --git a/www-apps/nextcloud/nextcloud-14.0.1.ebuild b/www-apps/nextcloud/nextcloud-14.0.1.ebuild
new file mode 100644
index 000000000000..b6bf2a09eba7
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-14.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="http://nextcloud.com"
+SRC_URI="http://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+curl mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="dev-lang/php[curl?,filter,gd,hash,json,mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_src_install
+}