summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-10 02:07:37 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-10 02:07:37 +0200
commit4ab982611b81ffd8406caf9407842ded4887e347 (patch)
tree75f1764381c1145bdd1629cb50c9a5b84ef3c878 /www-apps
parentnet-misc/radvd: drop old version (diff)
downloadgentoo-4ab982611b81ffd8406caf9407842ded4887e347.tar.gz
gentoo-4ab982611b81ffd8406caf9407842ded4887e347.tar.bz2
gentoo-4ab982611b81ffd8406caf9407842ded4887e347.zip
www-apps/icingaweb2: migrate to GLEP 81
Also migrated to EAPI 7 and dropped old nonexistent PHP versions in tree. Closes: https://bugs.gentoo.org/781593 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.8.2-r1.ebuild77
-rw-r--r--www-apps/icingaweb2/icingaweb2-9999.ebuild26
2 files changed, 89 insertions, 14 deletions
diff --git a/www-apps/icingaweb2/icingaweb2-2.8.2-r1.ebuild b/www-apps/icingaweb2/icingaweb2-2.8.2-r1.ebuild
new file mode 100644
index 000000000000..cffc856a67d8
--- /dev/null
+++ b/www-apps/icingaweb2/icingaweb2-2.8.2-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit depend.apache multilib
+
+DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
+HOMEPAGE="http://www.icinga.org/"
+
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="amd64 x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apache2 apache2-server fpm ldap mysql nginx pdf postgres"
+REQUIRED_USE="( ^^ ( apache2-server nginx ) ) apache2? ( apache2-server )"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ dev-php/pecl-imagick
+ pdf? ( media-gfx/imagemagick[png] )
+ apache2-server? ( >=www-servers/apache-2.4.0 )
+ nginx? ( >=www-servers/nginx-1.7.0:* )
+ || (
+ dev-lang/php:7.3[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.4[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ acct-group/icingacmd
+ acct-group/icingaweb2"
+RDEPEND="${DEPEND}"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+
+ use nginx && usermod -a -G icingacmd,icingaweb2 nginx || die
+ use apache2 && usermod -a -G icingacmd,icingaweb2 apache || die
+}
+
+pkg_config() {
+ if [[ -d /etc/icingaweb2 ]] ; then
+ einfo "Updating existing installation ..."
+ else
+ einfo "Running first time setup ..."
+ einfo "Creating configuration directory ..."
+ /usr/share/${PN}/bin/icingacli setup config directory || die
+ einfo "Creating authentication token for web setup ..."
+ /usr/share/${PN}/bin/icingacli setup token create || die
+ if use apache2 ; then
+ einfo "The following might be useful for your Apache2 configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public || die
+ fi
+ if use nginx ; then
+ einfo "The following might be useful for your NGinx configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public || die
+ fi
+ fi
+ einfo "All done."
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r "${S}"/*
+ fperms -R a+rX "/usr/share/${PN}/public/"
+ fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
+}
+
+pkg_postinst() {
+ einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
+}
diff --git a/www-apps/icingaweb2/icingaweb2-9999.ebuild b/www-apps/icingaweb2/icingaweb2-9999.ebuild
index 70eeef62f5d0..f0757e1ba820 100644
--- a/www-apps/icingaweb2/icingaweb2-9999.ebuild
+++ b/www-apps/icingaweb2/icingaweb2-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
-inherit depend.apache multilib user
+inherit depend.apache multilib
DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
HOMEPAGE="http://www.icinga.org/"
@@ -28,11 +28,11 @@ DEPEND=">=net-analyzer/icinga2-2.1.1
apache2-server? ( >=www-servers/apache-2.4.0 )
nginx? ( >=www-servers/nginx-1.7.0:* )
|| (
- dev-lang/php:5.6[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
- dev-lang/php:7.1[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
- dev-lang/php:7.2[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
dev-lang/php:7.3[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
- )"
+ dev-lang/php:7.4[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ acct-group/icingacmd
+ acct-group/icingaweb2"
RDEPEND="${DEPEND}"
want_apache2
@@ -40,10 +40,8 @@ want_apache2
pkg_setup() {
depend.apache_pkg_setup
- enewgroup icingaweb2
- enewgroup icingacmd
- use nginx && usermod -a -G icingacmd,icingaweb2 nginx
- use apache2 && usermod -a -G icingacmd,icingaweb2 apache
+ use nginx && usermod -a -G icingacmd,icingaweb2 nginx || die
+ use apache2 && usermod -a -G icingacmd,icingaweb2 apache || die
}
pkg_config() {
@@ -52,16 +50,16 @@ pkg_config() {
else
einfo "Running first time setup ..."
einfo "Creating configuration directory ..."
- /usr/share/${PN}/bin/icingacli setup config directory
+ /usr/share/${PN}/bin/icingacli setup config directory || die
einfo "Creating authentication token for web setup ..."
- /usr/share/${PN}/bin/icingacli setup token create
+ /usr/share/${PN}/bin/icingacli setup token create || die
if use apache2 ; then
einfo "The following might be useful for your Apache2 configuration:"
- /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
+ /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public || die
fi
if use nginx ; then
einfo "The following might be useful for your NGinx configuration:"
- /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
+ /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public || die
fi
fi
einfo "All done."