summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-05-13 10:10:13 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-05-13 10:10:34 +0200
commit5951d97e6e43c8310cbf07d8b76e1b4d02fc0051 (patch)
treed32f14bad12fd6b541cf41c571acdd45eec46ccc /www-apps
parentdev-ruby/date_validator: add 0.11.0 (diff)
downloadgentoo-5951d97e6e43c8310cbf07d8b76e1b4d02fc0051.tar.gz
gentoo-5951d97e6e43c8310cbf07d8b76e1b4d02fc0051.tar.bz2
gentoo-5951d97e6e43c8310cbf07d8b76e1b4d02fc0051.zip
www-apps/postfixadmin: bump to 3.3.9
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/postfixadmin/Manifest1
-rw-r--r--www-apps/postfixadmin/postfixadmin-3.3.9.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/www-apps/postfixadmin/Manifest b/www-apps/postfixadmin/Manifest
index fe3753e3de82..8cc4e8135a4d 100644
--- a/www-apps/postfixadmin/Manifest
+++ b/www-apps/postfixadmin/Manifest
@@ -1 +1,2 @@
DIST postfixadmin-3.3.8.tar.gz 1865581 BLAKE2B f8b29248e839d973fd72647747e0bba7452676543f44310f12203d5e64e83222a3992e282a3898fa077dc54100b3446e4d1cded56cd464d72b2997ce34f064db SHA512 bfe5d874083568f1e8b1830394338d2aa29e39e30834d4c8c728836495f12f6d49c65b83b1fae1fce20e7456afaef0058320033866b720a5858911ceec22a022
+DIST postfixadmin-3.3.9.tar.gz 1866167 BLAKE2B 28546631dce340d3c1128b525de1c33e9e3aa23cd557e6c8f7e9b26f97aedba67f2e5f3ea351e0db2d79e068e16cfa1672cbe3e6abbffd19e5009e2a9df84523 SHA512 791b05df34a4f2eec01fe6f6b9038a6630cd60c42e1f2e725fe3d033a692b77d2d688858b947c53d1ce48258c7c87a2e3fb31356e553632b88149d5a29bfa70e
diff --git a/www-apps/postfixadmin/postfixadmin-3.3.9.ebuild b/www-apps/postfixadmin/postfixadmin-3.3.9.ebuild
new file mode 100644
index 000000000000..0df1b6d26679
--- /dev/null
+++ b/www-apps/postfixadmin/postfixadmin-3.3.9.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit user webapp
+
+DESCRIPTION="Web Based Management tool for Postfix style virtual domains and users"
+HOMEPAGE="http://postfixadmin.sourceforge.net"
+SRC_URI="https://github.com/postfixadmin/postfixadmin/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+mysql postgres +vacation"
+REQUIRED_USE="|| ( mysql postgres )"
+
+DEPEND="
+ dev-lang/php:*[unicode,imap,postgres?]
+ vacation? (
+ dev-perl/DBI
+ dev-perl/Email-Sender
+ dev-perl/Email-Valid
+ dev-perl/Log-Dispatch
+ dev-perl/Log-Log4perl
+ dev-perl/MIME-Charset
+ dev-perl/MIME-EncWords
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )
+ )
+"
+RDEPEND="${DEPEND}
+ virtual/httpd-php
+ mysql? ( || ( dev-lang/php[mysqli] dev-lang/php[mysql] ) )"
+
+S="${WORKDIR}/${PN}-${P}"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if use vacation; then
+ enewgroup vacation
+ enewuser vacation -1 -1 -1 vacation
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ if use vacation; then
+ insinto /var/spool/vacation
+ newins VIRTUAL_VACATION/vacation.pl vacation.pl-${SLOT}
+ fowners vacation:vacation /var/spool/vacation/vacation.pl-${SLOT}
+ fperms 770 /var/spool/vacation/vacation.pl-${SLOT}
+ dodoc VIRTUAL_VACATION/FILTER_README
+ newdoc VIRTUAL_VACATION/INSTALL.md VIRTUAL_VACATION_INSTALL.md
+ rm -r VIRTUAL_VACATION/{vacation.pl,INSTALL.md,tests,FILTER_README} || die
+ fi
+
+ docinto /usr/share/doc/${PF}/
+ dodoc -r ADDITIONS
+
+ local docs="DOCUMENTS/*.txt INSTALL.TXT CHANGELOG.TXT"
+ dodoc ${docs}
+
+ rm -rf ${docs} DOCUMENTS/ GPL-LICENSE.TXT LICENSE.TXT debian/ tests/ ADDITIONS/
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config.inc.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-2.3.txt
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ einfo "Please note that if upgrading from version prior to 3.3.0,"
+ einfo "existing setup_password will no longer work and you will"
+ einfo "need to generate new one. See instructions in setup.php."
+
+ if use vacation; then
+ # portage does not update owners of directories (feature :)
+ chown vacation:vacation "${ROOT}"/var/spool/vacation/
+ einfo
+ einfo "/var/spool/vacation/vacation.pl symlink was updated to:"
+ einfo "/var/spool/vacation/vacation.pl-${SLOT}"
+ ln -sf "${ROOT}"/var/spool/vacation/vacation.pl{-${SLOT},} || die
+ fi
+}
+
+pkg_postrm() {
+ # Make sure we don't leave broken vacation.pl symlink
+ find -L "${ROOT}"/var/spool/vacation/ -type l -delete
+ local shopt_save=$(shopt -p nullglob)
+ shopt -s nullglob
+ local vacation=( "${ROOT}"/var/spool/vacation/vacation.pl-* )
+ ${shopt_save}
+ if [[ ! -e "${ROOT}"/var/spool/vacation/vacation.pl && -n ${vacation[@]} ]]; then
+ ln -s "${vacation[-1]}" "${ROOT}"/var/spool/vacation/vacation.pl || die
+ ewarn "/var/spool/vacation/vacation.pl was updated to point on most"
+ ewarn "recent verion, but please, do your own checks"
+ fi
+}