summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2023-05-08 21:26:33 -0400
committerKenton Groombridge <concord@gentoo.org>2023-05-08 21:26:33 -0400
commit6769429b2e5fdca5a3198eb7b452c9d14be5792b (patch)
tree0e1d20b3655c153463d013db9a698f223bff1f71 /www-apps
parentdev-util/android-studio: add 2022.3.1.13, drop 2022.3.1.12 (diff)
downloadgentoo-6769429b2e5fdca5a3198eb7b452c9d14be5792b.tar.gz
gentoo-6769429b2e5fdca5a3198eb7b452c9d14be5792b.tar.bz2
gentoo-6769429b2e5fdca5a3198eb7b452c9d14be5792b.zip
www-apps/miniflux: add 2.0.44
Signed-off-by: Kenton Groombridge <concord@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/miniflux/Manifest2
-rw-r--r--www-apps/miniflux/miniflux-2.0.44.ebuild107
2 files changed, 109 insertions, 0 deletions
diff --git a/www-apps/miniflux/Manifest b/www-apps/miniflux/Manifest
index 0a0264103333..f7fc86caea62 100644
--- a/www-apps/miniflux/Manifest
+++ b/www-apps/miniflux/Manifest
@@ -1,2 +1,4 @@
DIST miniflux-2.0.43-deps.tar.xz 38360844 BLAKE2B 4b3a51acf0f319a99ab5b8a03dd32cae54d73ad7c35de6659cc77b1e227551f444280f670eddb4f7580685dd44bce7fedc0af31f5a5dafbbf0f7bc4c17077910 SHA512 e41a9a112ab0dfe0b7cd3670ceecf88aed77b1a908413af09e56e48f0570a34a0f0055e13fc5244b2052db4e79b28f6ce27564f29273d0a333fbbce18fd6d7ec
DIST miniflux-2.0.43.tar.gz 586624 BLAKE2B 33245f2da209c7cb7a647b3bc2f571e9596467c28779038384e6501e8c966b95f087cd0da4feb78cec254b1efbcd3a8dcdfaeb089fc440d1bab1c5ca086db9b6 SHA512 fd09a2ecb00173a6b2f0f7438ff677af5b5c1b616f1a44b138478452a78e0a925f802eeda0e8072211ed2dbbc59eeeee7079b13fbb086663ceebd3d2e06dceca
+DIST miniflux-2.0.44-deps.tar.xz 38348604 BLAKE2B 6709ad503ec64ea64fb35624ff0f6d641a6ccac78d52469a0a6c6e905e505c78866603f310e82c5ff7e1bcd7656cb0d9b3516bb9d0822d7a3f8bbbdadaff0aca SHA512 f463a5a63c5611e8b90ebf15127e05e2df878bb6c49a347f182c5df40feea7e0b2fa21cff4c92b6a99f82e8be4cbd113999f0b3ba6187897af9fad49c9a2aecb
+DIST miniflux-2.0.44.tar.gz 574354 BLAKE2B a0c29cb88d88584619e6890a01af15d7b7d9a6ab230b60d76c01d95e82c5ef665aeb19f120180bc328ef3847cae2c87096a096e8f0d0455f7694539556453e5b SHA512 6c1057bcb4daf3110a8885363e2386c6d68776e917f0277299ab94fb46553a8a1b3acf4a2893ab03d30e2b3c26118257e68a7f33d5d436884bfafd8e06fc5e0a
diff --git a/www-apps/miniflux/miniflux-2.0.44.ebuild b/www-apps/miniflux/miniflux-2.0.44.ebuild
new file mode 100644
index 000000000000..b2e63151f22c
--- /dev/null
+++ b/www-apps/miniflux/miniflux-2.0.44.ebuild
@@ -0,0 +1,107 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd
+
+# Get with 'git rev-parse --short HEAD'
+MY_GIT_COMMIT="4c0c6581"
+
+DESCRIPTION="Minimalist and opinionated feed reader"
+HOMEPAGE="https://miniflux.app https://github.com/miniflux/v2"
+SRC_URI="https://github.com/${PN}/v2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~concord/distfiles/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv"
+
+RESTRICT="test" # requires network access
+
+DEPEND="acct-user/miniflux"
+RDEPEND="${DEPEND}
+ >=dev-db/postgresql-9.5
+"
+
+S="${WORKDIR}/v2-${PV}"
+
+src_compile() {
+ ego build -ldflags="
+ -s -w
+ -X 'miniflux.app/version.Version=${PV}'
+ -X 'miniflux.app/version.Commit=${MY_GIT_COMMIT}'
+ -X 'miniflux.app/version.BuildDate=$(date +%FT%T%z)'
+ " -o miniflux main.go
+}
+
+src_install() {
+ dobin miniflux
+
+ insinto /etc
+ doins "${FILESDIR}/${PN}.conf"
+
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ newinitd "${FILESDIR}/${PN}.initd-r1" ${PN}
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ fowners miniflux:root /etc/${PN}.conf
+ fperms o-rwx /etc/${PN}.conf
+
+ local DOCS=(
+ ChangeLog
+ README.md
+ "${FILESDIR}"/README.gentoo
+ )
+
+ # Makefile has no install target, so call einstalldocs directly
+ einstalldocs
+
+ doman "${PN}".1
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+
+ echo
+ elog "Before using miniflux, you must first create and initialize the database"
+ elog "and enable the hstore extension for it."
+ elog ""
+ elog "Afterwards, create your first admin user by running:"
+ elog " miniflux -create-admin"
+ else
+ # This is an existing installation
+
+ echo
+ elog "If you are upgrading from a previous version, schema migrations must be performed."
+ elog "To perform the migrations, stop the daemon, backup your database, and run:"
+ elog " emerge --config =${PF}"
+ fi
+
+ echo
+ elog "Please read"
+ elog ""
+ elog " ${EPREFIX}/usr/share/doc/${PF}/README.gentoo*"
+ elog ""
+ elog "for more information."
+}
+
+pkg_config() {
+ # To be safe, avoid doing migrations if miniflux is running
+ if pgrep miniflux; then
+ die "miniflux appears to be running, refusing to continue."
+ fi
+
+ # Extract the database URL variable instead of just sourcing the config file
+ # because miniflux itself may interpret quotes as part of the URL
+ local DATABASE_URL="$(sed -n 's/^DATABASE_URL=\(.*\)/\1/p' "${EROOT}/etc/${PN}.conf")"
+ [[ -n "${DATABASE_URL}" ]] || die "Failed getting DATABASE_URL from config file"
+
+ DATABASE_URL="${DATABASE_URL}" "${EROOT}"/usr/bin/miniflux -migrate \
+ || die "miniflux -migrate failed. Please check the above output for errors."
+
+ echo
+ elog "Database migrations complete."
+}