summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-12-12 19:04:30 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-12-12 19:05:09 -0600
commit72db0b7cc75bfe807aab89aacbc6e41ce8e42cde (patch)
treecbdb5edb302bb53328b67614a7df46c47a43f2cf /www-apps
parentdev-python/sqlalchemy: Stabilize 1.3.17 s390, #731602 (diff)
downloadgentoo-72db0b7cc75bfe807aab89aacbc6e41ce8e42cde.tar.gz
gentoo-72db0b7cc75bfe807aab89aacbc6e41ce8e42cde.tar.bz2
gentoo-72db0b7cc75bfe807aab89aacbc6e41ce8e42cde.zip
www-apps/novnc: 1.2.0 bump with adding py38
Closes: https://bugs.gentoo.org/759562 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/novnc/Manifest1
-rw-r--r--www-apps/novnc/novnc-1.2.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/www-apps/novnc/Manifest b/www-apps/novnc/Manifest
index a8f2de942996..14b6c5e328c6 100644
--- a/www-apps/novnc/Manifest
+++ b/www-apps/novnc/Manifest
@@ -1,2 +1,3 @@
DIST novnc-1.0.0.tar.gz 1551574 BLAKE2B 58bd63eb0480b3f20ed16907725e0abcf8c699671614dc195f46a363d6ab9cdb5b0b033ba0ba16bbe39b16437fb94f64a741acd69d1c3c3957a0e60353d78a89 SHA512 97a86be5f10f382e2ed641360f5f6c3b22998f68f980c78138aca900ef6a011c1f6aa9cbdd8cd07afd4884e8c65af30d65487e87bb34e524c10f16cf4cd116a3
DIST novnc-1.1.0.tar.gz 1034997 BLAKE2B 0cb920cac99c3567cbf1c6a58e12649d4bca211d552a472a73ac1089d7c8a18d9478dcfeb558b6302c0c74d321b62575c35a492b02717dc4721b6a9b42f54415 SHA512 9c736912f5a3051027efe779fc64b182f523b9378ff412d78202e52665772678846d97fe3cc5ac18f5c29dd83d5ff2a2dd915e5eadf9af3573fe871db2e7821e
+DIST novnc-1.2.0.tar.gz 1356408 BLAKE2B a84b767afcdaa641a21943d19ac93c9200074c24c83c899fe2452a82eef526ecd74de92da47b3caa85abe9d51f2fb8d5078f3bf66c0868a241218d22a9088239 SHA512 461490da7bb983e9c94b8ce39f8455ee6609b5a9df8d88254bcc37ebaa5153f5ee9db6afbd88b51762d6d55661bc5cde6fbe70616597583bfce1203e337adf75
diff --git a/www-apps/novnc/novnc-1.2.0.ebuild b/www-apps/novnc/novnc-1.2.0.ebuild
new file mode 100644
index 000000000000..efb86e05f7cc
--- /dev/null
+++ b/www-apps/novnc/novnc-1.2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="noVNC is a VNC client implemented using HTML5 technologies"
+HOMEPAGE="https://kanaka.github.com/noVNC/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kanaka/noVNC.git"
+else
+ SRC_URI="https://github.com/kanaka/noVNC/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/noVNC-${PV}"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/websockify[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+
+python_compile() {
+ :
+}
+
+src_install() {
+ exeinto /usr/share/novnc/utils
+ for f in utils/*; do
+ [[ ! f = utils/README.md ]] && doexe $f
+ done
+
+ dodoc README.md LICENSE.txt
+
+ insinto /usr/share/novnc
+ doins -r vnc.html vnc_lite.html app/ core/ vendor/
+ dosym vnc_lite.html /usr/share/novnc/vnc_auto.html # for compat
+ dosym ../share/novnc/utils/launch.sh /usr/bin/novnc
+}