summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-20 10:40:29 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-20 10:40:47 -0500
commit7427922822ae6c8dc14ec001d6f76e77339e2b70 (patch)
tree49f95df7b4ac1e525f96cafd6d1d2a9b328ed577 /www-apps
parentnet-analyzer/netdata: add lto USE flag (diff)
downloadgentoo-7427922822ae6c8dc14ec001d6f76e77339e2b70.tar.gz
gentoo-7427922822ae6c8dc14ec001d6f76e77339e2b70.tar.bz2
gentoo-7427922822ae6c8dc14ec001d6f76e77339e2b70.zip
www-apps/icingaweb2: remove 2.7
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/icingaweb2/Manifest1
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.7.4.ebuild79
2 files changed, 0 insertions, 80 deletions
diff --git a/www-apps/icingaweb2/Manifest b/www-apps/icingaweb2/Manifest
index dfb00b7ea2ee..69e960c2ff60 100644
--- a/www-apps/icingaweb2/Manifest
+++ b/www-apps/icingaweb2/Manifest
@@ -1,2 +1 @@
-DIST icingaweb2-2.7.4.tar.gz 8388685 BLAKE2B b179820828631bc65140bfc81908c267fb7ee0b5cd3e1edbafc1edf583718b478061beb66931cdb3ff8b0243d7205600d5549d7db1838650be0cb4fdae0e38bd SHA512 e8864a3aa03b902ba31dcec4c3ef2c87eeab8f885020b6b6b1bd97d90be1e8645c3e56b8e32d42f3379fc43f338c31cb2fb1114a1ef2fd97f33b344068771c78
DIST icingaweb2-2.8.2.tar.gz 8514166 BLAKE2B 7e6a44574999967a6a728c5818999ac6f15234f1cfd1415132e1a8219e897affddd4d4ec488bb90ced82a0ce5403220463ccfa0424014a4c090176d85fd968a9 SHA512 252ecb36751add239897b6344dd622542f892b1850398fe724d0ab91e8d691cefe0b33c727c28aa630c93b76b381aabe69721db034c4de0518f346bbd5b698de
diff --git a/www-apps/icingaweb2/icingaweb2-2.7.4.ebuild b/www-apps/icingaweb2/icingaweb2-2.7.4.ebuild
deleted file mode 100644
index 261a6839860d..000000000000
--- a/www-apps/icingaweb2/icingaweb2-2.7.4.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit depend.apache eutils multilib user
-
-DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
-HOMEPAGE="http://www.icinga.org/"
-
-if [[ ${PV} == *9999 ]];then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Icinga/icingaweb2.git"
- EGIT_BRANCH="master"
-else
- SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
- KEYWORDS="amd64 x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="apache2 apache2-server fpm ldap mysql nginx pdf postgres"
-REQUIRED_USE="( ^^ ( apache2-server nginx ) ) apache2? ( apache2-server )"
-
-DEPEND=">=net-analyzer/icinga2-2.1.1
- dev-php/pecl-imagick
- pdf? ( media-gfx/imagemagick[png] )
- apache2-server? ( >=www-servers/apache-2.4.0 )
- nginx? ( >=www-servers/nginx-1.7.0:* )
- || (
- dev-lang/php:5.6[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
- dev-lang/php:7.1[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
- dev-lang/php:7.2[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
- dev-lang/php:7.3[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
- )"
-RDEPEND="${DEPEND}"
-
-want_apache2
-
-pkg_setup() {
- depend.apache_pkg_setup
-
- enewgroup icingaweb2
- enewgroup icingacmd
- use nginx && usermod -a -G icingacmd,icingaweb2 nginx
- use apache2 && usermod -a -G icingacmd,icingaweb2 apache
-}
-
-pkg_config() {
- if [[ -d /etc/icingaweb2 ]] ; then
- einfo "Updating existing installation ..."
- else
- einfo "Running first time setup ..."
- einfo "Creating configuration directory ..."
- /usr/share/${PN}/bin/icingacli setup config directory
- einfo "Creating authentication token for web setup ..."
- /usr/share/${PN}/bin/icingacli setup token create
- if use apache2 ; then
- einfo "The following might be useful for your Apache2 configuration:"
- /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
- fi
- if use nginx ; then
- einfo "The following might be useful for your NGinx configuration:"
- /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
- fi
- fi
- einfo "All done."
-}
-
-src_install() {
- insinto "/usr/share/${PN}"
- doins -r "${S}"/*
- fperms -R a+rX "/usr/share/${PN}/public/"
- fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
-}
-
-pkg_postinst() {
- einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
-}