summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2019-11-20 15:19:32 -0100
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2019-11-20 15:20:14 -0100
commit86b197b64333c5bc1685738fc4c65a304d89694a (patch)
tree3c4ab800e7a89d82741a7b80dc7f17882e2e45f9 /www-apps
parentmedia-libs/zxing-cpp: 1.0.7 version bump (diff)
downloadgentoo-86b197b64333c5bc1685738fc4c65a304d89694a.tar.gz
gentoo-86b197b64333c5bc1685738fc4c65a304d89694a.tar.bz2
gentoo-86b197b64333c5bc1685738fc4c65a304d89694a.zip
www-apps/drupal: 8.7.10 version bump and clean-ups.
Version bump. Drop the acclerator use flag and deps as xcache is going away. Use dev-lang/php[hash(+)] as hash become required since PHP 7.4. Bug: https://bugs.gentoo.org/688058 Review dev-lang/php deps and fix keywords. Thanks to Brian Evans <grknight@gentoo.org> for the review. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-8.7.10.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index acb096aa96aa..25f2dd2f8209 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,4 +1,5 @@
DIST drupal-7.67.tar.gz 3312764 BLAKE2B bb7f21e80ca192ff3e37f917c1fa43dcd8d3cd8b60ff012d1fe22e279ffd674e08be6aef6328d0c5b7c50a106592bde299300fe9ccb0c4c1ffc1aca57c3ca6ad SHA512 0e4f60010b1395183cea19424e8c2849f93fb7285a081bf7d0c774b8e82f403083533059f58c3831950cc06dfa8117d443db52b66a521301ceac10b1b333aa28
DIST drupal-8.6.16.tar.gz 17151378 BLAKE2B 2bdd14ff7a5f898af2d322a6b2862643899dfbe2ad05c99b85f036161612cccfc2c25105c8eef37311634a2aa03ed792db8de3e625aed5adb94cd8f644557fcb SHA512 34f260d780bce286a0a61b710c340d2622cb857aa92a2bdaad63737303ef2f4f1751edc3f415daaa14b9cb483757e367e639136d03f571cba5165129bba31e12
+DIST drupal-8.7.10.tar.gz 17894144 BLAKE2B cf20860bc11ca65a7ff0808e533f5c3aac39d4f5b0f9052601d1bf510cdc28bb5fca99d14d78badc61158f06742e1fb6addfc4145ad17720095631f7258b0cd7 SHA512 c614a64efd86c529d89f4411d4418731ae85cf0af5a236dd3a475f68dd4d408fb7c6d378477897e2ce68c71cc287f218dab2d45cc3d96967a75a6500e0161716
DIST drupal-8.7.8.tar.gz 17882836 BLAKE2B 8a521c5c615356548eea8a64ee81e31082e3b9c5ed37c66fef7f2f3c426c7339e4848b90306cfccae1005c5c6d8fe8d7964662012da66c9c6754c6052d102173 SHA512 cc68e6318ebc162cd50fe19046a992ae2ca338f9da564a12a88954edb2c0cecaa56b0ded22903f67f305ab1fee48dd8a2bbf8b65a9efda2e1ce50d11b97bab28
DIST drupal-8.7.9.tar.gz 17888541 BLAKE2B 958779c7ae8fa1527ae91d3174c19afc311682c4bbceacd6592796abf781b4e52b0e1ad5f020bd79d2d55508a954bf969076121d703f69959afd6b7a87b6e9b9 SHA512 6181af0e096974e1eb7d5a046d8f34372725891937fcce7d9c0b6b1dffebc0d6fc3519f16df6edbea35c081231c9f8411166f66586cb932de1e6aadebfa78cb1
diff --git a/www-apps/drupal/drupal-8.7.10.ebuild b/www-apps/drupal/drupal-8.7.10.ebuild
new file mode 100644
index 000000000000..945c43dcf134
--- /dev/null
+++ b/www-apps/drupal/drupal-8.7.10.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+ virtual/httpd-php
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}