summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-08-11 09:32:27 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-08-11 09:35:23 -0500
commit88044f6a1469458f0b533fe84a2facaff5e3c0b2 (patch)
tree4f3af27eaef63512b979faf7e6395559d50e2cb3 /www-apps
parentgui-apps/mako: 1.6 stable amd64 arm64 x86 (diff)
downloadgentoo-88044f6a1469458f0b533fe84a2facaff5e3c0b2.tar.gz
gentoo-88044f6a1469458f0b533fe84a2facaff5e3c0b2.tar.bz2
gentoo-88044f6a1469458f0b533fe84a2facaff5e3c0b2.zip
www-apps/icingaweb2: 2.9.3 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/icingaweb2/Manifest1
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.9.3.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/www-apps/icingaweb2/Manifest b/www-apps/icingaweb2/Manifest
index 28aabbaeec3e..e89dde707b21 100644
--- a/www-apps/icingaweb2/Manifest
+++ b/www-apps/icingaweb2/Manifest
@@ -3,3 +3,4 @@ DIST icingaweb2-2.8.3.tar.gz 8514052 BLAKE2B 507753833ed8a0de816651f3fdb06f3fdf0
DIST icingaweb2-2.8.4.tar.gz 8514585 BLAKE2B 1c331d45152a94dcaf21509e36ecd9c90c840f41bf14d102910e65fce28994bb7db3319c39e5d5740638a673c74b84b54d803b97d91cb8968260174b2437a7ca SHA512 7f136f7901db8398fab85fef079d4e5af1662c13c5c107d3c1c10e022186bdca29d3b144f937e40e470975b97bd98215ec3e0c7f2b6127a6a74143fbe0e1882c
DIST icingaweb2-2.9.0.tar.gz 10895850 BLAKE2B cf0f1375e3eb29ddbbf6691afd1c240ae1431b7dd82bd591dd3fe135602d1eabc418c6279fe7bd8f8e519f264b69a9da8bb1d09d286f37aa2f7e5ed21ddacd5a SHA512 d8f2817c025160cd8f59f33d678ca6eea9b893b80ca5c45c719d8778269da46322e720a1c73d7bcd7be73a07f08dbe279ffb78220f2a6c00f7e07e9f0f88d4d4
DIST icingaweb2-2.9.2.tar.gz 12304718 BLAKE2B ba5d0872318a504d25b614825008e90cabd4680b30686d90ad438408e4a248f9dc2ef9410c5405da7efac949c6c41d89c64604b18c6d86f9ba479c99a8daff9a SHA512 67268544db0c267f9522b2105db52d87967835279eb621b79827b7b1b80a327b69348c849e4d3716a9cd26dfaef31a06b5ba125d30a48c3f5686dcf4c7a7a959
+DIST icingaweb2-2.9.3.tar.gz 12307606 BLAKE2B fddd72823674ae64191bf55f0dc378ef50cd7849a18199310fbe25446aff3e0c325b20aa0244c751b07852d3cca81ecdaba02c3250eb77b36645829d7da61377 SHA512 46ae2790743fb5e0a80861da522cfa2783d181ec056135e97949fffbc3ca821f778033db9e276e824430a6b7a1dd842f387b599fa70072e63fb6ebd74dd2bfc0
diff --git a/www-apps/icingaweb2/icingaweb2-2.9.3.ebuild b/www-apps/icingaweb2/icingaweb2-2.9.3.ebuild
new file mode 100644
index 000000000000..84db9d6e0716
--- /dev/null
+++ b/www-apps/icingaweb2/icingaweb2-2.9.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit depend.apache multilib
+
+DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
+HOMEPAGE="http://www.icinga.org/"
+
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apache2 apache2-server fpm ldap mysql nginx pdf postgres"
+REQUIRED_USE="( ^^ ( apache2-server nginx ) ) apache2? ( apache2-server )"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ dev-php/pecl-imagick
+ pdf? ( media-gfx/imagemagick[png] )
+ apache2-server? ( >=www-servers/apache-2.4.0 )
+ nginx? ( >=www-servers/nginx-1.7.0:* )
+ || (
+ dev-lang/php:7.3[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.4[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:8.0[apache2?,cli,fpm?,gd,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ acct-group/icingacmd
+ acct-group/icingaweb2"
+RDEPEND="${DEPEND}"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+
+ use nginx && usermod -a -G icingacmd,icingaweb2 nginx
+ use apache2 && usermod -a -G icingacmd,icingaweb2 apache
+}
+
+pkg_config() {
+ if [[ -d /etc/icingaweb2 ]] ; then
+ einfo "Updating existing installation ..."
+ else
+ einfo "Running first time setup ..."
+ einfo "Creating configuration directory ..."
+ /usr/share/${PN}/bin/icingacli setup config directory
+ einfo "Creating authentication token for web setup ..."
+ /usr/share/${PN}/bin/icingacli setup token create
+ if use apache2 ; then
+ einfo "The following might be useful for your Apache2 configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
+ fi
+ if use nginx ; then
+ einfo "The following might be useful for your NGinx configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
+ fi
+ fi
+ einfo "All done."
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r "${S}"/*
+ fperms -R a+rX "/usr/share/${PN}/public/"
+ fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
+}
+
+pkg_postinst() {
+ einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
+}