summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-10-29 14:29:58 +0100
committerJames Le Cuirot <chewi@gentoo.org>2022-10-29 14:32:31 +0100
commit9b95d5375dc7e9170f893c709eab2b02215f9af6 (patch)
treefbfca99e249d80958560642503cf183e445c3040 /www-apps
parentdev-util/patchelf: Drop old 0.14.5 (diff)
downloadgentoo-9b95d5375dc7e9170f893c709eab2b02215f9af6.tar.gz
gentoo-9b95d5375dc7e9170f893c709eab2b02215f9af6.tar.bz2
gentoo-9b95d5375dc7e9170f893c709eab2b02215f9af6.zip
www-apps/xpra-html5: Version bump to 6.0
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/xpra-html5/Manifest1
-rw-r--r--www-apps/xpra-html5/xpra-html5-6.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/www-apps/xpra-html5/Manifest b/www-apps/xpra-html5/Manifest
index c4f6b2920012..ebb5d888cd27 100644
--- a/www-apps/xpra-html5/Manifest
+++ b/www-apps/xpra-html5/Manifest
@@ -1 +1,2 @@
DIST xpra-html5-5.0.tar.gz 1570694 BLAKE2B aef7b818aa618c143701993627e629884b5e696c7334e6b75701a20028f18aced5e3249505ac031d6cd0a08d79ca2b9728afdb2e90712fcbe45d43d02598f608 SHA512 8318c6dd8f8f53d0a132272c2bb8c69e8ba928f2f267679aee48cec4598faa828788a219dfa342162e1fcf8159bf46b44d50db57180f1aa972edd67fa43e9cd5
+DIST xpra-html5-6.0.tar.gz 1417240 BLAKE2B c887d88c97f4925c511e4120556b98329c205e5fecb8189d615028b4e982d829c9d5649beb646a3f2f0ca42138dd8c26fdb86a2c2c2ee85834e88d14ce8ae1cc SHA512 e5c923df17f25e065ca90499ead4cd33057bf8c2a06aa3b8d4c74e2b3a083b69b525f2dd4d01267168fe5bd8211035067bf952802a64c198dc21106dc7aa384f
diff --git a/www-apps/xpra-html5/xpra-html5-6.0.ebuild b/www-apps/xpra-html5/xpra-html5-6.0.ebuild
new file mode 100644
index 000000000000..5c2270895f63
--- /dev/null
+++ b/www-apps/xpra-html5/xpra-html5-6.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+inherit python-any-r1
+
+DESCRIPTION="HTML5 client to connect to any xpra server"
+HOMEPAGE="https://xpra.org/"
+SRC_URI="https://github.com/Xpra-org/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="brotli +gzip minify"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ brotli? ( app-arch/brotli )
+ minify? ( dev-util/uglifyjs )
+"
+
+src_configure() {
+ cat <<EOF > vcs-info || die
+BRANCH=gentoo
+REVISION=${PR#r}
+LOCAL_MODIFICATIONS=0
+EOF
+}
+
+src_install() {
+ "${PYTHON}" <<EOF || die
+import setup
+setup.set_version("${PV}")
+setup.install_html5(
+ root="${D}",
+ install_dir="${EPREFIX}/usr/share/xpra/www/",
+ config_dir="${EPREFIX}/etc/xpra/html5-client",
+ minifier="$(usex minify uglifyjs copy)",
+ gzip=$(usex gzip True False),
+ brotli=$(usex brotli True False),
+)
+EOF
+}