summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Andrejak <thomas.andrejak@gmail.com>2019-11-07 02:40:36 +0100
committerGöktürk Yüksek <gokturk@gentoo.org>2019-12-24 16:54:51 -0500
commitb96ac1a5c074bdd68204cde4b02fc3abb8efe7c5 (patch)
tree427c8791c38d43caa8b34fb3587080d4b1569ad9 /www-apps
parentdev-python/lark-parser: Add new package (diff)
downloadgentoo-b96ac1a5c074bdd68204cde4b02fc3abb8efe7c5.tar.gz
gentoo-b96ac1a5c074bdd68204cde4b02fc3abb8efe7c5.tar.bz2
gentoo-b96ac1a5c074bdd68204cde4b02fc3abb8efe7c5.zip
www-apps/prewikka: Bump version 5.1
Closes: https://github.com/gentoo/gentoo/pull/13578 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/prewikka/Manifest1
-rw-r--r--www-apps/prewikka/prewikka-5.1.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/www-apps/prewikka/Manifest b/www-apps/prewikka/Manifest
index 1024ef2e42d9..f38c408eb201 100644
--- a/www-apps/prewikka/Manifest
+++ b/www-apps/prewikka/Manifest
@@ -1,3 +1,4 @@
DIST prewikka-3.1.0.tar.gz 1349193 BLAKE2B b87021ecec490b44f080dfd7a29b301ec55c1e6316fbaa385edfd9a9c586c8eb964bd8aa637041eda3fff3b7d3463845de207bc9e6cb6a209d3c15c8c661daaa SHA512 7321e7383d6205f18dffd00a23d07e9154dd79e35eb58d04a6af77bc9f70e476b67a953eb5d09685b4a7c386ecdb9111d40c77bf3b570ffc27a1c90b612a4803
DIST prewikka-4.0.0.tar.gz 1365985 BLAKE2B 2248c80bebccf4a5f4b99f46d3af6f2aff433c19105e02dfa6c8570a6e41436a9f74971774f3963cbec9abcf70a2bf52b04cd99d930f3e193033aeb1246d1a18 SHA512 01e69b89543cac6b7a694a48cb184759641d37a5987530ce5b738a287a9cd72cc37f6bb85a621d6eb973e957730a6cb438fd302a33f2324359232e4325970bb6
DIST prewikka-4.1.5.tar.gz 1432885 BLAKE2B aa899eae92b7eee10c4e80544fc02c80fce403dd808464ef3ca21a6d8ddb052730314bd4b83970c684401c53f8398df0f9ca5180c946999e08a2faf9eb7b94f4 SHA512 f68fb6c893727e1bfc2611ef8e3327e6c44d24ea36239fb998675d0e8102dd9849990dbd344c9f584a045f9ed6b4208c3a9928c952ed6248e691687827677dd3
+DIST prewikka-5.1.1.tar.gz 1662093 BLAKE2B a4057ee35bb2dbc55ee86c4f41c32074d20712e79fe62b4a409fb0c842ee6aac06418aeace8d11d3c74c99b6787a2e507d0e424180849b4acb3296ebc6c785f0 SHA512 97ac557964fc7a3a633d879830dbda1a263061acc7d943798638686a67db46f08371af081b07eded60dc9856dd47641fae5df50603e190f36acb71a45ee6089a
diff --git a/www-apps/prewikka/prewikka-5.1.1.ebuild b/www-apps/prewikka/prewikka-5.1.1.ebuild
new file mode 100644
index 000000000000..1ab92c9ebfde
--- /dev/null
+++ b/www-apps/prewikka/prewikka-5.1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_REQ_USE="ssl"
+
+inherit distutils-r1
+
+DESCRIPTION="Graphical front-end analysis console for the Prelude Framework"
+HOMEPAGE="https://www.prelude-siem.org"
+SRC_URI="https://www.prelude-siem.org/pkg/src/5.1.0/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-libs/libprelude-5.1.0[python,${PYTHON_USEDEP}]
+ <dev-libs/libprelude-6[python,${PYTHON_USEDEP}]
+ >=dev-libs/libpreludedb-5.1.0[python,${PYTHON_USEDEP}]
+ <dev-libs/libpreludedb-6[python,${PYTHON_USEDEP}]
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/croniter[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/lark-parser[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/voluptuous[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ media-fonts/font-xfree86-type1"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="dev-python/lesscpy[${PYTHON_USEDEP}]
+ sys-devel/gettext"
+
+pkg_postinst() {
+ optfeature "Asynchronous DNS" dev-python/twisted[${PYTHON_USEDEP}]
+}