summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-03-11 18:11:40 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-03-11 18:12:45 +0100
commitcb5ce2b431b892d312d67a117f6460c324f62440 (patch)
treea1e2085bbd4c5d2d75a481e86d88f73773cd3e62 /www-apps
parentdev-python/python-ctags: add Python 3.8 support, add slot operator (diff)
downloadgentoo-cb5ce2b431b892d312d67a117f6460c324f62440.tar.gz
gentoo-cb5ce2b431b892d312d67a117f6460c324f62440.tar.bz2
gentoo-cb5ce2b431b892d312d67a117f6460c324f62440.zip
www-apps/klaus: bump to 1.5.2, add Python 3.8 support
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/klaus/Manifest1
-rw-r--r--www-apps/klaus/klaus-1.5.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/www-apps/klaus/Manifest b/www-apps/klaus/Manifest
index f7dd242ba097..2a4129b7bd55 100644
--- a/www-apps/klaus/Manifest
+++ b/www-apps/klaus/Manifest
@@ -1,2 +1,3 @@
DIST klaus-1.4.0.tar.gz 36879 BLAKE2B 8a621338514e3be143c5b64a0a486d47edc7e7a14c839bc135e7c1693fd09ddea1529b5b2e1d8e0bb70f152629d7bff288f9221ae4243dac01995da4d00e5848 SHA512 8e596590fe29c62eeb823047780f747a0f4908f926dad8ff54000469dca013fcfcbaf7b53c0555db095fef71e4d9056e9b6e959005550bdfccc338f1ee3a5d2c
DIST klaus-1.5.1.tar.gz 37563 BLAKE2B 164971626cab61d49e662fd356e0954e6ce8c1028d2452d661b3fdc386d835408e5aaaf83f14ec8851b7482e5a848086c6f15765811454ecf16628c01ba154b8 SHA512 a2244973ff93dbb00f5771755704fe7c6d5ee7f4f47189643f27cc114216a9b14327fc537b5c934c7ed8a08df52727600761402da0d492ffa5d5ba6c5f24af56
+DIST klaus-1.5.2.tar.gz 38168 BLAKE2B 4bcaf91ce641ca1f937d8b1b46367caf0ac7e9130fe222c820ded7cca8a708d1374142b09ae511da2695a64b3f2b67be69645d05602779c05081081b29494d9d SHA512 6423bfbef83f09b9abe4a1150d096ae72fc058a81c60fac585796918fa7c12b9a81c4d5808cf2e18acda5f6b891eaf93ed72a2e229b5b8d6ab5f060ea3230932
diff --git a/www-apps/klaus/klaus-1.5.2.ebuild b/www-apps/klaus/klaus-1.5.2.ebuild
new file mode 100644
index 000000000000..351c5e29721b
--- /dev/null
+++ b/www-apps/klaus/klaus-1.5.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple, easy-to-set-up Git web viewer"
+HOMEPAGE="https://github.com/jonashaag/klaus/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ctags"
+
+RDEPEND="
+ >=dev-python/dulwich-0.19.3[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/httpauth[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ ctags? ( dev-python/python-ctags[${PYTHON_USEDEP}] )
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# The tests can only be run from a git repository
+# so they are not included in the source distributions
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman ${PN}.1
+}