summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2018-02-24 14:20:37 -0100
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2018-02-24 14:22:09 -0100
commitcc90a8bb43083bdab14a9ee0ef95709a7f2f2975 (patch)
tree58a46b0a306db41e09a4b7c4812152b02bce299d /www-apps
parentdev-python/sphinx: Bump (diff)
downloadgentoo-cc90a8bb43083bdab14a9ee0ef95709a7f2f2975.tar.gz
gentoo-cc90a8bb43083bdab14a9ee0ef95709a7f2f2975.tar.bz2
gentoo-cc90a8bb43083bdab14a9ee0ef95709a7f2f2975.zip
www-apps/drupal: Security bump to releases 7.57 and 8.4.5 - SA-CORE-2018-001.
Bug: https://bugs.gentoo.org/648552 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/drupal/Manifest2
-rw-r--r--www-apps/drupal/drupal-7.57.ebuild74
-rw-r--r--www-apps/drupal/drupal-8.4.5.ebuild86
3 files changed, 162 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index 5db6ab9ce61e..284f3d52e884 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,3 +1,5 @@
DIST drupal-7.56.tar.gz 3277833 BLAKE2B 30b707b9a9846d8d22401cc193c1ed32068bbcab3103fc7bd43164ad2f13feaad48e19c6e660bd1e51aaf7dbc5d91547a57ce05e55a4a73f0a13e972d0fee661 SHA512 ab7ad8d9cb26e89b9d81280b1677584072db627d508ccade9442c95a90f24c94d11561013c8a7297ddae6ae43696d0b711b8c37ab98f89539f6f0e0154db6344
+DIST drupal-7.57.tar.gz 3279405 BLAKE2B 4697f5f30d5d2bbe821a766c2f0a05813fba091c1e976f0e0ca726e86a6d14633eecd586c29fd3a66001b143c641c74c277e90f13fd96cf14f02c38f0f9b43e0 SHA512 79e7e38c605cf60e458b2846ef4ce95f82368954f86fac6e79c19357e7a4ff714367c5580836ae2e45b22029d9ba2f2566901887d37bfa1ec2ed94a5a370fa0e
DIST drupal-8.3.7.tar.gz 12739663 BLAKE2B 9bbd3086ff516671cb33fd9a47f69bc1ebeaf6af5ef2b8058906ad09a75de5aa0c6ec256d9a7116fd899735b706035f9f0975a19f3bcd7e8cf52f904c2fc066e SHA512 d454a51b2bc7ffbad3e461df1d2ea1f38797716b046a520ad65fab5f5c398091b28bc623d3efc2d18176e6506a95e113e1d5e5a0a76e50ca7f22a995920ea671
DIST drupal-8.4.2.tar.gz 13393043 BLAKE2B 6e0db7b46cdd67ba93aadd279a1d0950e85aafdc697650ac81a9c3f10d1ffa19219d5e773f8efabf08152a712f368f15eae96353ea1b4d2427fe35355e1ca5ba SHA512 ce4ba105c253669ed18656d50a172d2f0622b1be121895486b2df00dfda0f71c497277cbc3e3a7a9fb426b9fb0828bfcf7ede3ff134304ca136ed689d4f15582
+DIST drupal-8.4.5.tar.gz 13414036 BLAKE2B b82753e320c3970d786ca10292b0aacbb3c5b6ba15dedf210144205b9e24bd25d3913453e70fc6736c34184dcc486f2323b39b9f6e60a3e8ec1b15bc55ae9c0b SHA512 105a6bce140b1f5965d42f46df4a8fa0f8802ae6b4efde5c095004f51beebe5f1c4d3064e3363f59f9a15f739ea598b2e9a03304630731113777b3639b3440d2
diff --git a/www-apps/drupal/drupal-7.57.ebuild b/www-apps/drupal/drupal-7.57.ebuild
new file mode 100644
index 000000000000..904fbef88e17
--- /dev/null
+++ b/www-apps/drupal/drupal-7.57.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+ virtual/httpd-php
+ accelerator? ( ||
+ (
+ dev-php/xcache
+ (
+ >=dev-lang/php-5.5[opcache]
+ dev-php/pecl-apcu
+ )
+ )
+ )
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt INSTALL.mysql.txt INSTALL.pgsql.txt INSTALL.sqlite.txt UPGRADE.txt "
+ dodoc ${docs}
+ rm -f ${docs} INSTALL COPYRIGHT.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+}
diff --git a/www-apps/drupal/drupal-8.4.5.ebuild b/www-apps/drupal/drupal-8.4.5.ebuild
new file mode 100644
index 000000000000..703cace2293b
--- /dev/null
+++ b/www-apps/drupal/drupal-8.4.5.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+ virtual/httpd-php
+ accelerator? ( ||
+ (
+ dev-php/xcache
+ (
+ >=dev-lang/php-5.5[opcache]
+ dev-php/pecl-apcu
+ )
+ )
+ )
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}