summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2021-09-24 09:43:12 +0000
committerSam James <sam@gentoo.org>2021-09-25 00:39:17 +0100
commitd8eb1a2a34f3ef391302555965bdd02a014ff742 (patch)
treec9f34f951b5f252ba4ded98f63bae11b205aad90 /www-apps
parentwww-apps/gitea: bump to 1.15.3 (diff)
downloadgentoo-d8eb1a2a34f3ef391302555965bdd02a014ff742.tar.gz
gentoo-d8eb1a2a34f3ef391302555965bdd02a014ff742.tar.bz2
gentoo-d8eb1a2a34f3ef391302555965bdd02a014ff742.zip
www-apps/gitea: bump to 1.14.7
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/22385 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gitea/Manifest1
-rw-r--r--www-apps/gitea/gitea-1.14.7.ebuild128
2 files changed, 129 insertions, 0 deletions
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index 369f01dd0bb3..402794e64d08 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -1,3 +1,4 @@
DIST gitea-1.14.6.tar.gz 117871468 BLAKE2B f71ea5e6761e36bbb5d4304e606b99513196703773c4595fef85e1641cff179e2b58b3150de199636a504ec806fc17d8deb73cac903824502749cbcdd6f72aaa SHA512 2e17994dbadc29d62f244d70550da59c1ab6818a1e5af20265405024b26fe6641bbeabb6b227f432170abd133fb3f11a2b5d9ac814ebd234729e4fcc0c4ed6d0
+DIST gitea-1.14.7.tar.gz 117981989 BLAKE2B e3159f0a3c07511319491865ab75a4619e1c696e19e0dc6dc0ce56d0adf06f6be0658b96d65a8085694aac0fc0a5131e127b8181d789847708bc56691ad6a547 SHA512 023a6583f8352974df3138b8aa5e7729cef1769dff7a3a59b1a5efe66e4527296045ae10f69982592a9d932d390c60e749199e4d1fe1010b7507de5576c8abca
DIST gitea-1.15.2.tar.gz 48648887 BLAKE2B 5bd5800e4c967946dad918d57318831cc7a55cdeedd46e8efb74cd47940eefde1212b85f43b77f1ba443d2c09997a5dd1dd29fd9c7bbc404cf2943048e42225c SHA512 47332f07882c2bef26f9417f0617801518c0448cbe84c2a70b140f38dbe18c17cfe9bb077da49536663066b8d09a566a423256430f954beafc53d746b5bfd578
DIST gitea-1.15.3.tar.gz 48671233 BLAKE2B 3440e02711f696fff8629e5049c44963a31375516ae8e335069970d8a9a65792c60a382444bea6d49f1048936862ff5e56b79eaa7bc1aefaafe0c080ce52cb02 SHA512 00bf48e8c30ee2c00465f7e29055149e68a1f2956860ca4314c7671d054e93c94024d8aed91770b1a0a50a21937bb51e42da5d9639462c21f9a56652fbfdf04e
diff --git a/www-apps/gitea/gitea-1.14.7.ebuild b/www-apps/gitea/gitea-1.14.7.ebuild
new file mode 100644
index 000000000000..51099cd019ab
--- /dev/null
+++ b/www-apps/gitea/gitea-1.14.7.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit fcaps go-module tmpfiles systemd
+MY_PV="${PV/_rc/-rc}"
+
+DESCRIPTION="A painless self-hosted Git service"
+HOMEPAGE="https://gitea.io"
+
+if [[ ${PV} != 9999* ]] ; then
+ SRC_URI="https://github.com/go-gitea/gitea/releases/download/v${MY_PV}/gitea-src-${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64"
+ S="${WORKDIR}"
+else
+ EGIT_REPO_URI="https://github.com/go-gitea/gitea"
+ inherit git-r3
+ S="${WORKDIR}/${P}"
+fi
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+IUSE="+acct build-client pam sqlite"
+
+BDEPEND="build-client? ( >=net-libs/nodejs-10[npm] )"
+COMMON_DEPEND="
+ acct? (
+ acct-group/git
+ acct-user/git[gitea] )
+ pam? ( sys-libs/pam )"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ dev-vcs/git"
+
+DOCS=(
+ custom/conf/app.example.ini CONTRIBUTING.md README.md
+)
+FILECAPS=(
+ -m 0755 cap_net_bind_service+ep usr/bin/gitea
+)
+
+RESTRICT="test"
+QA_PRESTRIPPED="usr/bin/gitea"
+
+src_prepare() {
+ default
+
+ local sedcmds=(
+ -e "s#^ROOT =#ROOT = ${EPREFIX}/var/lib/gitea/gitea-repositories#"
+ -e "s#^ROOT_PATH =#ROOT_PATH = ${EPREFIX}/var/log/gitea#"
+ -e "s#^APP_DATA_PATH = data#APP_DATA_PATH = ${EPREFIX}/var/lib/gitea/data#"
+ -e "s#^HTTP_ADDR = 0.0.0.0#HTTP_ADDR = 127.0.0.1#"
+ -e "s#^MODE = console#MODE = file#"
+ -e "s#^LEVEL = Trace#LEVEL = Info#"
+ -e "s#^LOG_SQL = true#LOG_SQL = false#"
+ -e "s#^DISABLE_ROUTER_LOG = false#DISABLE_ROUTER_LOG = true#"
+ )
+
+ sed -i "${sedcmds[@]}" custom/conf/app.example.ini || die
+ if use sqlite ; then
+ sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.example.ini || die
+ fi
+
+ einfo "Remove tests which are known to fail with network-sandbox enabled."
+ rm ./modules/migrations/github_test.go || die
+
+ einfo "Remove tests which depend on gitea git-repo."
+ rm ./modules/git/blob_test.go || die
+ rm ./modules/git/repo_test.go || die
+
+ # Remove already build assets (like frontend part)
+ use build-client && emake clean-all
+}
+
+src_compile() {
+ local gitea_tags=(
+ bindata
+ $(usev pam)
+ $(usex sqlite 'sqlite sqlite_unlock_notify' '')
+ )
+ local gitea_settings=(
+ "-X code.gitea.io/gitea/modules/setting.CustomConf=${EPREFIX}/etc/gitea/app.ini"
+ "-X code.gitea.io/gitea/modules/setting.CustomPath=${EPREFIX}/var/lib/gitea/custom"
+ "-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
+ )
+ local makeenv=(
+ TAGS="${gitea_tags[*]}"
+ LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[*]}"
+ )
+ [[ ${PV} != 9999* ]] && makeenv+=("DRONE_TAG=${MY_PV}")
+
+ if use build-client; then
+ # -j1 as Makefile doesn't handle dependancy correctly, and is not
+ # useful as golang compiler don't use this info.
+ env "${makeenv[@]}" emake -j1 build
+ else
+ env "${makeenv[@]}" emake backend
+ fi
+}
+
+src_install() {
+ dobin gitea
+
+ einstalldocs
+
+ newconfd "${FILESDIR}/gitea.confd-r1" gitea
+ newinitd "${FILESDIR}/gitea.initd-r3" gitea
+ newtmpfiles - gitea.conf <<-EOF
+ d /run/gitea 0755 git git
+ EOF
+ systemd_newunit "${FILESDIR}"/gitea.service-r3 gitea.service
+
+ insinto /etc/gitea
+ newins custom/conf/app.example.ini app.ini
+ if use acct ; then
+ fowners root:git /etc/gitea/{,app.ini}
+ fperms g+w,o-rwx /etc/gitea/{,app.ini}
+
+ diropts -m0750 -o git -g git
+ keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
+ keepdir /var/log/gitea
+ fi
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+ tmpfiles_process gitea.conf
+}