summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2019-04-12 12:59:47 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2019-04-12 12:59:47 +0000
commitdaee4e9c8e3b64105f872d0a845dee75aa5a349a (patch)
tree2a63d118cd4e9f3545dde68e5d8f5dace7aa8de5 /www-apps
parentdev-cpp/rttr: add ~x86 keyword (diff)
downloadgentoo-daee4e9c8e3b64105f872d0a845dee75aa5a349a.tar.gz
gentoo-daee4e9c8e3b64105f872d0a845dee75aa5a349a.tar.bz2
gentoo-daee4e9c8e3b64105f872d0a845dee75aa5a349a.zip
www-apps/drupal: Bump to release 8.6.14.
Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-8.6.14.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index a934dec7d03d..7ef3c1736562 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,3 +1,4 @@
DIST drupal-7.65.tar.gz 3298607 BLAKE2B f3a728c3e464b8d94719ed7a79359c5fa2b8b0216ee90029d05e873377566a398d80f188f9dc36f2504057c0000a7bcd364d5c4f50652f25e73e1aa0e7d5d7b1 SHA512 a79ff93e13456b35160ee17f986dce9cffefa265d0034dab6223a3097eaf45c11ea3548904ff6c125be0817dc71a8ac7320aca91a11eefeaad03d45527725e79
DIST drupal-8.5.14.tar.gz 15828327 BLAKE2B aa638ac4643541d9ec2b2168633c8ab4fe6b64f3c2b9fec46a6a45903ccaaa26ba671c62d57c51a5698ad2558c6ed3ee491dff739f1eed05ea2a0fefba5ace31 SHA512 2be4878cbb27389d11f3686fdc911468a8481d7cbade168c70e733615f2ed699bcc8eb1798079d0b354c81caec0cf74fb232b310e9ab7e059c00fba4b3ee2796
DIST drupal-8.6.13.tar.gz 17137449 BLAKE2B f52b082bdccbeb3600da723483bbdef8645babc84a433c82e38b7029332764361a3ca6996b6ac9c20e96c27b4412c7d14a9b0b454c234594f13ba4fdeba39029 SHA512 ed9da8596ca5f4dee569b2beea561b75742aa801ef450258786c6d496e9205cd865af3a6cca56bc276df48841b95bcaaaae46ffcda6bbf8183866ec3c991fff2
+DIST drupal-8.6.14.tar.gz 17136296 BLAKE2B e539fd4bc1dfe743f879fb3137b2bd5280187e6c9091859d31ae5ef5529ceae028bd9438d11b4acb18756918264d2b4b52e436b7d8bdef2c6bd427be18424c87 SHA512 22902aa09ae83452423e69e1dd5f9b58f1de454fc6e503634383c6cf8ebd1d75732629dd103bfcaa007013f37b0f87a3ab4768e2710e7e191369857211ddf2cd
diff --git a/www-apps/drupal/drupal-8.6.14.ebuild b/www-apps/drupal/drupal-8.6.14.ebuild
new file mode 100644
index 000000000000..a8514d07dfe0
--- /dev/null
+++ b/www-apps/drupal/drupal-8.6.14.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+ virtual/httpd-php
+ accelerator? ( ||
+ (
+ dev-php/xcache
+ (
+ >=dev-lang/php-5.5[opcache]
+ dev-php/pecl-apcu
+ )
+ )
+ )
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}