summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-08-20 11:40:29 -0400
committerMike Gilbert <floppym@gentoo.org>2016-08-20 11:40:29 -0400
commit2d802144d674286b08349c8a00c9c5ce78e93943 (patch)
treefd27b28be5a7f9ec2d4003fca0d176085fe45c16 /www-client/chromium
parentwww-client/chromium: use tc-is-clang (diff)
downloadgentoo-2d802144d674286b08349c8a00c9c5ce78e93943.tar.gz
gentoo-2d802144d674286b08349c8a00c9c5ce78e93943.tar.bz2
gentoo-2d802144d674286b08349c8a00c9c5ce78e93943.zip
www-client/chromium: check MERGE_TYPE before gcc version
Diffstat (limited to 'www-client/chromium')
-rw-r--r--www-client/chromium/chromium-54.0.2832.2.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/www-client/chromium/chromium-54.0.2832.2.ebuild b/www-client/chromium/chromium-54.0.2832.2.ebuild
index 27c458a6fce4..b1895b90265b 100644
--- a/www-client/chromium/chromium-54.0.2832.2.ebuild
+++ b/www-client/chromium/chromium-54.0.2832.2.ebuild
@@ -165,8 +165,10 @@ PATCHES=(
)
pkg_pretend() {
- if tc-is-gcc && ! version_is_at_least 4.8 "$(gcc-version)"; then
- die 'At least gcc 4.8 is required, see bugs: #535730, #525374, #518668.'
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if tc-is-gcc && ! version_is_at_least 4.8 "$(gcc-version)"; then
+ die 'At least gcc 4.8 is required, see bugs: #535730, #525374, #518668.'
+ fi
fi
# Check build requirements, bug #541816 and bug #471810 .
@@ -181,7 +183,6 @@ pkg_pretend() {
}
pkg_setup() {
-
# Make sure the build system will use the right python, bug #344367.
python-any-r1_pkg_setup