summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-02-09 12:43:47 +0100
committerJeroen Roovers <jer@gentoo.org>2020-02-09 12:45:15 +0100
commit9489ea43e91dbe22e609e7029759defc6b7ffe8b (patch)
tree02d1bb5d0788e92a87051edfe93dd5f7096eac3e /www-client/dillo/files
parentmail-client/hap: port to EAPI=7 (diff)
downloadgentoo-9489ea43e91dbe22e609e7029759defc6b7ffe8b.tar.gz
gentoo-9489ea43e91dbe22e609e7029759defc6b7ffe8b.tar.bz2
gentoo-9489ea43e91dbe22e609e7029759defc6b7ffe8b.zip
www-client/dillo: Fix compiling against >dev-libs/openssl-1.1
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Closes: https://bugs.gentoo.org/708732 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'www-client/dillo/files')
-rw-r--r--www-client/dillo/files/dillo-3.0.5-openssl-1.1.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/www-client/dillo/files/dillo-3.0.5-openssl-1.1.patch b/www-client/dillo/files/dillo-3.0.5-openssl-1.1.patch
new file mode 100644
index 000000000000..f21694113c2b
--- /dev/null
+++ b/www-client/dillo/files/dillo-3.0.5-openssl-1.1.patch
@@ -0,0 +1,26 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -286,7 +286,7 @@
+
+ if test "x$ssl_ok" = "xyes"; then
+ old_libs="$LIBS"
+- AC_CHECK_LIB(ssl, SSL_library_init, ssl_ok=yes, ssl_ok=no, -lcrypto)
++ AC_CHECK_LIB(ssl, OPENSSL_config, ssl_ok=yes, ssl_ok=no, -lcrypto)
+ LIBS="$old_libs"
+ fi
+
+--- a/dpi/https.c
++++ b/dpi/https.c
+@@ -476,7 +476,11 @@
+ case X509_V_ERR_DEPTH_ZERO_SELF_SIGNED_CERT:
+ /*Either self signed and untrusted*/
+ /*Extract CN from certificate name information*/
++#if OPENSSL_VERSION_NUMBER < 0x10100000L
+ if ((cn = strstr(remote_cert->name, "/CN=")) == NULL) {
++#else
++ if ((cn = strstr(X509_get_subject_name(remote_cert), "/CN=")) == NULL) {
++#endif
+ strcpy(buf, "(no CN given)");
+ } else {
+ char *cn_end;
+