summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-client/elinks/elinks-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-client/elinks/elinks-9999.ebuild')
-rw-r--r--www-client/elinks/elinks-9999.ebuild150
1 files changed, 150 insertions, 0 deletions
diff --git a/www-client/elinks/elinks-9999.ebuild b/www-client/elinks/elinks-9999.ebuild
new file mode 100644
index 000000000000..df0bd820cabe
--- /dev/null
+++ b/www-client/elinks/elinks-9999.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+inherit autotools eutils git-r3 flag-o-matic python-any-r1
+
+EGIT_REPO_URI="git://repo.or.cz/elinks.git"
+
+MY_P="${P/_/}"
+DESCRIPTION="Advanced and well-established text-mode web browser"
+HOMEPAGE="http://elinks.or.cz/"
+SRC_URI="http://dev.gentoo.org/~spock/portage/distfiles/elinks-0.10.4.conf.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="bittorrent bzip2 debug finger ftp gopher gpm guile idn ipv6 \
+ javascript lua +mouse nls nntp perl ruby samba ssl unicode X zlib"
+RESTRICT="test"
+
+DEPEND="dev-libs/boehm-gc
+ >=dev-libs/expat-1.95.4
+ bzip2? ( >=app-arch/bzip2-1.0.2 )
+ ssl? ( >=dev-libs/openssl-0.9.6g )
+ X? ( x11-libs/libX11 x11-libs/libXt )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ lua? ( >=dev-lang/lua-5 )
+ gpm? ( >=sys-libs/ncurses-5.2 >=sys-libs/gpm-1.20.0-r5 )
+ guile? ( >=dev-scheme/guile-1.6.4-r1[deprecated,discouraged] )
+ idn? ( net-dns/libidn )
+ perl? ( dev-lang/perl:= )
+ ruby? ( dev-lang/ruby dev-ruby/rubygems )
+ samba? ( net-fs/samba )
+ javascript? ( >=dev-lang/spidermonkey-1.8.5:0= )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ default
+ git-r3_src_unpack
+}
+
+src_prepare() {
+ mv "${WORKDIR}/${PN}-0.10.4.conf" "${WORKDIR}/${PN}.conf"
+ if ! use ftp ; then
+ sed -i -e 's/\(.*protocol.ftp.*\)/# \1/' "${WORKDIR}"/${PN}.conf
+ fi
+ sed -i -e 's/\(.*set protocol.ftp.use_epsv.*\)/# \1/' "${WORKDIR}"/${PN}.conf
+ epatch "${FILESDIR}"/${P}-parallel-make.patch
+
+ epatch_user
+
+ # Regenerate acinclude.m4 - based on autogen.sh.
+ cat > acinclude.m4 <<- _EOF
+ dnl Automatically generated from config/m4/ files.
+ dnl Do not modify!
+ _EOF
+ cat config/m4/*.m4 >> acinclude.m4
+ sed -i -e 's/-Werror//' configure*
+
+ eautoreconf
+}
+
+src_configure() {
+ # NOTE about GNUTSL SSL support (from the README -- 25/12/2002)
+ # As GNUTLS is not yet 100% stable and its support in ELinks is not so well
+ # tested yet, it's recommended for users to give a strong preference to OpenSSL whenever possible.
+ local myconf=""
+
+ if use debug ; then
+ myconf="--enable-debug"
+ else
+ myconf="--enable-fastmem"
+ fi
+
+ if use ssl ; then
+ myconf="${myconf} --with-openssl=${EPREFIX}/usr"
+ else
+ myconf="${myconf} --without-openssl --without-gnutls"
+ fi
+
+ econf \
+ --sysconfdir="${EPREFIX}"/etc/elinks \
+ --enable-leds \
+ --enable-88-colors \
+ --enable-256-colors \
+ --enable-true-color \
+ --enable-html-highlight \
+ $(use_with gpm) \
+ $(use_with zlib) \
+ $(use_with bzip2 bzlib) \
+ $(use_with X x) \
+ $(use_with lua) \
+ $(use_with guile) \
+ $(use_with perl) \
+ $(use_with ruby) \
+ $(use_with idn) \
+ $(use_with javascript spidermonkey) \
+ $(use_enable bittorrent) \
+ $(use_enable nls) \
+ $(use_enable ipv6) \
+ $(use_enable ftp) \
+ $(use_enable gopher) \
+ $(use_enable nntp) \
+ $(use_enable finger) \
+ $(use_enable samba smb) \
+ $(use_enable mouse) \
+ ${myconf}
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ emake V=1 DESTDIR="${D}" install
+
+ insopts -m 644 ; insinto /etc/elinks
+ doins "${WORKDIR}"/elinks.conf
+ newins contrib/keybind-full.conf keybind-full.sample
+ newins contrib/keybind.conf keybind.conf.sample
+
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README SITES THANKS TODO doc/*.*
+ docinto contrib ; dodoc contrib/{README,colws.diff,elinks[-.]vim*}
+ insinto /usr/share/doc/${PF}/contrib/lua ; doins contrib/lua/{*.lua,elinks-remote}
+ insinto /usr/share/doc/${PF}/contrib/conv ; doins contrib/conv/*.*
+ insinto /usr/share/doc/${PF}/contrib/guile ; doins contrib/guile/*.scm
+
+ # Remove some conflicting files on OSX. The files provided by OSX 10.4
+ # are more or less the same. -- Fabian Groffen (2005-06-30)
+ rm -f "${ED}"/usr/share/locale/locale.alias "${ED}"/usr/lib/charset.alias || die
+}
+
+pkg_postinst() {
+ einfo "This ebuild provides a default config for ELinks."
+ einfo "Please check /etc/elinks/elinks.conf"
+ einfo
+ einfo "You may want to convert your html.cfg and links.cfg of"
+ einfo "Links or older ELinks versions to the new ELinks elinks.conf"
+ einfo "using /usr/share/doc/${PF}/contrib/conv/conf-links2elinks.pl"
+ einfo
+ einfo "Please have a look at /etc/elinks/keybind-full.sample and"
+ einfo "/etc/elinks/keybind.conf.sample for some bindings examples."
+ einfo
+ einfo "You will have to set your TERM variable to 'xterm-256color'"
+ einfo "to be able to use 256 colors in elinks."
+ echo
+}