summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz Tiram <oz.tiram@gmail.com>2023-02-27 15:07:08 +0100
committerSam James <sam@gentoo.org>2023-03-16 23:50:36 +0000
commit7443350a860b025b89a7f1e501a6ee630f0344f3 (patch)
treea439eee9d9e51dc00ad875bfa47bbbed8400c9aa /www-client/luakit
parentdev-libs/glib: drop 2.76.0 (diff)
downloadgentoo-7443350a860b025b89a7f1e501a6ee630f0344f3.tar.gz
gentoo-7443350a860b025b89a7f1e501a6ee630f0344f3.tar.bz2
gentoo-7443350a860b025b89a7f1e501a6ee630f0344f3.zip
www-client/luakit: add 2.3.3
Closes: https://bugs.gentoo.org/900775 Bug: https://bugs.gentoo.org/893714 Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-client/luakit')
-rw-r--r--www-client/luakit/Manifest1
-rw-r--r--www-client/luakit/luakit-2.3.3.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/www-client/luakit/Manifest b/www-client/luakit/Manifest
index 636495d9404f..7d4a8cc9f198 100644
--- a/www-client/luakit/Manifest
+++ b/www-client/luakit/Manifest
@@ -1,2 +1,3 @@
DIST luakit-2.2.1.tar.gz 488845 BLAKE2B 2bed592f7d56fc4b5bad4fee3563805954c6211222e25344d01430ef9f2921c240e9cb3c735564fae66d0739d50da41a90309c7dba3ba9f4631d880b9a47e4b1 SHA512 9a055c1541f31027805d3da2604d98c0193a9c2874099fc3ab3ef08c645a8e91b8504d1162e86cbd29a5e5e0a3c54b3154299708f864d135d8640bcc3866674b
+DIST luakit-2.3.3.tar.gz 507343 BLAKE2B 4b9c3b3e4d5ff50f1c7409cf8f77ca7c81032f13051c3cca2aef4f794ee159fd12c5bfe0706e74414056899ef64330e888fe141256e52bc6d89eb572cca975e0 SHA512 ae5088541118c693db4a90f7e727d1f4094b56d4ea4cd51d2019351ff6b44672a1d7b9f80b351a37767556564b68633d815649ceaa4d8bd3b966a20a155ba2b2
DIST luakit-2.3.tar.gz 497470 BLAKE2B 980eabba255a83a26acf565df170907805df5eb6ea7bfc978c5a180c27575d7ebadec7c97ba7af1a60cdc08654f4c4ca1967b25272dd4788a553815f91cc1502 SHA512 98a473bcafbd082093689fd58b8c9828e3d79b8ae367ea4d030bb2b1671bf4f61a4f07fe57b99e6c69c40e26ad8b96b88b67e48ce085187923a1a1d976bdcee3
diff --git a/www-client/luakit/luakit-2.3.3.ebuild b/www-client/luakit/luakit-2.3.3.ebuild
new file mode 100644
index 000000000000..4c994069bf52
--- /dev/null
+++ b/www-client/luakit/luakit-2.3.3.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-1 luajit )
+
+inherit lua-single toolchain-funcs xdg
+
+DESCRIPTION="A fast, extensible, and customizable web browser"
+HOMEPAGE="https://luakit.github.io/luakit"
+
+SRC_URI="https://github.com/luakit/luakit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~arm64"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="doc test"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ net-libs/webkit-gtk:4.1=
+ x11-libs/gtk+:3
+ ${LUA_DEPS}
+ $(lua_gen_cond_dep '
+ dev-lua/luafilesystem[${LUA_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ dev-lua/luafilesystem
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+ test? (
+ $(lua_gen_cond_dep '
+ dev-lua/luassert[${LUA_USEDEP}]
+ dev-lua/luacheck[${LUA_USEDEP}]
+ ')
+ x11-base/xorg-server[xvfb]
+ )
+"
+src_configure() {
+ export LUA_BIN_NAME=${ELUA}
+ export LUA_PKG_NAME=${ELUA}
+ tc-export CC PKG_CONFIG
+}
+
+src_compile() {
+ emake \
+ PREFIX="${EPREFIX}/usr" \
+ USE_LUAJIT=$(usex lua_single_target_luajit 1 0) \
+ ${PN} ${PN}.so
+
+ use doc && emake doc
+}
+
+src_test() {
+ local failing_test
+ for failing_test in test_clib_luakit test_image_css; do
+ mv tests/async/${failing_test}.lua{,.disabled} || die
+ done
+
+ emake \
+ USE_LUAJIT=$(usex lua_single_target_luajit 1 0) \
+ run-tests
+}
+
+src_install() {
+ emake \
+ DESTDIR="${ED}" \
+ DOCDIR="${EPREFIX}/usr/share/doc/${PF}" \
+ PREFIX="${EPREFIX}/usr" \
+ USE_LUAJIT=$(usex lua_single_target_luajit 1 0) \
+ XDGPREFIX="${EPREFIX}/etc/xdg" \
+ install
+
+ rm "${ED}/usr/share/doc/${PF}/COPYING.GPLv3" || die
+
+ use doc && dodoc -r doc/html
+}