summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <sultan@gentoo.org>2022-03-24 19:41:59 +0100
committerStephan Hartmann <sultan@gentoo.org>2022-03-24 19:42:17 +0100
commitdf186d0b7f4ae066435c5ff7291d15e927a09fc2 (patch)
treeeceb27024cae4a80ee5ed7f0c586d9ae0bd5c77a /www-client/microsoft-edge
parentmedia-sound/din: removed obsolete 53 (diff)
downloadgentoo-df186d0b7f4ae066435c5ff7291d15e927a09fc2.tar.gz
gentoo-df186d0b7f4ae066435c5ff7291d15e927a09fc2.tar.bz2
gentoo-df186d0b7f4ae066435c5ff7291d15e927a09fc2.zip
www-client/microsoft-edge: automated bump (99.0.1150.52)
Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
Diffstat (limited to 'www-client/microsoft-edge')
-rw-r--r--www-client/microsoft-edge/Manifest1
-rw-r--r--www-client/microsoft-edge/microsoft-edge-99.0.1150.52.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/www-client/microsoft-edge/Manifest b/www-client/microsoft-edge/Manifest
index 7884fd7dff99..ead677e71e16 100644
--- a/www-client/microsoft-edge/Manifest
+++ b/www-client/microsoft-edge/Manifest
@@ -1 +1,2 @@
DIST microsoft-edge-stable_99.0.1150.46-1_amd64.deb 117789352 BLAKE2B bc48bb1e7bcb716be3fae9367f4b81fc2f7c8e5e6a3413fe9585c079fa04ea5cce9870b6e3bb1aa8980508eb1774f3654b8913927e69adcbfb8c4f4031c32b36 SHA512 dcbde923e038e04ace82fd739446b4cf2384a262bbf47508e9fe8eb115d1aa1eba80cede1cd121afd8690d485531153821e901ea9650918ba1380f3566e10df3
+DIST microsoft-edge-stable_99.0.1150.52-1_amd64.deb 117788060 BLAKE2B 0a77b949d71ab0473d56386a5af0b1f427729da2466f9023c5b3c143e37142c86be47000b891a82e801d57ac0f10090dd3cdaf43dfc247adb2f27d62924f8933 SHA512 071d104a80278ee4f8f44e9492007056b399d0fc33b7fb304633d7316b412f2dca6d7f7f285b8c064ab60cb19cccc532eb8cea4cc7cc88f6f35284a54188714c
diff --git a/www-client/microsoft-edge/microsoft-edge-99.0.1150.52.ebuild b/www-client/microsoft-edge/microsoft-edge-99.0.1150.52.ebuild
new file mode 100644
index 000000000000..a8cc7e730ebf
--- /dev/null
+++ b/www-client/microsoft-edge/microsoft-edge-99.0.1150.52.ebuild
@@ -0,0 +1,116 @@
+# Copyright 2011-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit chromium-2 desktop pax-utils unpacker xdg
+
+DESCRIPTION="The web browser from Microsoft"
+HOMEPAGE="https://www.microsoft.com/en-us/edge"
+
+if [[ ${PN} == microsoft-edge ]]; then
+ MY_PN=${PN}-stable
+else
+ MY_PN=${PN}
+fi
+
+KEYWORDS="-* ~amd64"
+
+MY_P="${MY_PN}_${PV}-1"
+
+SRC_URI="https://packages.microsoft.com/repos/edge/pool/main/m/${MY_PN}/${MY_P}_amd64.deb"
+
+LICENSE="microsoft-edge"
+SLOT="0"
+RESTRICT="bindist mirror strip"
+IUSE="+mip"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ app-accessibility/at-spi2-core:2
+ app-misc/ca-certificates
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/liberation-fonts
+ media-libs/alsa-lib
+ media-libs/mesa[gbm(+)]
+ net-misc/curl[ssl]
+ net-print/cups
+ sys-apps/dbus
+ sys-apps/util-linux
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3[X]
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/libxshmfence
+ x11-libs/pango
+ x11-misc/xdg-utils
+ mip? ( app-crypt/libsecret )
+"
+
+QA_PREBUILT="*"
+QA_DESKTOP_FILE="usr/share/applications/microsoft-edge.*\\.desktop"
+S=${WORKDIR}
+EDGE_HOME="opt/microsoft/msedge${PN#microsoft-edge}"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your tree before reporting a bug for microsoft-edge fetch failures."
+}
+
+pkg_pretend() {
+ # Protect against people using autounmask overzealously
+ use amd64 || die "microsoft-edge only works on amd64"
+}
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ dodir /
+ cd "${ED}" || die
+ unpacker
+
+ rm _gpgorigin || die
+
+ rm -r etc usr/share/menu || die
+ mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
+
+ gzip -d usr/share/doc/${PF}/changelog.gz || die
+ gzip -d usr/share/man/man1/${MY_PN}.1.gz || die
+ if [[ -L usr/share/man/man1/${PN}.1.gz ]]; then
+ rm usr/share/man/man1/${PN}.1.gz || die
+ dosym ${MY_PN}.1 usr/share/man/man1/${PN}.1
+ fi
+
+ local suffix=
+ [[ ${PN} == microsoft-edge-beta ]] && suffix=_beta
+ [[ ${PN} == microsoft-edge-dev ]] && suffix=_dev
+
+ local size
+ for size in 16 24 32 48 64 128 256 ; do
+ newicon -s ${size} "${EDGE_HOME}/product_logo_${size}${suffix}.png" ${PN}.png
+ done
+
+ if ! use mip; then
+ rm "${EDGE_HOME}"/libmip_{core,protection_sdk}.so || die
+ fi
+
+ pax-mark m "${EDGE_HOME}/msedge"
+}