summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-client/phantomjs/phantomjs-1.9.8.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-client/phantomjs/phantomjs-1.9.8.ebuild')
-rw-r--r--www-client/phantomjs/phantomjs-1.9.8.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/www-client/phantomjs/phantomjs-1.9.8.ebuild b/www-client/phantomjs/phantomjs-1.9.8.ebuild
new file mode 100644
index 000000000000..57e8c0221db9
--- /dev/null
+++ b/www-client/phantomjs/phantomjs-1.9.8.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs pax-utils multiprocessing
+
+DESCRIPTION="A headless WebKit scriptable with a JavaScript API"
+HOMEPAGE="http://phantomjs.org/"
+SRC_URI="https://bitbucket.org/ariya/phantomjs/downloads/${P}-source.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples"
+
+RDEPEND="dev-libs/icu:=
+ dev-libs/openssl
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e '/^# CONFIG += text_breaking_with_icu/s:#::' \
+ src/qt/src/3rdparty/webkit/Source/JavaScriptCore/JavaScriptCore.pri \
+ || die
+
+ # Respect CC, CXX, {C,CXX,LD}FLAGS in .qmake.cache
+ sed -i \
+ -e "/^SYSTEM_VARIABLES=/i \
+ CC='$(tc-getCC)'\n\
+ CXX='$(tc-getCXX)'\n\
+ CFLAGS='${CFLAGS}'\n\
+ CXXFLAGS='${CXXFLAGS}'\n\
+ LDFLAGS='${LDFLAGS}'\n\
+ QMakeVar set QMAKE_CFLAGS_RELEASE\n\
+ QMakeVar set QMAKE_CFLAGS_DEBUG\n\
+ QMakeVar set QMAKE_CXXFLAGS_RELEASE\n\
+ QMakeVar set QMAKE_CXXFLAGS_DEBUG\n\
+ QMakeVar set QMAKE_LFLAGS_RELEASE\n\
+ QMakeVar set QMAKE_LFLAGS_DEBUG\n"\
+ src/qt/configure \
+ || die
+
+ # Respect CC, CXX, LINK and *FLAGS in config.tests
+ find src/qt/config.tests/unix -name '*.test' -type f -exec \
+ sed -i -e "/bin\/qmake/ s: \"\$SRCDIR/: \
+ 'QMAKE_CC=$(tc-getCC)' 'QMAKE_CXX=$(tc-getCXX)' 'QMAKE_LINK=$(tc-getCXX)' \
+ 'QMAKE_CFLAGS+=${CFLAGS}' 'QMAKE_CXXFLAGS+=${CXXFLAGS}' 'QMAKE_LFLAGS+=${LDFLAGS}'&:" \
+ {} + || die
+}
+
+src_compile() {
+ ./build.sh \
+ --confirm \
+ --jobs $(makeopts_jobs) \
+ --qt-config "$($(tc-getPKG_CONFIG) --cflags-only-I freetype2)" \
+ || die
+}
+
+src_test() {
+ ./bin/phantomjs test/run-tests.js || die
+}
+
+src_install() {
+ pax-mark m bin/phantomjs || die
+ dobin bin/phantomjs
+ dodoc ChangeLog README.md
+ if use examples ; then
+ docinto examples
+ dodoc examples/*
+ fi
+}