summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2021-05-18 19:06:31 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-06-07 14:05:05 +0300
commit5a200bbbdf0dec57be5b2b5aa50e2acbf130ab9c (patch)
tree6926a44f0dd91922259ea52f32594b06694c0ca8 /www-client/surf/surf-2.1.ebuild
parentwww-client/surf: update live (diff)
downloadgentoo-5a200bbbdf0dec57be5b2b5aa50e2acbf130ab9c.tar.gz
gentoo-5a200bbbdf0dec57be5b2b5aa50e2acbf130ab9c.tar.bz2
gentoo-5a200bbbdf0dec57be5b2b5aa50e2acbf130ab9c.zip
www-client/surf: add 2.1
Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-client/surf/surf-2.1.ebuild')
-rw-r--r--www-client/surf/surf-2.1.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/www-client/surf/surf-2.1.ebuild b/www-client/surf/surf-2.1.ebuild
new file mode 100644
index 000000000000..15922a19958a
--- /dev/null
+++ b/www-client/surf/surf-2.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="a simple web browser based on WebKit/GTK+"
+HOMEPAGE="https://surf.suckless.org/"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.suckless.org/surf"
+ EGIT_BRANCH="surf-webkit2"
+else
+ SRC_URI="https://dl.suckless.org/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="tabbed"
+
+DEPEND="
+ app-crypt/gcr[gtk]
+ dev-libs/glib:2
+ net-libs/webkit-gtk:4
+ x11-libs/gtk+:3
+ x11-libs/libX11
+"
+RDEPEND="${DEPEND}
+ !sci-chemistry/surf
+ !savedconfig? (
+ net-misc/curl
+ x11-apps/xprop
+ x11-misc/dmenu
+ x11-terms/st
+ )
+ tabbed? ( x11-misc/tabbed )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+pkg_setup() {
+ if ! use savedconfig; then
+ elog "The default config.h assumes you have"
+ elog " net-misc/curl"
+ elog " x11-terms/st"
+ elog "installed to support the download function."
+ elog "Without those, downloads will fail (gracefully)."
+ elog "You can fix this by:"
+ elog "1) Installing these packages, or"
+ elog "2) Setting USE=savedconfig and changing config.h accordingly."
+ fi
+}
+
+src_prepare() {
+ default
+
+ restore_config config.h
+
+ tc-export CC PKG_CONFIG
+}
+
+src_install() {
+ default
+
+ if use tabbed; then
+ dobin surf-open.sh
+ fi
+
+ save_config config.h
+}