summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <sultan@gentoo.org>2022-05-06 11:57:34 +0200
committerStephan Hartmann <sultan@gentoo.org>2022-05-06 11:57:34 +0200
commit018a37ee9b2815597b4c95fcb7ffb8c0acdc6cbf (patch)
tree46a7ffe81c0984578e8238af1b3f2ef393b93003 /www-client
parentwww-client/microsoft-edge: amd64 stable (101.0.1210.39) (diff)
downloadgentoo-018a37ee9b2815597b4c95fcb7ffb8c0acdc6cbf.tar.gz
gentoo-018a37ee9b2815597b4c95fcb7ffb8c0acdc6cbf.tar.bz2
gentoo-018a37ee9b2815597b4c95fcb7ffb8c0acdc6cbf.zip
www-client/microsoft-edge: remove old
Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/microsoft-edge/Manifest1
-rw-r--r--www-client/microsoft-edge/microsoft-edge-101.0.1210.32.ebuild116
2 files changed, 0 insertions, 117 deletions
diff --git a/www-client/microsoft-edge/Manifest b/www-client/microsoft-edge/Manifest
index 5261dcb96fbe..ef23c39e5563 100644
--- a/www-client/microsoft-edge/Manifest
+++ b/www-client/microsoft-edge/Manifest
@@ -1,2 +1 @@
-DIST microsoft-edge-stable_101.0.1210.32-1_amd64.deb 119486916 BLAKE2B 79da63b26b7609bc04841053728765e6f5e1579b736b806af8f5df5b4c9102e42db903d003bd2ac21551cba34f5eadde9d884b03b8c66cc0691a443e83eba15d SHA512 d334d93ec2fe1d906840ee6382f70264d3dbf544dcad870ac75224e11909720c5daa916a7fee5986649c5fc68d1ffd38fbc4f463218357579bb1b69dfec9f5b8
DIST microsoft-edge-stable_101.0.1210.39-1_amd64.deb 119390660 BLAKE2B c45385f86db5cf20f055165e3bff145fd7ad0fdb3e1784af6982e7460b9d182c77774b97422982c646427232385f23980a8ee554d2b8ad566cc013cad0af06ee SHA512 f522318fa4853a7f84e7f2abbd4b91ce2586411d4244afd19d0ae19667b74fae46c9b4f4e7090c5ec9f365eb603b76f9d501b107e040d1e1a144cca2f15d5eee
diff --git a/www-client/microsoft-edge/microsoft-edge-101.0.1210.32.ebuild b/www-client/microsoft-edge/microsoft-edge-101.0.1210.32.ebuild
deleted file mode 100644
index 3db12034b572..000000000000
--- a/www-client/microsoft-edge/microsoft-edge-101.0.1210.32.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 2011-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-inherit chromium-2 desktop pax-utils unpacker xdg
-
-DESCRIPTION="The web browser from Microsoft"
-HOMEPAGE="https://www.microsoft.com/en-us/edge"
-
-if [[ ${PN} == microsoft-edge ]]; then
- MY_PN=${PN}-stable
-else
- MY_PN=${PN}
-fi
-
-KEYWORDS="-* amd64"
-
-MY_P="${MY_PN}_${PV}-1"
-
-SRC_URI="https://packages.microsoft.com/repos/edge/pool/main/m/${MY_PN}/${MY_P}_amd64.deb"
-
-LICENSE="microsoft-edge"
-SLOT="0"
-RESTRICT="bindist mirror strip"
-IUSE="+mip"
-
-RDEPEND="
- app-accessibility/at-spi2-atk:2
- app-accessibility/at-spi2-core:2
- app-misc/ca-certificates
- dev-libs/atk
- dev-libs/expat
- dev-libs/glib:2
- dev-libs/nspr
- dev-libs/nss
- media-fonts/liberation-fonts
- media-libs/alsa-lib
- media-libs/mesa[gbm(+)]
- net-misc/curl[ssl]
- net-print/cups
- sys-apps/dbus
- sys-apps/util-linux
- sys-libs/glibc
- x11-libs/cairo
- x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:3[X]
- x11-libs/libdrm
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXdamage
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXrandr
- x11-libs/libxcb
- x11-libs/libxkbcommon
- x11-libs/libxshmfence
- x11-libs/pango
- x11-misc/xdg-utils
- mip? ( app-crypt/libsecret )
-"
-
-QA_PREBUILT="*"
-QA_DESKTOP_FILE="usr/share/applications/microsoft-edge.*\\.desktop"
-S=${WORKDIR}
-EDGE_HOME="opt/microsoft/msedge${PN#microsoft-edge}"
-
-pkg_nofetch() {
- eerror "Please wait 24 hours and sync your tree before reporting a bug for microsoft-edge fetch failures."
-}
-
-pkg_pretend() {
- # Protect against people using autounmask overzealously
- use amd64 || die "microsoft-edge only works on amd64"
-}
-
-pkg_setup() {
- chromium_suid_sandbox_check_kernel_config
-}
-
-src_unpack() {
- :
-}
-
-src_install() {
- dodir /
- cd "${ED}" || die
- unpacker
-
- rm _gpgorigin || die
-
- rm -r etc usr/share/menu || die
- mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
-
- gzip -d usr/share/doc/${PF}/changelog.gz || die
- gzip -d usr/share/man/man1/${MY_PN}.1.gz || die
- if [[ -L usr/share/man/man1/${PN}.1.gz ]]; then
- rm usr/share/man/man1/${PN}.1.gz || die
- dosym ${MY_PN}.1 usr/share/man/man1/${PN}.1
- fi
-
- local suffix=
- [[ ${PN} == microsoft-edge-beta ]] && suffix=_beta
- [[ ${PN} == microsoft-edge-dev ]] && suffix=_dev
-
- local size
- for size in 16 24 32 48 64 128 256 ; do
- newicon -s ${size} "${EDGE_HOME}/product_logo_${size}${suffix}.png" ${PN}.png
- done
-
- if ! use mip; then
- rm "${EDGE_HOME}"/libmip_{core,protection_sdk}.so || die
- fi
-
- pax-mark m "${EDGE_HOME}/msedge"
-}