summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-09-08 15:26:33 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-09-08 15:34:21 +0200
commit033d61f705d54eb3b8c246faeec0d6be2809e84e (patch)
tree4b40eaae1c56b6db9f41399f9a54470082264848 /www-client
parentwww-client/firefox: amd64 stable (diff)
downloadgentoo-033d61f705d54eb3b8c246faeec0d6be2809e84e.tar.gz
gentoo-033d61f705d54eb3b8c246faeec0d6be2809e84e.tar.bz2
gentoo-033d61f705d54eb3b8c246faeec0d6be2809e84e.zip
www-client/firefox: patch ccache_stats function to avoid ccache calls
Backport of commit 41eaecf1fce33a9f8b733861105c979a2c9ccd9a. Bug: https://bugs.gentoo.org/665420 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/firefox-60.2.0.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/www-client/firefox/firefox-60.2.0.ebuild b/www-client/firefox/firefox-60.2.0.ebuild
index 9f2f3d4e3b20..dcc8e593f359 100644
--- a/www-client/firefox/firefox-60.2.0.ebuild
+++ b/www-client/firefox/firefox-60.2.0.ebuild
@@ -216,6 +216,13 @@ src_configure() {
# Only available on mozilla-overlay for experimentation -- Removed in Gentoo repo per bug 571180
#use egl && mozconfig_annotate 'Enable EGL as GL provider' --with-gl-provider=EGL
+ # Disable built-in ccache support to avoid sandbox violation, #665420
+ # Use FEATURES=ccache instead!
+ mozconfig_annotate '' --without-ccache
+ sed -i -e 's/ccache_stats = None/return None/' \
+ python/mozbuild/mozbuild/controller/building.py || \
+ die "Failed to disable ccache stats call"
+
# Setup api key for location services
echo -n "${_google_api_key}" > "${S}"/google-api-key
mozconfig_annotate '' --with-google-api-keyfile="${S}/google-api-key"