summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-10-26 17:07:39 +0800
committerIan Delaney <idella4@gentoo.org>2015-10-26 17:08:25 +0800
commit23ddc3e23c490b151da683ffbbf4181e9847748d (patch)
tree27ac1347cf4af6e5fecce4339c15765fe938ea1a /www-client
parentmedia-video/vlc: 2.2.0 version removed bug #564140. (diff)
downloadgentoo-23ddc3e23c490b151da683ffbbf4181e9847748d.tar.gz
gentoo-23ddc3e23c490b151da683ffbbf4181e9847748d.tar.bz2
gentoo-23ddc3e23c490b151da683ffbbf4181e9847748d.zip
www-client/qutebrowser: version bump to 0.4.1
Updated SRC_URI and added new dependency, the hardened profile masked (by hardened team) due to runtime failure with JIT. ebuild prepared and submitted by the package's own author "The-Compiler" with support from similar users. Commited by proxy-maintainers team due to extended absence of the developer maintainer. Fixes the gentoo bug Gentoo bug: #564140 Package-Manager: portage-2.2.23
Diffstat (limited to 'www-client')
-rw-r--r--www-client/qutebrowser/Manifest1
-rw-r--r--www-client/qutebrowser/qutebrowser-0.4.1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/www-client/qutebrowser/Manifest b/www-client/qutebrowser/Manifest
index 039da4ad9325..4b10d3120d70 100644
--- a/www-client/qutebrowser/Manifest
+++ b/www-client/qutebrowser/Manifest
@@ -1,2 +1,3 @@
DIST qutebrowser-0.2.1.tar.gz 892955 SHA256 0738377c1069d7d9ce1ff61e7425a139b44d21493d3a5c6338d697eb54f26d31 SHA512 9c49779515e6d7a3c9b93d50b51138f20292712f08de6f682db4f452c893796d9c66af7cca9ab7c18a5b7ddc147d62b7649572c7cdd416cc67c81cdf462c4f01 WHIRLPOOL 5f2f42163b59490eda25bad390c71113c8e7725a7bd8fa47240516a336364c76a7f97c516996f1ffcbc11025785070a30a6bccdcd66a06459ffbb24f874ed960
DIST qutebrowser-0.3.0.tar.gz 938380 SHA256 a0c02148bf76eb13691d9476e6ab8bc791993dfe7a408974ba31dd6eb6584461 SHA512 ee0e5808f7732c3c4cd577beb9c25227af0b6a3136bd20b80e18fef20a0d7ae34111f40db2bc0071e34a92c0b0dc94c8899f0953107b4926ff5ba2894fc818e0 WHIRLPOOL 95bd3e1a8c065a31d816ea8f7d85649d937aed6ddf85cb28ad309cab2d7ed0b9dc72672106321be9a2d0a085622114fc340122920c4c528750e70636d88930d3
+DIST qutebrowser-0.4.1.tar.gz 909363 SHA256 6e1022e4b349fd09bd8efa643d2411badb8305fee911d266db5dce66290a3ed7 SHA512 a31b3a99010babf26c4e9c867840d419e0f2f3acf874d9b61812744d1845914fd2505c8178976a14e57286842706431ad6305773e7087db6a4d4105b91c98aed WHIRLPOOL 2176e54fcff48b6b81629040b9826ea981b5eec963b506a54194d60a12a971763df9609f00958b30f61c209acf306faa2290f58d81590eed89e0b3705a2b9b9f
diff --git a/www-client/qutebrowser/qutebrowser-0.4.1.ebuild b/www-client/qutebrowser/qutebrowser-0.4.1.ebuild
new file mode 100644
index 000000000000..0bfb6986d259
--- /dev/null
+++ b/www-client/qutebrowser/qutebrowser-0.4.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python3_4 )
+
+inherit distutils-r1 eutils fdo-mime
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/The-Compiler/qutebrowser.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/The-Compiler/qutebrowser/releases/download/v${PV}/qutebrowser-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A keyboard-driven, vim-like browser based on PyQt5 and QtWebKit"
+HOMEPAGE="https://github.com/The-Compiler/qutebrowser"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="gstreamer test"
+
+COMMON_DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${COMMON_DEPEND}
+ app-text/asciidoc
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-python/jinja-2.7.3[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.0.2[${PYTHON_USEDEP}]
+ >=dev-python/pypeg2-2.15.1[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP},gui,network,printsupport,webkit,widgets]
+ dev-python/sip[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.11[${PYTHON_USEDEP}]
+ gstreamer? ( dev-qt/qtwebkit:5[gstreamer] )
+"
+
+RESTRICT="test"
+
+python_compile_all() {
+ if [[ ${PV} == "9999" ]]; then
+ "${PYTHON}" scripts/asciidoc2html.py || die "Failed generating docs"
+ fi
+
+ a2x -f manpage doc/${PN}.1.asciidoc || die "Failed generating man page"
+}
+
+python_test() {
+ py.test tests || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ doman doc/${PN}.1
+ dodoc {CHANGELOG,CONTRIBUTING,FAQ,README}.asciidoc
+
+ domenu ${PN}.desktop
+ doicon icons/${PN}.svg
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}