summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-03-02 14:53:04 +0100
committerPacho Ramos <pacho@gentoo.org>2023-03-02 14:53:04 +0100
commit292a6f3831e3c9b309caa64ae9f6b4eb43c37099 (patch)
tree1abaaee4ea536890232128f73ee056891c796011 /www-client
parentnet-im/rocketchat-desktop-bin: dosym does not need explicit die (diff)
downloadgentoo-292a6f3831e3c9b309caa64ae9f6b4eb43c37099.tar.gz
gentoo-292a6f3831e3c9b309caa64ae9f6b4eb43c37099.tar.bz2
gentoo-292a6f3831e3c9b309caa64ae9f6b4eb43c37099.zip
www-client/uget: add 2.2.3
Closes: https://bugs.gentoo.org/696764 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/uget/Manifest1
-rw-r--r--www-client/uget/files/uget-2.2.1-ayatana.patch28
-rw-r--r--www-client/uget/uget-2.2.3.ebuild64
3 files changed, 93 insertions, 0 deletions
diff --git a/www-client/uget/Manifest b/www-client/uget/Manifest
index c990ac19d540..a33c3aa1c163 100644
--- a/www-client/uget/Manifest
+++ b/www-client/uget/Manifest
@@ -1 +1,2 @@
DIST uget-2.2.1.tar.gz 1006697 BLAKE2B 2580cbcbe12d3001ada252a46358c4bc357fbe2ca4e3433e13ad95efb8e99d567a194db024eaf2ba58246a35937a5262be62aac4ee24272421f531dc72eeab20 SHA512 b76e5240e42cd0aa5bc47eb1a9cff0a0d8cdea87995455d72cf925923321f492200896ad904960e7f7462eb9655284f5b295b8a779b42223fe73a098a143576f
+DIST uget-2.2.3-1.tar.gz 1003976 BLAKE2B 1b599c9c5ba4cb5929c211c35382b9dbc6940e52bc995f150632dfc52f1429d26e15d330f53d1da9bd1ef296368cf3877673ee3fb5ab3f33d5ded4cf86b7b3d2 SHA512 a2359200486c60a79d53083f25c627d70f969880765e5c38897e7d35e94540c59e45f294dc10b0863ae812c449d232ad230cae90bb5e0ebded9bcabf2b4b7725
diff --git a/www-client/uget/files/uget-2.2.1-ayatana.patch b/www-client/uget/files/uget-2.2.1-ayatana.patch
new file mode 100644
index 000000000000..2cac1e750d56
--- /dev/null
+++ b/www-client/uget/files/uget-2.2.1-ayatana.patch
@@ -0,0 +1,28 @@
+--- a/configure.ac.old 2023-03-02 14:21:42.687929964 +0100
++++ b/configure.ac 2023-03-02 14:28:47.497666291 +0100
+@@ -169,12 +169,12 @@
+ [enable_appindicator="auto"]
+ )
+ if test x$enable_appindicator = xauto ; then
+- PKG_CHECK_EXISTS([appindicator3-0.1],
++ PKG_CHECK_EXISTS([ayatana-appindicator3-0.1],
+ [enable_appindicator="yes"],
+ [enable_appindicator="no"])
+ fi
+ if test x$enable_appindicator = xyes ; then
+- PKG_CHECK_MODULES(APP_INDICATOR, appindicator3-0.1)
++ PKG_CHECK_MODULES(APP_INDICATOR, ayatana-appindicator3-0.1)
+ AC_SUBST(APP_INDICATOR_CFLAGS)
+ AC_SUBST(APP_INDICATOR_LIBS)
+ AC_DEFINE(HAVE_APP_INDICATOR, 1, [Have AppIndicator])
+--- a/ui-gtk/UgtkTrayIcon.h.old 2023-03-02 14:32:54.816318966 +0100
++++ b/ui-gtk/UgtkTrayIcon.h 2023-03-02 14:33:20.186180008 +0100
+@@ -41,7 +41,7 @@
+ #include <UgtkConfig.h>
+
+ #ifdef HAVE_APP_INDICATOR
+-#include <libappindicator/app-indicator.h>
++#include <libayatana-appindicator/app-indicator.h>
+ #endif
+
+ #ifdef __cplusplus
diff --git a/www-client/uget/uget-2.2.3.ebuild b/www-client/uget/uget-2.2.3.ebuild
new file mode 100644
index 000000000000..b64f27cf31ef
--- /dev/null
+++ b/www-client/uget/uget-2.2.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools xdg
+
+DESCRIPTION="Download manager using gtk+ and libcurl"
+HOMEPAGE="http://www.ugetdm.com"
+SRC_URI="mirror://sourceforge/urlget/${P}-1.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="aria2 appindicator control-socket +gnutls gstreamer libnotify nls openssl rss"
+REQUIRED_USE="^^ ( gnutls openssl )"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libpcre
+ net-misc/curl
+ >=x11-libs/gtk+-3.4:3
+ gnutls? (
+ net-libs/gnutls
+ dev-libs/libgcrypt:0
+ )
+ aria2? ( net-misc/aria2[xmlrpc] )
+ appindicator? ( dev-libs/libayatana-appindicator )
+ gstreamer? ( media-libs/gstreamer:1.0 )
+ libnotify? ( x11-libs/libnotify )
+ openssl? ( dev-libs/openssl:0= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.1-fno-common.patch
+ # https://github.com/ugetdm/uget/issues/49
+ "${FILESDIR}"/${PN}-2.2.1-ayatana.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable appindicator)
+ $(use_enable control-socket unix_socket)
+ $(use_enable gstreamer)
+ $(use_enable libnotify notify)
+ $(use_enable nls)
+ $(use_enable rss rss_notify)
+ $(use_with gnutls)
+ $(use_with openssl)
+ )
+
+ econf "${myconf[@]}"
+}