summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-06 06:13:23 +0000
committerSam James <sam@gentoo.org>2022-11-06 06:14:47 +0000
commit2da168a8984c23f8bd5fe11d7a4fde5291e3ed6f (patch)
tree86a93386887e5916027423f7337a728b280ec2dc /www-client
parentwww-client/opera: remove old (diff)
downloadgentoo-2da168a8984c23f8bd5fe11d7a4fde5291e3ed6f.tar.gz
gentoo-2da168a8984c23f8bd5fe11d7a4fde5291e3ed6f.tar.bz2
gentoo-2da168a8984c23f8bd5fe11d7a4fde5291e3ed6f.zip
www-client/opera-beta: automated bump (93.0.4585.3)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/opera-beta/Manifest1
-rw-r--r--www-client/opera-beta/opera-beta-93.0.4585.3.ebuild159
2 files changed, 160 insertions, 0 deletions
diff --git a/www-client/opera-beta/Manifest b/www-client/opera-beta/Manifest
index 33b2a5096fd3..ab1a38467bb7 100644
--- a/www-client/opera-beta/Manifest
+++ b/www-client/opera-beta/Manifest
@@ -1,4 +1,5 @@
DIST opera-beta_91.0.4516.10_amd64.deb 88072156 BLAKE2B b92b6382cf13c03d49f26da4793167fc1c9c98aec366503bd264cbd2ac9f13c10eb929da5863fe90910139e25cddefe035dc4977b0784f97bac21c016444d436 SHA512 7b120b8b9c5b619844389c00ef6ed5b9fef3e709127c4ad4f7eae0cb09a2d74de2c926c605bb919b0f8442800cd5f1e54d82a4c8643fd3f9e386a8fcb8e4688e
DIST opera-beta_91.0.4516.3_amd64.deb 88063968 BLAKE2B 36bb20ff01d6d5a9a442fca497974fa8f43ffb6cd011e873acbc1ca6d1c4642d971ecfe949a6c905e78c48e47d20e0de29afafc5dc02ab6948bfd7ff60726b94 SHA512 cfaa8be684bf2fc003bd8ed6d05c377554581b47273bc6dcecbf3bda18a2b72d9e26aa201a58ab2e3545c32f8d9f7c7ee1f7b5bb6aa5c9fa4aac86b92f48b0bf
DIST opera-beta_91.0.4516.6_amd64.deb 88110388 BLAKE2B 9e032b21cd19161178441942f5a525507b3ac61abcc5b6409fd0d4b5d6d9ff08399e2461684fdeb922ebb52c99a974a031ea4365a0f78396c2f48075eb8973d9 SHA512 937bc3fb40db72f53824c06f1e4884bd42a022c594d64bc87975535f68b7d5e63e1ea8fb31e5d090021a85bfe3a15b14698217f8d5631dde615b02229dcb472d
+DIST opera-beta_93.0.4585.3_amd64.deb 99354024 BLAKE2B 5463de57611b1b803eccfe19faeb5c2320bd60615b109e44085141b30d1af0bc0699cb5fe5b4a0bcd6f864c3d6d4faf83572bbeed5ff6c08ae849b63811c7395 SHA512 d4d438d6354999f43654f8e93e3b25d050a4bd1cc97cc354946a0ca0de496590d6e35e49b5178e3199be4efefbb1ab46a59dd7f14d891d12c72933b8b9db5279
DIST opera-ffmpeg-codecs-105.0.5195.19.tar.xz 1413912 BLAKE2B 52e951eb93b2ed91b4053002a43e79884c46aab7b2218a08717927e3f43bc247b340bafc18488fcf6596d4441c318d6fe734869c8daad047107aeff0fade4c71 SHA512 f29bc9146fa67b71fa2df83a9b731e9cb4ce7827a573b63fa1c10baba5980f0375cfab2c6e1edce01415753b6f3e0b65de7d361d9400550d7a2d637236e2e414
diff --git a/www-client/opera-beta/opera-beta-93.0.4585.3.ebuild b/www-client/opera-beta/opera-beta-93.0.4585.3.ebuild
new file mode 100644
index 000000000000..861830ed07f3
--- /dev/null
+++ b/www-client/opera-beta/opera-beta-93.0.4585.3.ebuild
@@ -0,0 +1,159 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+CHROMIUM_LANGS="
+ bg bn ca cs da de el en-GB en-US es-419 es fil fi fr hi hr hu id
+ it ja ko lt lv ms nb nl pl pt-BR pt-PT ro ru sk sr sv sw ta te th tr uk vi
+ zh-CN zh-TW
+"
+
+# These are intended for ebuild maintainer use to force RPM if DEB is not available.
+: ${OPERA_FORCE_RPM=no}
+
+inherit chromium-2 pax-utils xdg
+
+if [[ ${OPERA_FORCE_RPM} == yes ]]; then
+ inherit rpm
+ OPERA_ARCHIVE_EXT="rpm"
+else
+ inherit unpacker
+ OPERA_ARCHIVE_EXT="deb"
+fi
+
+DESCRIPTION="A fast and secure web browser"
+HOMEPAGE="https://www.opera.com/"
+LICENSE="OPERA-2018"
+SLOT="0"
+
+SRC_URI_BASE=(
+ "https://download1.operacdn.com/pub/${PN}"
+ "https://download2.operacdn.com/pub/${PN}"
+ "https://download3.operacdn.com/pub/${PN}"
+ "https://download4.operacdn.com/pub/${PN}"
+)
+
+if [[ ${PN} == opera ]]; then
+ MY_PN=${PN}-stable
+ SRC_URI_BASE=( "${SRC_URI_BASE[@]/%//desktop}" )
+else
+ MY_PN=${PN}
+fi
+
+KEYWORDS="-* ~amd64"
+
+FFMPEG_VERSION="105.0.5195.19"
+
+SRC_URI="${SRC_URI_BASE[@]/%//${PV}/linux/${MY_PN}_${PV}_amd64.${OPERA_ARCHIVE_EXT}}
+ proprietary-codecs? (
+ mirror+https://dev.gentoo.org/~sultan/distfiles/www-client/opera/opera-ffmpeg-codecs-${FFMPEG_VERSION}.tar.xz
+ )"
+
+IUSE="+proprietary-codecs suid"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ || (
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ ( app-accessibility/at-spi2-atk dev-libs/atk )
+ )
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ gnome-base/gsettings-desktop-schemas
+ media-libs/alsa-lib
+ media-libs/mesa[gbm(+)]
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/libxshmfence
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/pango
+"
+
+QA_PREBUILT="*"
+S=${WORKDIR}
+OPERA_HOME="opt/opera${PN#opera}"
+
+pkg_pretend() {
+ # Protect against people using autounmask overzealously
+ use amd64 || die "opera only works on amd64"
+}
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ dodir /
+ cd "${ED}" || die
+ if [[ ${OPERA_FORCE_RPM} == yes ]]; then
+ rpm_src_unpack "${A[0]}"
+ else
+ unpacker
+ fi
+
+ # move to /opt, bug #573052
+ mkdir -p "${OPERA_HOME%${PN}}"
+ if [[ ${OPERA_FORCE_RPM} == yes ]]; then
+ mv "usr/lib64/${PN}" "${OPERA_HOME%${PN}}" || die
+ else
+ mv "usr/lib/x86_64-linux-gnu/${PN}" "${OPERA_HOME%${PN}}" || die
+ fi
+ rm -r "usr/lib" || die
+
+ # disable auto update
+ rm "${OPERA_HOME}/${PN%-*}_autoupdate"{,.licenses,.version} || die
+
+ if [[ ${OPERA_FORCE_RPM} == yes ]]; then
+ rm "${OPERA_HOME}/setup_repo.sh" || die
+ else
+ rm -r "usr/share/lintian" || die
+
+ # fix docs
+ mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
+ gzip -d usr/share/doc/${PF}/changelog.gz || die
+ fi
+
+ # fix desktop file
+ sed -i \
+ -e 's|^TargetEnvironment|X-&|g' \
+ usr/share/applications/${PN}.desktop || die
+
+ # remove unused language packs
+ pushd "${OPERA_HOME}/localization" > /dev/null || die
+ chromium_remove_language_paks
+ popd > /dev/null || die
+
+ # setup opera symlink
+ rm "usr/bin/${PN}" || die
+ dosym "../../${OPERA_HOME}/${PN}" "/usr/bin/${PN}"
+
+ # install proprietary codecs
+ rm "${OPERA_HOME}/resources/ffmpeg_preload_config.json" || die
+ if use proprietary-codecs; then
+ mv lib_extra "${OPERA_HOME}"
+ fi
+
+ # pax mark opera, bug #562038
+ pax-mark m "${OPERA_HOME}/opera"
+ # enable suid sandbox if requested
+ use suid && fperms 4711 "${OPERA_HOME}/opera_sandbox"
+}