summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-01 00:03:15 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-01 02:33:11 +0100
commit5fdad3d06f1617fc43fed221b06a8285bd4a1e05 (patch)
tree2287f1e31696bb6dfd6f34219158af4162039e5d /www-client
parentnet-mail/dovecot: bump, fixup for problem caused by patch for CVE-2017-15132 (diff)
downloadgentoo-5fdad3d06f1617fc43fed221b06a8285bd4a1e05.tar.gz
gentoo-5fdad3d06f1617fc43fed221b06a8285bd4a1e05.tar.bz2
gentoo-5fdad3d06f1617fc43fed221b06a8285bd4a1e05.zip
www-client/qupzilla: 2.2.5 version bump
Package-Manager: Portage-2.3.21, Repoman-2.3.6
Diffstat (limited to 'www-client')
-rw-r--r--www-client/qupzilla/Manifest1
-rw-r--r--www-client/qupzilla/qupzilla-2.2.5.ebuild120
2 files changed, 121 insertions, 0 deletions
diff --git a/www-client/qupzilla/Manifest b/www-client/qupzilla/Manifest
index 1bcc8ee72396..6ac3a86b4ca0 100644
--- a/www-client/qupzilla/Manifest
+++ b/www-client/qupzilla/Manifest
@@ -1,4 +1,5 @@
DIST QupZilla-2.1.2.tar.xz 2767560 BLAKE2B 4d012f86618680a112c227d07d71c24d6fc2c517be63fe172abc99eb0c20e8b2756e2cc51049b0dff91e1739357121afe0b1e7328df372370dec969995447eb0 SHA512 d09a394ba70ae0f7f908940a26d6554a3706b6638c197d16b75e1e5855f76015c8e13b7155c40dacee3a38080a0c277d9410eaf07cf912dc4b295eafe1ff6343
DIST QupZilla-2.2.4.tar.xz 2525660 BLAKE2B b94841d12c8f374df2fb4a8773d9d7e6b1b6b35db51ddd20d94f7a2cb70a345226baff64bf15be756e3911fa86714588e9e8c51842562ca558f1abd537ce3ffa SHA512 07a71fb3eb52356589871fb458fa3e931ee01f87e67ecbba614f715181130f9bec53e2f6df2c83f08d0223990f8bbe225ea21171e048574b265ae20576b48053
+DIST QupZilla-2.2.5.tar.xz 2532760 BLAKE2B b9bf3f5415aa5a06397a7b9f98f56a16a7c9238d561bf6a2583214e43b23c53c825c8274b51ff0e34ced8aac6077c12dad60968d88abe810ccb35dbd2a457e0e SHA512 78e02141f18268a5f31a896c49e4f6cbd709e609dfcdb50277fc20123526e5316b79ede612dcac74ff07103334c381e4d657b18b6e187a10983d5a44a649858a
DIST qupzilla-plugins-2016.05.02.tar.gz 425314 BLAKE2B c10f9f3fe17f36b91a77b4bdb15b3d0c63160c50b558ba2f180ec83b2d226b15baea51e9125e0c72d3960c2f99f8f3753d90c7eeb4b88eb07381da19bc3ea777 SHA512 b294ecb2372b3267603a43bc7412ab75d2cd29a8c4667331f0d2c74e3b0b99d0c2a005b9e4854c6d777894522bba9fb3b1607e85e8da6dcbaa760c9ddc6288f2
DIST qupzilla-plugins-2017.03.26.tar.gz 430926 BLAKE2B d5db8c854886b1af8db20aaffe9a244600259d4f8cbc40890bf0f1075f790afe1a6e2ac19abe06c585eff0353127a3a7b1b1b79013bfc1b81bf5df750e5d9d20 SHA512 3b04b41208dddd25fd58937986cf12f2b521cf78a64380b915d46735ada3f4776f914056c5511daa781c89867d0309af7cbf833eb71dfa4b14b6b9ba25d80315
diff --git a/www-client/qupzilla/qupzilla-2.2.5.ebuild b/www-client/qupzilla/qupzilla-2.2.5.ebuild
new file mode 100644
index 000000000000..acb97d50c177
--- /dev/null
+++ b/www-client/qupzilla/qupzilla-2.2.5.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PLOCALES="ar_SA bg_BG ca_ES cs_CZ da_DK de_DE el_GR es_419 es_ES es_MX es_VE
+ eu_ES fa_IR fi_FI fr_FR gl_ES he_IL hr_HR hu_HU id_ID is it_IT ja_JP
+ ka_GE lg lt lv_LV nb_NO nl_NL nqo pl_PL pt_BR pt_PT ro_RO ru_RU sk_SK
+ sl_SI sr sr@ijekavian sr@ijekavianlatin sr@latin sv_SE tr_TR uk_UA
+ uz@Latn zh_CN zh_HK zh_TW"
+
+PLUGINS_HASH="80fea7df7765fdf9c9c64fdb667052b25f1c0a22"
+PLUGINS_VERSION="2017.03.26" # if there are no updates, we can use the older archive
+
+inherit gnome2-utils l10n qmake-utils xdg-utils
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/QupZilla/${PN}.git"
+else
+ MY_P=QupZilla-${PV}
+ SRC_URI="https://github.com/QupZilla/${PN}/releases/download/v${PV}/${MY_P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S=${WORKDIR}/${MY_P}
+fi
+
+DESCRIPTION="A cross-platform web browser using QtWebEngine"
+HOMEPAGE="https://www.qupzilla.com/"
+SRC_URI+=" https://github.com/QupZilla/${PN}-plugins/archive/${PLUGINS_HASH}.tar.gz -> ${PN}-plugins-${PLUGINS_VERSION}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="dbus debug gnome-keyring kwallet libressl nonblockdialogs"
+
+COMMON_DEPEND="
+ >=dev-qt/qtcore-5.8:5
+ >=dev-qt/qtdeclarative-5.8:5[widgets]
+ >=dev-qt/qtgui-5.8:5
+ >=dev-qt/qtnetwork-5.8:5[ssl]
+ >=dev-qt/qtprintsupport-5.8:5
+ >=dev-qt/qtsql-5.8:5[sqlite]
+ >=dev-qt/qtwebchannel-5.8:5
+ >=dev-qt/qtwebengine-5.8:5[widgets]
+ >=dev-qt/qtwidgets-5.8:5
+ >=dev-qt/qtx11extras-5.8:5
+ x11-libs/libxcb:=
+ dbus? ( >=dev-qt/qtdbus-5.8:5 )
+ gnome-keyring? ( gnome-base/gnome-keyring )
+ kwallet? ( kde-frameworks/kwallet:5 )
+ libressl? ( dev-libs/libressl:= )
+ !libressl? ( dev-libs/openssl:0= )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-qt/linguist-tools-5.8:5
+ >=dev-qt/qtconcurrent-5.8:5
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-qt/qtsvg-5.8:5
+"
+
+DOCS=( AUTHORS BUILDING.md CHANGELOG FAQ README.md )
+
+src_unpack() {
+ if [[ ${PV} == *9999 ]]; then
+ git-r3_src_unpack
+ fi
+ default
+}
+
+src_prepare() {
+ # get extra plugins into qupzilla build tree
+ mv "${WORKDIR}"/${PN}-plugins-${PLUGINS_HASH}/plugins/* src/plugins/ || die
+
+ rm_loc() {
+ # remove localizations the user has not specified
+ sed -i -e "/${1}.ts/d" translations/translations.pri || die
+ rm translations/${1}.ts || die
+ }
+
+ # remove outdated prebuilt localizations
+ rm -rf bin/locale || die
+
+ # remove empty locale
+ rm translations/empty.ts || die
+
+ l10n_find_plocales_changes translations '' .ts
+ l10n_for_each_disabled_locale_do rm_loc
+
+ default
+}
+
+src_configure() {
+ # see BUILDING document for explanation of options
+ export \
+ QUPZILLA_PREFIX="${EPREFIX}/usr" \
+ USE_LIBPATH="${EPREFIX}/usr/$(get_libdir)" \
+ DEBUG_BUILD=$(usex debug true '') \
+ DISABLE_DBUS=$(usex dbus '' true) \
+ GNOME_INTEGRATION=$(usex gnome-keyring true '') \
+ KDE_INTEGRATION=$(usex kwallet true '') \
+ NONBLOCK_JS_DIALOGS=$(usex nonblockdialogs true '')
+
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}