summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-12-16 18:24:04 -0500
committerMike Gilbert <floppym@gentoo.org>2017-12-16 18:24:18 -0500
commit7803280172901a7f2b13d7886fe60a0eb69925c4 (patch)
treece3517476009443bdeb8eab596642426e505aaf6 /www-client
parentdev-libs/qjson: Drop old (diff)
downloadgentoo-7803280172901a7f2b13d7886fe60a0eb69925c4.tar.gz
gentoo-7803280172901a7f2b13d7886fe60a0eb69925c4.tar.bz2
gentoo-7803280172901a7f2b13d7886fe60a0eb69925c4.zip
www-client/chromium: fix build with clang
Closes: https://bugs.gentoo.org/637654 Package-Manager: Portage-2.3.19_p1, Repoman-2.3.6_p35
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/chromium-64.0.3282.24.ebuild1
-rw-r--r--www-client/chromium/files/chromium-clang-r2.patch21
2 files changed, 22 insertions, 0 deletions
diff --git a/www-client/chromium/chromium-64.0.3282.24.ebuild b/www-client/chromium/chromium-64.0.3282.24.ebuild
index bf7155220b07..7737358b3393 100644
--- a/www-client/chromium/chromium-64.0.3282.24.ebuild
+++ b/www-client/chromium/chromium-64.0.3282.24.ebuild
@@ -147,6 +147,7 @@ PATCHES=(
"${FILESDIR}/chromium-webrtc-r0.patch"
"${FILESDIR}/chromium-memcpy-r0.patch"
"${FILESDIR}/chromium-cups-r0.patch"
+ "${FILESDIR}/chromium-clang-r2.patch"
)
pre_build_checks() {
diff --git a/www-client/chromium/files/chromium-clang-r2.patch b/www-client/chromium/files/chromium-clang-r2.patch
new file mode 100644
index 000000000000..aaee16717643
--- /dev/null
+++ b/www-client/chromium/files/chromium-clang-r2.patch
@@ -0,0 +1,21 @@
+--- a/build/config/compiler/BUILD.gn
++++ b/build/config/compiler/BUILD.gn
+@@ -422,18 +422,6 @@
+ cflags += [ "-fcolor-diagnostics" ]
+ }
+
+- # TODO(hans): Remove this once Clang generates better optimized debug info by
+- # default. https://crbug.com/765793
+- if (is_clang && !is_nacl && current_toolchain == host_toolchain &&
+- target_os != "chromeos") {
+- cflags += [
+- "-Xclang",
+- "-mllvm",
+- "-Xclang",
+- "-instcombine-lower-dbg-declare=0",
+- ]
+- }
+-
+ # Print absolute paths in diagnostics. There is no precedent for doing this
+ # on Linux/Mac (GCC doesn't support it), but MSVC does this with /FC and
+ # Windows developers rely on it (crbug.com/636109) so only do this on Windows.