summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPawel Hajdan, Jr <phajdan.jr@gentoo.org>2017-09-30 18:26:21 +0200
committerPawel Hajdan, Jr <phajdan.jr@gentoo.org>2017-09-30 18:26:21 +0200
commit7843d29ab07411a9c70962fb90b4cd1546910242 (patch)
tree58d57537ea7307e85a59b4689dc1d5e093cff555 /www-client
parentx11-plugins/pidgin-sipe: Drop old (diff)
downloadgentoo-7843d29ab07411a9c70962fb90b4cd1546910242.tar.gz
gentoo-7843d29ab07411a9c70962fb90b4cd1546910242.tar.bz2
gentoo-7843d29ab07411a9c70962fb90b4cd1546910242.zip
www-client/chromium: fix remaining gcc-5 issues
Bug: https://bugs.gentoo.org/show_bug.cgi?id=628284 Package-Manager: Portage-2.3.8, Repoman-2.3.1
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/chromium-62.0.3202.18.ebuild2
-rw-r--r--www-client/chromium/chromium-63.0.3223.8.ebuild2
-rw-r--r--www-client/chromium/files/chromium-gcc5-r3.patch98
-rw-r--r--www-client/chromium/files/chromium-gcc5-r4.patch98
4 files changed, 198 insertions, 2 deletions
diff --git a/www-client/chromium/chromium-62.0.3202.18.ebuild b/www-client/chromium/chromium-62.0.3202.18.ebuild
index 2d08ef65db0a..72bfe6ed14d9 100644
--- a/www-client/chromium/chromium-62.0.3202.18.ebuild
+++ b/www-client/chromium/chromium-62.0.3202.18.ebuild
@@ -144,7 +144,7 @@ GTK+ icon theme.
PATCHES=(
"${FILESDIR}/${PN}-widevine-r1.patch"
"${FILESDIR}/${PN}-FORTIFY_SOURCE-r2.patch"
- "${FILESDIR}/${PN}-gcc5-r2.patch"
+ "${FILESDIR}/${PN}-gcc5-r3.patch"
"${FILESDIR}/${PN}-gn-bootstrap-r17.patch"
"${FILESDIR}/${PN}-glibc2.26-r1.patch"
)
diff --git a/www-client/chromium/chromium-63.0.3223.8.ebuild b/www-client/chromium/chromium-63.0.3223.8.ebuild
index 222538cbccb8..809c36dc7ab4 100644
--- a/www-client/chromium/chromium-63.0.3223.8.ebuild
+++ b/www-client/chromium/chromium-63.0.3223.8.ebuild
@@ -144,7 +144,7 @@ GTK+ icon theme.
PATCHES=(
"${FILESDIR}/${PN}-widevine-r1.patch"
"${FILESDIR}/${PN}-FORTIFY_SOURCE-r2.patch"
- "${FILESDIR}/${PN}-gcc5-r2.patch"
+ "${FILESDIR}/${PN}-gcc5-r4.patch"
"${FILESDIR}/${PN}-gn-bootstrap-r20.patch"
)
diff --git a/www-client/chromium/files/chromium-gcc5-r3.patch b/www-client/chromium/files/chromium-gcc5-r3.patch
new file mode 100644
index 000000000000..7605df6b145a
--- /dev/null
+++ b/www-client/chromium/files/chromium-gcc5-r3.patch
@@ -0,0 +1,98 @@
+--- a/third_party/WebKit/Source/platform/wtf/typed_arrays/ArrayBufferContents.h
++++ b/third_party/WebKit/Source/platform/wtf/typed_arrays/ArrayBufferContents.h
+@@ -63,7 +63,7 @@ class WTF_EXPORT ArrayBufferContents {
+ allocation_length_(0),
+ data_(data),
+ data_length_(0),
+- kind_(AllocationKind::kNormal),
++ kind_(WTF::ArrayBufferContents::AllocationKind::kNormal),
+ deleter_(deleter) {}
+ DataHandle(void* allocation_base,
+ size_t allocation_length,
+@@ -94,11 +94,11 @@ class WTF_EXPORT ArrayBufferContents {
+ reinterpret_cast<uintptr_t>(allocation_base_) +
+ allocation_length_);
+ switch (kind_) {
+- case AllocationKind::kNormal:
++ case WTF::ArrayBufferContents::AllocationKind::kNormal:
+ DCHECK(deleter_);
+ deleter_(data_);
+ return;
+- case AllocationKind::kReservation:
++ case WTF::ArrayBufferContents::AllocationKind::kReservation:
+ ReleaseReservedMemory(allocation_base_, allocation_length_);
+ return;
+ }
+--- a/third_party/webrtc/modules/audio_processing/aec3/aec_state.cc.orig 2017-08-15 12:45:59.433532111 +0000
++++ b/third_party/webrtc/modules/audio_processing/aec3/aec_state.cc 2017-08-15 17:52:59.691328825 +0000
+@@ -10,7 +10,7 @@
+
+ #include "webrtc/modules/audio_processing/aec3/aec_state.h"
+
+-#include <math.h>
++#include <cmath>
+ #include <numeric>
+ #include <vector>
+
+--- a/gpu/ipc/common/mailbox_struct_traits.h
++++ b/gpu/ipc/common/mailbox_struct_traits.h
+@@ -15,7 +15,7 @@ namespace mojo {
+ template <>
+ struct StructTraits<gpu::mojom::MailboxDataView, gpu::Mailbox> {
+ static base::span<const int8_t> name(const gpu::Mailbox& mailbox) {
+- return mailbox.name;
++ return base::make_span(mailbox.name);
+ }
+ static bool Read(gpu::mojom::MailboxDataView data, gpu::Mailbox* out);
+ };
+--- a/services/viz/public/cpp/compositing/filter_operation_struct_traits.h
++++ b/services/viz/public/cpp/compositing/filter_operation_struct_traits.h
+@@ -134,7 +134,7 @@ struct StructTraits<viz::mojom::FilterOperationDataView, cc::FilterOperation> {
+ static base::span<const float> matrix(const cc::FilterOperation& operation) {
+ if (operation.type() != cc::FilterOperation::COLOR_MATRIX)
+ return base::span<const float>();
+- return operation.matrix();
++ return base::make_span(operation.matrix());
+ }
+
+ static base::span<const gfx::Rect> shape(
+--- a/services/viz/public/cpp/compositing/quads_struct_traits.h
++++ b/services/viz/public/cpp/compositing/quads_struct_traits.h
+@@ -284,7 +284,7 @@
+
+ static base::span<const float> vertex_opacity(const cc::DrawQuad& input) {
+ const cc::TextureDrawQuad* quad = cc::TextureDrawQuad::MaterialCast(&input);
+- return quad->vertex_opacity;
++ return base::make_span(quad->vertex_opacity);
+ }
+
+ static bool y_flipped(const cc::DrawQuad& input) {
+--- a/third_party/WebKit/Source/platform/exported/WebCORS.cpp
++++ b/third_party/WebKit/Source/platform/exported/WebCORS.cpp
+@@ -480,7 +480,7 @@ WebString AccessControlErrorString(
+ }
+ default:
+ NOTREACHED();
+- return "";
++ return WebString();
+ }
+ }
+
+@@ -512,7 +512,7 @@ WebString PreflightErrorString(const PreflightStatus status,
+ }
+ default:
+ NOTREACHED();
+- return "";
++ return WebString();
+ }
+ }
+
+@@ -533,7 +533,7 @@ WebString RedirectErrorString(const RedirectStatus status,
+ }
+ default:
+ NOTREACHED();
+- return "";
++ return WebString();
+ }
+ }
+
diff --git a/www-client/chromium/files/chromium-gcc5-r4.patch b/www-client/chromium/files/chromium-gcc5-r4.patch
new file mode 100644
index 000000000000..cb978d58a060
--- /dev/null
+++ b/www-client/chromium/files/chromium-gcc5-r4.patch
@@ -0,0 +1,98 @@
+--- a/third_party/WebKit/Source/platform/wtf/typed_arrays/ArrayBufferContents.h
++++ b/third_party/WebKit/Source/platform/wtf/typed_arrays/ArrayBufferContents.h
+@@ -63,7 +63,7 @@ class WTF_EXPORT ArrayBufferContents {
+ allocation_length_(0),
+ data_(data),
+ data_length_(0),
+- kind_(AllocationKind::kNormal),
++ kind_(WTF::ArrayBufferContents::AllocationKind::kNormal),
+ deleter_(deleter) {}
+ DataHandle(void* allocation_base,
+ size_t allocation_length,
+@@ -94,11 +94,11 @@ class WTF_EXPORT ArrayBufferContents {
+ reinterpret_cast<uintptr_t>(allocation_base_) +
+ allocation_length_);
+ switch (kind_) {
+- case AllocationKind::kNormal:
++ case WTF::ArrayBufferContents::AllocationKind::kNormal:
+ DCHECK(deleter_);
+ deleter_(data_);
+ return;
+- case AllocationKind::kReservation:
++ case WTF::ArrayBufferContents::AllocationKind::kReservation:
+ ReleaseReservedMemory(allocation_base_, allocation_length_);
+ return;
+ }
+--- a/third_party/webrtc/modules/audio_processing/aec3/aec_state.cc.orig 2017-08-15 12:45:59.433532111 +0000
++++ b/third_party/webrtc/modules/audio_processing/aec3/aec_state.cc 2017-08-15 17:52:59.691328825 +0000
+@@ -10,7 +10,7 @@
+
+ #include "webrtc/modules/audio_processing/aec3/aec_state.h"
+
+-#include <math.h>
++#include <cmath>
+ #include <numeric>
+ #include <vector>
+
+--- a/gpu/ipc/common/mailbox_struct_traits.h
++++ b/gpu/ipc/common/mailbox_struct_traits.h
+@@ -15,7 +15,7 @@ namespace mojo {
+ template <>
+ struct StructTraits<gpu::mojom::MailboxDataView, gpu::Mailbox> {
+ static base::span<const int8_t> name(const gpu::Mailbox& mailbox) {
+- return mailbox.name;
++ return base::make_span(mailbox.name);
+ }
+ static bool Read(gpu::mojom::MailboxDataView data, gpu::Mailbox* out);
+ };
+--- a/services/viz/public/cpp/compositing/filter_operation_struct_traits.h
++++ b/services/viz/public/cpp/compositing/filter_operation_struct_traits.h
+@@ -134,7 +134,7 @@ struct StructTraits<viz::mojom::FilterOperationDataView, cc::FilterOperation> {
+ static base::span<const float> matrix(const cc::FilterOperation& operation) {
+ if (operation.type() != cc::FilterOperation::COLOR_MATRIX)
+ return base::span<const float>();
+- return operation.matrix();
++ return base::make_span(operation.matrix());
+ }
+
+ static base::span<const gfx::Rect> shape(
+--- a/services/viz/public/cpp/compositing/quads_struct_traits.h
++++ b/services/viz/public/cpp/compositing/quads_struct_traits.h
+@@ -303,7 +303,7 @@ struct StructTraits<viz::mojom::TextureQuadStateDataView, viz::DrawQuad> {
+ static base::span<const float> vertex_opacity(const viz::DrawQuad& input) {
+ const viz::TextureDrawQuad* quad =
+ viz::TextureDrawQuad::MaterialCast(&input);
+- return quad->vertex_opacity;
++ return base::make_span(quad->vertex_opacity);
+ }
+
+ static bool y_flipped(const viz::DrawQuad& input) {
+--- a/third_party/WebKit/Source/platform/exported/WebCORS.cpp
++++ b/third_party/WebKit/Source/platform/exported/WebCORS.cpp
+@@ -480,7 +480,7 @@ WebString AccessControlErrorString(
+ }
+ default:
+ NOTREACHED();
+- return "";
++ return WebString();
+ }
+ }
+
+@@ -512,7 +512,7 @@ WebString PreflightErrorString(const PreflightStatus status,
+ }
+ default:
+ NOTREACHED();
+- return "";
++ return WebString();
+ }
+ }
+
+@@ -533,7 +533,7 @@ WebString RedirectErrorString(const RedirectStatus status,
+ }
+ default:
+ NOTREACHED();
+- return "";
++ return WebString();
+ }
+ }
+