summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-12-21 14:36:27 +0100
committerPacho Ramos <pacho@gentoo.org>2021-12-21 14:36:27 +0100
commit86c5a4847deca695992db4e989c24cf182368af8 (patch)
tree6daa258347be1cd1acf0c9f2556981f8a0192c24 /www-client
parentapp-misc/jdupes: drop 1.20.2 (diff)
downloadgentoo-86c5a4847deca695992db4e989c24cf182368af8.tar.gz
gentoo-86c5a4847deca695992db4e989c24cf182368af8.tar.bz2
gentoo-86c5a4847deca695992db4e989c24cf182368af8.zip
www-client/epiphany: Bump to 40.6
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-40.6.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index e62b71038e64..325ceb613c26 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1 +1,2 @@
DIST epiphany-40.5.tar.xz 5380340 BLAKE2B 60dcdacd8fc199e68d2009c841e5d80e54c6246b9f39f9d6523fb8dcd837dba4a949911643c634abb5c53e08473e92b5bde90709ec8650cc23c4aceaeac14edd SHA512 939fc749723c87457a73b90fadb37e8c6db0996ada73d5c859ff3f9b8a2401bca369a8145336542a169b006a9c0e02f6642a1a39b3770654d30cb28b55e69972
+DIST epiphany-40.6.tar.xz 5380620 BLAKE2B 43a0ba03ebab5af074785beecacbf7279f0ee44c7f12467441fc026d8e48c16a1d3391080d2960d6b72027995b9fc203c15cbfa17db35cbf010edfa9d472422c SHA512 92805afe14323547c816beb43da104c05b62c59b64d7e3dc194f8e89be3abf309261310da11ff5c5ba99809794b796de9911316d77663a7c51b3a79b63fe4e1f
diff --git a/www-client/epiphany/epiphany-40.6.ebuild b/www-client/epiphany/epiphany-40.6.ebuild
new file mode 100644
index 000000000000..e46b4d99cdf3
--- /dev/null
+++ b/www-client/epiphany/epiphany-40.6.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.64.0:2
+ >=x11-libs/gtk+-3.24.0:3
+ >=dev-libs/nettle-3.4:=
+ >=net-libs/webkit-gtk-2.31.1:4=
+ >=x11-libs/cairo-1.2
+ >=app-crypt/gcr-3.5.5:=[gtk]
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ gnome-base/gsettings-desktop-schemas
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.6
+ app-arch/libarchive:=
+ >=dev-libs/libdazzle-3.37.1
+ >=gui-libs/libhandy-1.1.0:1=
+ >=app-crypt/libsecret-0.19
+ >=net-libs/libsoup-2.48.0:2.4
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-db/sqlite-3.22:3
+ dev-libs/gmp:0=
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+# appstream-glib needed for appdata.xml gettext translation
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Allow /var/tmp prefixed recursive delete (due to package manager setting TMPDIR)
+ "${FILESDIR}"/var-tmp-tests.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Ddeveloper_mode=false
+ -Dlibportal=disabled
+ # maybe enable later if network-sandbox is off, but in 3.32.4 the network test
+ # is commented out upstream anyway
+ -Dnetwork_tests=disabled
+ -Dtech_preview=false
+ $(meson_feature test unit_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version net-libs/webkit-gtk[jpeg2k]; then
+ ewarn "Your net-libs/webkit-gtk is built without USE=jpeg2k."
+ ewarn "Various image galleries/managers may be broken."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}