summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-22 05:26:53 +0000
committerSam James <sam@gentoo.org>2022-11-22 05:26:53 +0000
commit9023aa72a36857b93b3bc49b10623ba1a6ad6464 (patch)
tree22027564a55a5cc881b598e5b080e74da610b221 /www-client
parentwww-client/microsoft-edge: amd64 stable (107.0.1418.56) (diff)
downloadgentoo-9023aa72a36857b93b3bc49b10623ba1a6ad6464.tar.gz
gentoo-9023aa72a36857b93b3bc49b10623ba1a6ad6464.tar.bz2
gentoo-9023aa72a36857b93b3bc49b10623ba1a6ad6464.zip
www-client/microsoft-edge: remove old
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/microsoft-edge/Manifest1
-rw-r--r--www-client/microsoft-edge/microsoft-edge-107.0.1418.52.ebuild117
2 files changed, 0 insertions, 118 deletions
diff --git a/www-client/microsoft-edge/Manifest b/www-client/microsoft-edge/Manifest
index b6df72d74a99..7d35eb684d26 100644
--- a/www-client/microsoft-edge/Manifest
+++ b/www-client/microsoft-edge/Manifest
@@ -1,2 +1 @@
-DIST microsoft-edge-stable_107.0.1418.52-1_amd64.deb 134362110 BLAKE2B d24016448c20c39a6aa535bc03793e0041c8763cc68cb00edf2c8c606d9f066393d5f8c73f54722c2a7f6f1d5736f4d7571cbe284273863914127922b6ec747f SHA512 6150602bd5b83b988f8224e6c882118a1af9ac53d53d1450f0c86e796d842e1cc0abb094dbd68b969bd0de56f0790de0fdf92ba6bb60d72b34c2b23ddf48ff58
DIST microsoft-edge-stable_107.0.1418.56-1_amd64.deb 134321646 BLAKE2B 04e6581386a8260a3e895ce2722364df4cb8d43e4bff975b8b56743348b3dc44aebf1ff0b8c6f3efa65e1de48bcc86e11d3d42abc565cd43417fd68c64f11cd7 SHA512 5c0e24127e7dd3d5cc3a5c274ef517010aeed90f487f9973f73f424dc712738411e9ca6e09410a0e15520477ef607decfd44878d143dd3c168e6799b2e5598fa
diff --git a/www-client/microsoft-edge/microsoft-edge-107.0.1418.52.ebuild b/www-client/microsoft-edge/microsoft-edge-107.0.1418.52.ebuild
deleted file mode 100644
index 47d0b386f658..000000000000
--- a/www-client/microsoft-edge/microsoft-edge-107.0.1418.52.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 2011-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-inherit chromium-2 desktop pax-utils unpacker xdg
-
-DESCRIPTION="The web browser from Microsoft"
-HOMEPAGE="https://www.microsoft.com/en-us/edge"
-
-if [[ ${PN} == microsoft-edge ]]; then
- MY_PN=${PN}-stable
-else
- MY_PN=${PN}
-fi
-
-KEYWORDS="-* amd64"
-
-MY_P="${MY_PN}_${PV}-1"
-
-SRC_URI="https://packages.microsoft.com/repos/edge/pool/main/m/${MY_PN}/${MY_P}_amd64.deb"
-
-LICENSE="microsoft-edge"
-SLOT="0"
-RESTRICT="bindist mirror strip"
-IUSE="+mip"
-
-RDEPEND="
- || (
- >=app-accessibility/at-spi2-core-2.46.0:2
- ( app-accessibility/at-spi2-atk dev-libs/atk )
- )
- app-misc/ca-certificates
- dev-libs/expat
- dev-libs/glib:2
- dev-libs/nspr
- dev-libs/nss
- media-fonts/liberation-fonts
- media-libs/alsa-lib
- media-libs/mesa[gbm(+)]
- net-misc/curl[ssl]
- net-print/cups
- sys-apps/dbus
- sys-apps/util-linux
- sys-libs/glibc
- x11-libs/cairo
- x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:3[X]
- x11-libs/libdrm
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXdamage
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXrandr
- x11-libs/libxcb
- x11-libs/libxkbcommon
- x11-libs/libxshmfence
- x11-libs/pango
- x11-misc/xdg-utils
- mip? ( app-crypt/libsecret )
-"
-
-QA_PREBUILT="*"
-QA_DESKTOP_FILE="usr/share/applications/microsoft-edge.*\\.desktop"
-S=${WORKDIR}
-EDGE_HOME="opt/microsoft/msedge${PN#microsoft-edge}"
-
-pkg_nofetch() {
- eerror "Please wait 24 hours and sync your tree before reporting a bug for microsoft-edge fetch failures."
-}
-
-pkg_pretend() {
- # Protect against people using autounmask overzealously
- use amd64 || die "microsoft-edge only works on amd64"
-}
-
-pkg_setup() {
- chromium_suid_sandbox_check_kernel_config
-}
-
-src_unpack() {
- :
-}
-
-src_install() {
- dodir /
- cd "${ED}" || die
- unpacker
-
- rm -f _gpgorigin || die
-
- rm -r etc usr/share/menu || die
- mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
-
- gzip -d usr/share/doc/${PF}/changelog.gz || die
- gzip -d usr/share/man/man1/${MY_PN}.1.gz || die
- if [[ -L usr/share/man/man1/${PN}.1.gz ]]; then
- rm usr/share/man/man1/${PN}.1.gz || die
- dosym ${MY_PN}.1 usr/share/man/man1/${PN}.1
- fi
-
- local suffix=
- [[ ${PN} == microsoft-edge-beta ]] && suffix=_beta
- [[ ${PN} == microsoft-edge-dev ]] && suffix=_dev
-
- local size
- for size in 16 24 32 48 64 128 256 ; do
- newicon -s ${size} "${EDGE_HOME}/product_logo_${size}${suffix}.png" ${PN}.png
- done
-
- if ! use mip; then
- rm "${EDGE_HOME}"/libmip_{core,protection_sdk}.so || die
- fi
-
- pax-mark m "${EDGE_HOME}/msedge"
-}