summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <sultan@gentoo.org>2022-01-20 22:31:16 +0100
committerStephan Hartmann <sultan@gentoo.org>2022-01-20 22:32:08 +0100
commitc7aeaeac8f11064c6937e4ca24c14aabcb94a03c (patch)
tree5a82b0bb14a594222b21ebb31877472891531773 /www-client
parentapp-crypt/yubioath-desktop: drop 5.0.5 (diff)
downloadgentoo-c7aeaeac8f11064c6937e4ca24c14aabcb94a03c.tar.gz
gentoo-c7aeaeac8f11064c6937e4ca24c14aabcb94a03c.tar.bz2
gentoo-c7aeaeac8f11064c6937e4ca24c14aabcb94a03c.zip
www-client/microsoft-edge: automated bump (97.0.1072.69)
Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/microsoft-edge/Manifest1
-rw-r--r--www-client/microsoft-edge/microsoft-edge-97.0.1072.69.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/www-client/microsoft-edge/Manifest b/www-client/microsoft-edge/Manifest
index 04d666423d7f..e309eb4aa338 100644
--- a/www-client/microsoft-edge/Manifest
+++ b/www-client/microsoft-edge/Manifest
@@ -1 +1,2 @@
DIST microsoft-edge-stable_97.0.1072.62-1_amd64.deb 119827536 BLAKE2B 38e844de680a80c5ced1665a04302b171ff111370ef8fdd0d0bf8549274cf6e587d07bc3fa40bc43b85c45560a961ec1efa378c96a6510a127591fde7c8c10c8 SHA512 35f075c366f91091865628d576bfc9e6fec6b9389b0e1b7577a8a0679ae22435d0bb53653495c6a367a7dbcffac5d28176cd808ad296d6f47c0938cfd9df3893
+DIST microsoft-edge-stable_97.0.1072.69-1_amd64.deb 119803088 BLAKE2B db910e03922d8bed314fd44e3c7bf1bfdbe29d27cebce3d50a4d2de8b582689857fe66f8dbf72665d2be2b7311fd7a4246c0f9294e49abb909ce07b72c9028cb SHA512 0353134a114fb59115f5268a7e5d5792c4b491e22870e6791daaef0fbe090ab43155ed717f9f2e868b75dc903027bdd2dcdc4df72c2d0b19e2766a1efe782865
diff --git a/www-client/microsoft-edge/microsoft-edge-97.0.1072.69.ebuild b/www-client/microsoft-edge/microsoft-edge-97.0.1072.69.ebuild
new file mode 100644
index 000000000000..ae99bf2a06bb
--- /dev/null
+++ b/www-client/microsoft-edge/microsoft-edge-97.0.1072.69.ebuild
@@ -0,0 +1,109 @@
+# Copyright 2011-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit chromium-2 desktop pax-utils unpacker xdg
+
+DESCRIPTION="The web browser from Microsoft"
+HOMEPAGE="https://www.microsoft.com/en-us/edge"
+
+if [[ ${PN} == microsoft-edge ]]; then
+ MY_PN=${PN}-stable
+else
+ MY_PN=${PN}
+fi
+
+KEYWORDS="-* ~amd64"
+
+MY_P="${MY_PN}_${PV}-1"
+
+SRC_URI="https://packages.microsoft.com/repos/edge/pool/main/m/${MY_PN}/${MY_P}_amd64.deb"
+
+LICENSE="microsoft-edge"
+SLOT="0"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ app-accessibility/at-spi2-core:2
+ app-misc/ca-certificates
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/liberation-fonts
+ media-libs/alsa-lib
+ media-libs/mesa[gbm(+)]
+ net-misc/curl[ssl]
+ net-print/cups
+ sys-apps/dbus
+ sys-apps/util-linux
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3[X]
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/libxshmfence
+ x11-libs/pango
+ x11-misc/xdg-utils
+"
+
+QA_PREBUILT="*"
+QA_DESKTOP_FILE="usr/share/applications/microsoft-edge.*\\.desktop"
+S=${WORKDIR}
+EDGE_HOME="opt/microsoft/msedge${PN#microsoft-edge}"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your tree before reporting a bug for microsoft-edge fetch failures."
+}
+
+pkg_pretend() {
+ # Protect against people using autounmask overzealously
+ use amd64 || die "microsoft-edge only works on amd64"
+}
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ dodir /
+ cd "${ED}" || die
+ unpacker
+
+ rm _gpgorigin || die
+
+ rm -r etc usr/share/menu || die
+ mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
+
+ gzip -d usr/share/doc/${PF}/changelog.gz || die
+ gzip -d usr/share/man/man1/${MY_PN}.1.gz || die
+ if [[ -L usr/share/man/man1/${PN}.1.gz ]]; then
+ rm usr/share/man/man1/${PN}.1.gz || die
+ dosym ${MY_PN}.1 usr/share/man/man1/${PN}.1
+ fi
+
+ local suffix=
+ [[ ${PN} == microsoft-edge-beta ]] && suffix=_beta
+ [[ ${PN} == microsoft-edge-dev ]] && suffix=_dev
+
+ local size
+ for size in 16 24 32 48 64 128 256 ; do
+ newicon -s ${size} "${EDGE_HOME}/product_logo_${size}${suffix}.png" ${PN}.png
+ done
+
+ pax-mark m "${EDGE_HOME}/msedge"
+}