summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-02-12 16:45:54 -0500
committerMike Gilbert <floppym@gentoo.org>2019-02-12 16:46:28 -0500
commitdff605f2030ec8e60a47070de8d05bd7a3fc1470 (patch)
tree693ab6ff9c87055e41761d9c17e35d19d540a27c /www-client
parentmedia-libs/vidstab: Fix test failure with USE="-openmp" (diff)
downloadgentoo-dff605f2030ec8e60a47070de8d05bd7a3fc1470.tar.gz
gentoo-dff605f2030ec8e60a47070de8d05bd7a3fc1470.tar.bz2
gentoo-dff605f2030ec8e60a47070de8d05bd7a3fc1470.zip
www-client/chromium: add closure-compile USE flag
This makes java an optional dependency. Closes: https://bugs.gentoo.org/672778 Package-Manager: Portage-2.3.59_p2, Repoman-2.3.12_p67 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/chromium-72.0.3626.96.ebuild5
-rw-r--r--www-client/chromium/metadata.xml1
2 files changed, 4 insertions, 2 deletions
diff --git a/www-client/chromium/chromium-72.0.3626.96.ebuild b/www-client/chromium/chromium-72.0.3626.96.ebuild
index bf82cadbae56..b34fe2996fce 100644
--- a/www-client/chromium/chromium-72.0.3626.96.ebuild
+++ b/www-client/chromium/chromium-72.0.3626.96.ebuild
@@ -18,7 +18,7 @@ SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~x86"
-IUSE="component-build cups gnome-keyring +hangouts jumbo-build kerberos neon pic +proprietary-codecs pulseaudio selinux +suid +system-ffmpeg +system-icu +system-libvpx +tcmalloc widevine"
+IUSE="+closure-compile component-build cups gnome-keyring +hangouts jumbo-build kerberos neon pic +proprietary-codecs pulseaudio selinux +suid +system-ffmpeg +system-icu +system-libvpx +tcmalloc widevine"
RESTRICT="!system-ffmpeg? ( proprietary-codecs? ( bindist ) )"
COMMON_DEPEND="
@@ -105,7 +105,7 @@ BDEPEND="
sys-apps/hwids[usb(+)]
>=sys-devel/bison-2.4.3
sys-devel/flex
- virtual/jre
+ closure-compile? ( virtual/jre )
virtual/pkgconfig
"
@@ -472,6 +472,7 @@ src_configure() {
myconf_gn+=" use_system_harfbuzz=true"
# Optional dependencies.
+ myconf_gn+=" closure_compile=$(usex closure-compile true false)"
myconf_gn+=" enable_hangout_services_extension=$(usex hangouts true false)"
myconf_gn+=" enable_widevine=$(usex widevine true false)"
myconf_gn+=" use_cups=$(usex cups true false)"
diff --git a/www-client/chromium/metadata.xml b/www-client/chromium/metadata.xml
index 9cfaf6c4be53..42ec8adf1922 100644
--- a/www-client/chromium/metadata.xml
+++ b/www-client/chromium/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<longdescription>Chromium is the open-source web browser project behind Google Chrome</longdescription>
<use>
+ <flag name="closure-compile">Enable closure type-checking for Chrome's web technology-based UI. Requires Java.</flag>
<flag name="component-build">Split build into more shared libraries to speed up linking. Mostly intended for debugging and development, NOT RECOMMENDED for general use.</flag>
<flag name="hangouts">Enable support for Google Hangouts features such as screen sharing</flag>
<flag name="jumbo-build">Combine source files to speed up build process.</flag>