summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-20 01:51:34 +0100
committerSam James <sam@gentoo.org>2022-08-20 01:51:34 +0100
commitf5f41578d3816a79e98ac66f322ee55dfeba88e2 (patch)
treebdd0d95e9468807719226bdbe0a03e53c1b87934 /www-client
parentwww-client/opera: remove old (diff)
downloadgentoo-f5f41578d3816a79e98ac66f322ee55dfeba88e2.tar.gz
gentoo-f5f41578d3816a79e98ac66f322ee55dfeba88e2.tar.bz2
gentoo-f5f41578d3816a79e98ac66f322ee55dfeba88e2.zip
www-client/microsoft-edge: automated bump (104.0.1293.63)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/microsoft-edge/Manifest1
-rw-r--r--www-client/microsoft-edge/microsoft-edge-104.0.1293.63.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/www-client/microsoft-edge/Manifest b/www-client/microsoft-edge/Manifest
index e216a8899844..8039a3142f9d 100644
--- a/www-client/microsoft-edge/Manifest
+++ b/www-client/microsoft-edge/Manifest
@@ -1 +1,2 @@
DIST microsoft-edge-stable_104.0.1293.54-1_amd64.deb 131288252 BLAKE2B 720ca46f3a2ea38c4876d3db7c581f5d337b5ce54da80678ec09a3b4454ee9c2c006f0397f13be8c03a51a9c9c84ee8bf6e9b4ca25acad0855408d2738c49a8a SHA512 4318a49f294fc3ad867bef0804475e558c432adb6c810ef45cf9a0b9b6e6c0eba077a10bcc49f01074656eb8c2ef0fe78b369407f6be780df510a12b8a25b9ba
+DIST microsoft-edge-stable_104.0.1293.63-1_amd64.deb 131357868 BLAKE2B 656e8496fa5ccde00ba31f1b888bcfc37880c206e96218e36f108cda8573967f9720a8a524dd1de454e3f04e04cd6346f83152fdaa29934adeef132037251408 SHA512 9ecb6337612268262e93d774f24dd7b49ba98187aa74248d9279f4611a10ee024444c94ef926257ac1f5cf3da8b54dbdb6e357d5e3a1c22a14e57778d92c5202
diff --git a/www-client/microsoft-edge/microsoft-edge-104.0.1293.63.ebuild b/www-client/microsoft-edge/microsoft-edge-104.0.1293.63.ebuild
new file mode 100644
index 000000000000..a8cc7e730ebf
--- /dev/null
+++ b/www-client/microsoft-edge/microsoft-edge-104.0.1293.63.ebuild
@@ -0,0 +1,116 @@
+# Copyright 2011-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit chromium-2 desktop pax-utils unpacker xdg
+
+DESCRIPTION="The web browser from Microsoft"
+HOMEPAGE="https://www.microsoft.com/en-us/edge"
+
+if [[ ${PN} == microsoft-edge ]]; then
+ MY_PN=${PN}-stable
+else
+ MY_PN=${PN}
+fi
+
+KEYWORDS="-* ~amd64"
+
+MY_P="${MY_PN}_${PV}-1"
+
+SRC_URI="https://packages.microsoft.com/repos/edge/pool/main/m/${MY_PN}/${MY_P}_amd64.deb"
+
+LICENSE="microsoft-edge"
+SLOT="0"
+RESTRICT="bindist mirror strip"
+IUSE="+mip"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ app-accessibility/at-spi2-core:2
+ app-misc/ca-certificates
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/liberation-fonts
+ media-libs/alsa-lib
+ media-libs/mesa[gbm(+)]
+ net-misc/curl[ssl]
+ net-print/cups
+ sys-apps/dbus
+ sys-apps/util-linux
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3[X]
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/libxshmfence
+ x11-libs/pango
+ x11-misc/xdg-utils
+ mip? ( app-crypt/libsecret )
+"
+
+QA_PREBUILT="*"
+QA_DESKTOP_FILE="usr/share/applications/microsoft-edge.*\\.desktop"
+S=${WORKDIR}
+EDGE_HOME="opt/microsoft/msedge${PN#microsoft-edge}"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your tree before reporting a bug for microsoft-edge fetch failures."
+}
+
+pkg_pretend() {
+ # Protect against people using autounmask overzealously
+ use amd64 || die "microsoft-edge only works on amd64"
+}
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ dodir /
+ cd "${ED}" || die
+ unpacker
+
+ rm _gpgorigin || die
+
+ rm -r etc usr/share/menu || die
+ mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
+
+ gzip -d usr/share/doc/${PF}/changelog.gz || die
+ gzip -d usr/share/man/man1/${MY_PN}.1.gz || die
+ if [[ -L usr/share/man/man1/${PN}.1.gz ]]; then
+ rm usr/share/man/man1/${PN}.1.gz || die
+ dosym ${MY_PN}.1 usr/share/man/man1/${PN}.1
+ fi
+
+ local suffix=
+ [[ ${PN} == microsoft-edge-beta ]] && suffix=_beta
+ [[ ${PN} == microsoft-edge-dev ]] && suffix=_dev
+
+ local size
+ for size in 16 24 32 48 64 128 256 ; do
+ newicon -s ${size} "${EDGE_HOME}/product_logo_${size}${suffix}.png" ${PN}.png
+ done
+
+ if ! use mip; then
+ rm "${EDGE_HOME}"/libmip_{core,protection_sdk}.so || die
+ fi
+
+ pax-mark m "${EDGE_HOME}/msedge"
+}