summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2018-03-28 10:58:31 +0000
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-05 14:20:52 +0200
commitf111d467415a1cc36aeaaa5679131eb855a799bf (patch)
tree3eb39247a732e0b35f5a239ba0e8ec20ee2f1630 /www-misc/buku/buku-3.7.ebuild
parentdev-libs/sblim-sfcc: Update to 2.2.8 (diff)
downloadgentoo-f111d467415a1cc36aeaaa5679131eb855a799bf.tar.gz
gentoo-f111d467415a1cc36aeaaa5679131eb855a799bf.tar.bz2
gentoo-f111d467415a1cc36aeaaa5679131eb855a799bf.zip
www-misc/buku: Bump to 3.7
Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7682
Diffstat (limited to 'www-misc/buku/buku-3.7.ebuild')
-rw-r--r--www-misc/buku/buku-3.7.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/www-misc/buku/buku-3.7.ebuild b/www-misc/buku/buku-3.7.ebuild
new file mode 100644
index 000000000000..ea918b0c806b
--- /dev/null
+++ b/www-misc/buku/buku-3.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Powerful command-line bookmark manager"
+HOMEPAGE="https://github.com/jarun/Buku"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.13.1[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr/share/zsh/site-functions
+ doins auto-completion/zsh/_*
+
+ newbashcomp auto-completion/bash/buku-completion.bash "${PN}"
+
+ doman buku.1
+}
+
+python_test() {
+ py.test -v tests/test_* || die
+}