summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-10-24 16:19:04 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-10-24 16:19:04 +0200
commitff82bc730056751a6400394102d03636076120b2 (patch)
tree40580451a208ed668376d40f6c6203081f75acb8 /www-misc/htdig/htdig-3.2.0_beta6-r5.ebuild
parentnet-libs/libesmtp: Fixed HOMEPAGE and SRC_URI. (diff)
downloadgentoo-ff82bc730056751a6400394102d03636076120b2.tar.gz
gentoo-ff82bc730056751a6400394102d03636076120b2.tar.bz2
gentoo-ff82bc730056751a6400394102d03636076120b2.zip
www-misc/htdig: Added Debian patch to fix build issue.
Closes: https://bugs.gentoo.org/638720 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'www-misc/htdig/htdig-3.2.0_beta6-r5.ebuild')
-rw-r--r--www-misc/htdig/htdig-3.2.0_beta6-r5.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/www-misc/htdig/htdig-3.2.0_beta6-r5.ebuild b/www-misc/htdig/htdig-3.2.0_beta6-r5.ebuild
index 7596cb361676..eec36227e380 100644
--- a/www-misc/htdig/htdig-3.2.0_beta6-r5.ebuild
+++ b/www-misc/htdig/htdig-3.2.0_beta6-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -31,6 +31,7 @@ PATCHES=(
"${FILESDIR}"/${P}-quoting.patch
"${FILESDIR}"/${P}-gcc6.patch
"${FILESDIR}"/${P}-musl.patch
+ "${FILESDIR}"/${P}-drop-bogus-assignment.patch #638720
)
HTML_DOCS=( htdoc )
@@ -42,14 +43,16 @@ src_prepare() {
}
src_configure() {
- econf \
- --with-config-dir="${EPREFIX}"/etc/${PN} \
- --with-default-config-file="${EPREFIX}"/etc/${PN}/${PN}.conf \
- --with-database-dir="${EPREFIX}"/var/lib/${PN}/db \
- --with-cgi-bin-dir="${EPREFIX}"/var/www/localhost/cgi-bin \
- --with-search-dir="${EPREFIX}"/var/www/localhost/htdocs/${PN} \
- --with-image-dir="${EPREFIX}"/var/www/localhost/htdocs/${PN} \
+ local myeconfargs=(
+ --with-config-dir="${EPREFIX}"/etc/${PN}
+ --with-default-config-file="${EPREFIX}"/etc/${PN}/${PN}.conf
+ --with-database-dir="${EPREFIX}"/var/lib/${PN}/db
+ --with-cgi-bin-dir="${EPREFIX}"/var/www/localhost/cgi-bin
+ --with-search-dir="${EPREFIX}"/var/www/localhost/htdocs/${PN}
+ --with-image-dir="${EPREFIX}"/var/www/localhost/htdocs/${PN}
$(use_with ssl)
+ )
+ econf "${myeconfargs[@]}"
}
src_install () {