summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-08-24 15:43:59 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-08-24 16:01:43 +0200
commite58b650cb0b8a3f96a111fbc755decb4a94fb2b1 (patch)
treec5799dde39681ee9be3fd0b74b437ebaf276bb70 /www-misc/urlwatch/urlwatch-2.21.ebuild
parentdev-python/minidb: add Python 3.9 support (diff)
downloadgentoo-e58b650cb0b8a3f96a111fbc755decb4a94fb2b1.tar.gz
gentoo-e58b650cb0b8a3f96a111fbc755decb4a94fb2b1.tar.bz2
gentoo-e58b650cb0b8a3f96a111fbc755decb4a94fb2b1.zip
www-misc/urlwatch: bump to 2.21, add Python 3.9 support
Tests now use pytest instead of nose. Package-Manager: Portage-3.0.3, Repoman-2.3.23 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'www-misc/urlwatch/urlwatch-2.21.ebuild')
-rw-r--r--www-misc/urlwatch/urlwatch-2.21.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/www-misc/urlwatch/urlwatch-2.21.ebuild b/www-misc/urlwatch/urlwatch-2.21.ebuild
new file mode 100644
index 000000000000..890f051e65f0
--- /dev/null
+++ b/www-misc/urlwatch/urlwatch-2.21.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+# The package uses entry points but setup.py is weird
+# so the eclass doesn't detect it
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for monitoring webpages for updates"
+HOMEPAGE="https://thp.io/2008/urlwatch/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/minidb[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+python_test() {
+ local skipped_tests=(
+ # Require the pdftotext module
+ "lib/urlwatch/tests/test_filter_documentation.py::test_url[https://example.net/pdf-test.pdf-job12]"
+ "lib/urlwatch/tests/test_filter_documentation.py::test_url[https://example.net/pdf-test-password.pdf-job13]"
+ # Requires the pytesseract module
+ "lib/urlwatch/tests/test_filter_documentation.py::test_url[https://example.net/ocr-test.png-job26]"
+ )
+ pytest -vv ${skipped_tests[@]/#/--deselect } \
+ || die "Tests failed with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ if ! has_version dev-python/chump; then
+ elog "Install 'dev-python/chump' to enable Pushover" \
+ "notifications support"
+ fi
+ if ! has_version dev-python/pushbullet-py; then
+ elog "Install 'dev-python/pushbullet-py' to enable" \
+ "Pushbullet notifications support"
+ fi
+ elog "HTML parsing can be improved by installing one of the following packages"
+ elog "and changing the html2text subfilter parameter:"
+ elog "dev-python/beautifulsoup:4"
+ elog "app-text/html2text"
+ elog "dev-python/html2text"
+ elog "www-client/lynx"
+ fi
+}