summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPedro Arizmendi <dwosky@pm.me>2022-01-19 18:31:58 +0100
committerIonen Wolkens <ionen@gentoo.org>2022-02-06 14:33:46 -0500
commit6a34360938ddf88e594cfb59792363c0d4501f52 (patch)
treeb1aec6a578165bd043080ece1b294fbdac6a1c38 /www-misc
parentwww-apps/davical: version bump to 1.1.10 (diff)
downloadgentoo-6a34360938ddf88e594cfb59792363c0d4501f52.tar.gz
gentoo-6a34360938ddf88e594cfb59792363c0d4501f52.tar.bz2
gentoo-6a34360938ddf88e594cfb59792363c0d4501f52.zip
www-misc/monitorix: Version bump to 3.14.0
Signed-off-by: Pedro Arizmendi <dwosky@pm.me> Package-Manager: Portage-3.0.28, Repoman-3.0.3 Closes: https://github.com/gentoo/gentoo/pull/23872 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/monitorix/Manifest1
-rw-r--r--www-misc/monitorix/monitorix-3.14.0.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/www-misc/monitorix/Manifest b/www-misc/monitorix/Manifest
index 4d6fde28788e..6a6493638623 100644
--- a/www-misc/monitorix/Manifest
+++ b/www-misc/monitorix/Manifest
@@ -1,2 +1,3 @@
DIST monitorix-3.12.0.tar.gz 348117 BLAKE2B 65f6e5a8ef4acba2e5dd015e3acab1c927a8964de6cf0bb56a426e6e2dc5843083177591f26db639ed36df798db9659cd6345ca38df4f25fc9a4759e84f0d553 SHA512 7cbdb27df1d84e87f0b99d310d3b3a7c27e369adc82c88e297966e36de82c2f800474447dd628041f2feb89817ee496cbae65a4b0e4942a2f75c900f16ccfcf1
DIST monitorix-3.13.1.tar.gz 364091 BLAKE2B 0e11d1df2d5cbc4a7ec7b448b24409411903370b5fc0f35f7395439b017d0ce27e3d86fe19db70939942165a9e4bf72583030fdcd1b9c0b5be484c1c71af021e SHA512 224ccedd608cda609ea161f62e11266c13f26536d7e3c50a3690ace693ed52c71422f2ef0acabb4e8d69551458a6af2c33e6b776b1dec73cbf621a7f40339573
+DIST monitorix-3.14.0.tar.gz 393803 BLAKE2B 84a2b0a8417a405757e43c752b8e4aa0faf4c750895e5425801c3682f25671b8b4858ee4fdf94e4da181250c0ddbdc9237624af0d1dcbec4a29a8076f35a9fc6 SHA512 c7b11b2144b9cdcc5fdb33cfe208d5d5c7c8e27dfdacd51148a4077748632e592cf07dbecd5992c34ff4aea982e62a03a20d1920fe142da7f6ed5367729bfd2e
diff --git a/www-misc/monitorix/monitorix-3.14.0.ebuild b/www-misc/monitorix/monitorix-3.14.0.ebuild
new file mode 100644
index 000000000000..4201f609ca45
--- /dev/null
+++ b/www-misc/monitorix/monitorix-3.14.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit systemd optfeature
+
+DESCRIPTION="A lightweight system monitoring tool"
+HOMEPAGE="https://www.monitorix.org/"
+SRC_URI="https://www.monitorix.org/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ acct-user/monitorix
+ acct-group/monitorix
+ dev-perl/Config-General
+ dev-perl/DBI
+ dev-perl/HTTP-Server-Simple
+ dev-perl/IO-Socket-SSL
+ dev-perl/libwww-perl
+ dev-perl/MIME-Lite
+ dev-perl/XML-Simple
+ net-analyzer/rrdtool[graph,perl]
+ dev-perl/CGI"
+
+src_prepare() {
+ # Put better Gentoo defaults in the configuration file.
+ sed -e "s|\(base_dir.*\)/usr/share/${PN}|\1/usr/share/${PN}/htdocs|" \
+ -e "s|\(secure_log.*\)/var/log/secure|\1/var/log/auth.log|" \
+ -e "s|nobody|${PN}|g" -i ${PN}.conf || die
+ # Update systemd binary location
+ sed -e "s|/usr/bin|/usr/sbin|g" -i docs/${PN}.service || die
+ eapply_user
+}
+
+# Override compile phase
+src_compile() { :; }
+
+src_install() {
+ dosbin ${PN}
+
+ newinitd "${FILESDIR}/monitorix" ${PN}
+
+ insinto /etc/monitorix
+ doins ${PN}.conf
+
+ keepdir /etc/${PN}/conf.d
+
+ insinto /etc/logrotate.d
+ newins docs/${PN}.logrotate ${PN}
+
+ dodoc Changes README{,.nginx} docs/${PN}-{alert.sh,apache.conf,lighttpd.conf}
+ doman man/man5/${PN}.conf.5
+ doman man/man8/${PN}.8
+
+ insinto /var/lib/${PN}/www
+ doins logo_bot.png logo_top.png ${PN}ico.png
+
+ insinto /var/lib/${PN}/www/css
+ doins css/*.css
+
+ keepdir /var/lib/${PN}/www/imgs
+ fowners monitorix:monitorix /var/lib/${PN}/www/imgs
+
+ exeinto /var/lib/${PN}/www/cgi
+ doexe ${PN}.cgi
+
+ exeinto /usr/lib/${PN}
+ doexe lib/*.pm
+
+ keepdir /var/lib/${PN}/usage
+ insinto /var/lib/${PN}/reports
+ doins -r reports
+
+ systemd_dounit docs/${PN}.service
+}
+
+pkg_postinst() {
+ optfeature "disk drive temperatures and health" app-admin/hddtemp
+ optfeature "email reports/statics" mail-mta/postfix mail-mta/sendmail
+ optfeature "lm-sensors and GPU temperatures" sys-apps/lm-sensors
+ optfeature "APC UPS statistics" sys-power/apcupsd
+ optfeature "Network UPS Tools statistics" sys-power/nut
+ elog
+ elog "If you wish to use your own web server:"
+ elog " Web data can be found at: ${EROOT}/var/lib/${PN}/www/"
+ elog " Also please check the correct user and group ownership"
+ elog " of ${EROOT}/var/lib/${PN}/www/imgs/"
+}