summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-04-17 16:31:09 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-04-17 16:31:09 +0200
commit963216a731c39f143c82792350b96363b1dd970b (patch)
tree1a0a2e54c47fc801d9931a3b48b5c87e0d85a069 /www-misc
parentmetadata/install-qa-check.d: swap libltdl check to 'has' (diff)
downloadgentoo-963216a731c39f143c82792350b96363b1dd970b.tar.gz
gentoo-963216a731c39f143c82792350b96363b1dd970b.tar.bz2
gentoo-963216a731c39f143c82792350b96363b1dd970b.zip
www-misc/litmus: EAPI 5 -> 8
Closes: https://bugs.gentoo.org/715472 Closes: https://bugs.gentoo.org/835351 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/litmus/files/litmus-0.13-autotools-neon-version.patch (renamed from www-misc/litmus/files/0.13-autotools-neon-version.patch)6
-rw-r--r--www-misc/litmus/litmus-0.13-r1.ebuild (renamed from www-misc/litmus/litmus-0.13.ebuild)65
2 files changed, 38 insertions, 33 deletions
diff --git a/www-misc/litmus/files/0.13-autotools-neon-version.patch b/www-misc/litmus/files/litmus-0.13-autotools-neon-version.patch
index c2e0211b6508..b1fdfd61e3ec 100644
--- a/www-misc/litmus/files/0.13-autotools-neon-version.patch
+++ b/www-misc/litmus/files/litmus-0.13-autotools-neon-version.patch
@@ -1,11 +1,11 @@
---- configure.ac.ori 2014-01-31 01:00:58.796123088 +0100
-+++ configure.ac 2014-01-31 01:00:43.767787763 +0100
+--- a/configure.ac
++++ b/configure.ac
@@ -20,7 +20,7 @@
dnl List of tests
AC_SUBST([TESTS], ["basic copymove props locks http"])
-NE_REQUIRE_VERSIONS([0], [25 26 27 28 29])
-+NE_REQUIRE_VERSIONS([0], [25 26 27 28 29 30])
++NE_REQUIRE_VERSIONS([0], [25 26 27 28 29 30 31 32])
NEON_WITHOUT_ZLIB
NEON_WITHOUT_ACL
NEON_TEST
diff --git a/www-misc/litmus/litmus-0.13.ebuild b/www-misc/litmus/litmus-0.13-r1.ebuild
index a7cdc6362201..2f6f95a3ad14 100644
--- a/www-misc/litmus/litmus-0.13.ebuild
+++ b/www-misc/litmus/litmus-0.13-r1.ebuild
@@ -1,13 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=8
-inherit autotools epatch
-
-# TODO: FAIL (connection refused by '...' port 80: Connection refused)
-# We can't run tests that connect with the internet.
-RESTRICT="test"
+inherit autotools
DESCRIPTION="WebDAV server protocol compliance test suite"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
@@ -17,45 +13,54 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug expat gnutls kerberos libproxy +libxml2 pkcs11 +ssl threads"
-REQUIRED_USE="?? ( gnutls ssl )
+REQUIRED_USE="
+ ?? ( gnutls ssl )
^^ ( expat libxml2 )
- threads? ( ^^ ( gnutls ssl ) )"
+ threads? (
+ ^^ ( gnutls ssl )
+ )
+"
-NEON_DEP="net-libs/neon:0="
-DEPEND="${NEON_DEP}[expat?,gnutls?,kerberos?,libproxy?,pkcs11?,ssl?,zlib]
+# TODO: FAIL (connection refused by '...' port 80: Connection refused)
+# We can't run tests that connect with the internet.
+RESTRICT="test"
+DEPEND="
+ net-libs/neon:0=[expat?,gnutls?,kerberos?,libproxy?,pkcs11?,ssl?,zlib]
expat? ( dev-libs/expat:0 )
gnutls? ( net-libs/gnutls:0 )
kerberos? ( app-crypt/mit-krb5:0 )
libproxy? ( net-libs/libproxy:0 )
libxml2? ( dev-libs/libxml2:2 )
pkcs11? ( dev-libs/pakchois:0 )
- ssl? ( dev-libs/openssl:0 )"
+ ssl? ( dev-libs/openssl:0 )
+"
+
RDEPEND="${DEPEND}"
-DOCS=( ChangeLog FAQ NEWS README THANKS TODO )
+PATCHES=( "${FILESDIR}/${P}-autotools-neon-version.patch" )
src_prepare() {
- # Accept Neon 0.30.
- epatch "${FILESDIR}/${PV}-autotools-neon-version.patch"
-
+ default
eautoreconf
}
src_configure() {
- # No EGD available in the Portage tree.
- econf \
- --enable-warnings \
- --without-egd \
- --with-neon \
- --without-included-neon \
- $(use_enable debug) \
- $(use_enable threads threadsafe-ssl posix) \
- $(use_with gnutls ssl gnutls) \
- $(use_with ssl ssl openssl) \
- $(use_with expat) \
- $(use_with libxml2) \
- $(use_with kerberos gssapi) \
- $(use_with pkcs11 pakchois) \
+ local myeconfargs=(
+ --enable-warnings
+ --without-egd
+ --with-neon
+ --without-included-neon
+ $(use_enable debug)
+ $(use_enable threads threadsafe-ssl posix)
+ $(use_with gnutls ssl gnutls)
+ $(use_with ssl ssl openssl)
+ $(use_with expat)
+ $(use_with libxml2)
+ $(use_with kerberos gssapi)
+ $(use_with pkcs11 pakchois)
$(use_with libproxy)
+ )
+
+ econf "${myeconfargs[@]}"
}