summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2022-03-17 13:32:54 +0100
committerLouis Sautier <sbraz@gentoo.org>2022-03-17 13:32:54 +0100
commitb97f5ec6b40bb99fc7e43e7155691e6659fa0966 (patch)
treefcb160246b4425e6f1f0aaaa7053fdf0cc2e25d1 /www-misc
parentwww-misc/urlwatch: add 2.25 (diff)
downloadgentoo-b97f5ec6b40bb99fc7e43e7155691e6659fa0966.tar.gz
gentoo-b97f5ec6b40bb99fc7e43e7155691e6659fa0966.tar.bz2
gentoo-b97f5ec6b40bb99fc7e43e7155691e6659fa0966.zip
www-misc/urlwatch: drop 2.23
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/urlwatch/Manifest1
-rw-r--r--www-misc/urlwatch/urlwatch-2.23.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/www-misc/urlwatch/Manifest b/www-misc/urlwatch/Manifest
index c158afbf37c1..b39491bccf29 100644
--- a/www-misc/urlwatch/Manifest
+++ b/www-misc/urlwatch/Manifest
@@ -1,4 +1,3 @@
DIST urlwatch-2.22.tar.gz 136306 BLAKE2B e7f10872e5d7f42ec0ac1073783431c4b0e4fcdcf40884a9f7f52aee36705fbdbaaf5f9e671223715040c6f68cc580f531ba753c9326a2b1380d2fb707f66f1c SHA512 f2c1e0d279689d1e5761203ba139614b972c6266c30877262d59759b0ce63342a820a063f001039848427ea4af4325505c636762cdedb3dc60ebd09e859914f4
-DIST urlwatch-2.23.tar.gz 137917 BLAKE2B 330c52cad62985d24b2cc4c7345156abe9d5d369f8b3f4402856eb96a98f75422de49045bc10910e5cc81306744aad2dce7c05667a6f4eeb22b2bba47869f260 SHA512 e54f8fe2d8307ca9f2f222e6a2082d517a330db60e410b7c991283a2bf88aa861306965b23ca644811aa69425ec2281f7f48d5e34047b808c0897f45ffc7fcbc
DIST urlwatch-2.24.tar.gz 141175 BLAKE2B 7868ba757493c97ef65136d3da67ef3bb6b0d62e52ab150e169d66adea420872990527a622d305bd14923ff367041d615dcea1495871258040ec2cbb73ee7613 SHA512 ed84cb69ecd8894851c3be0165edfa1dfee92a0b49ea1383e4cfd7c31eb0604f99b1a90d9508753064b58bdd8fc4c0369d817303858d07562b37c3f2ac4cae52
DIST urlwatch-2.25.tar.gz 168241 BLAKE2B 85f76e849495f5457f43ccd37035aae84c6ae4c8649005e617a6a585bf3b73d30914f8c7a89c0fb9bb04cc07a8797d77be07807e8d7c64976355749417b39e40 SHA512 af14c5b4e11345e56e6f326c114629f1e074215d6cc66d9c642424b2a689dc80339157f1b2547fdbe7b7a13d520e2b83bf23c7477da4ae4e43d108e6452624ca
diff --git a/www-misc/urlwatch/urlwatch-2.23.ebuild b/www-misc/urlwatch/urlwatch-2.23.ebuild
deleted file mode 100644
index 42129d86b8d9..000000000000
--- a/www-misc/urlwatch/urlwatch-2.23.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="A tool for monitoring webpages for updates"
-HOMEPAGE="https://thp.io/2008/urlwatch/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/appdirs[${PYTHON_USEDEP}]
- dev-python/cssselect[${PYTHON_USEDEP}]
- dev-python/keyring[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/minidb[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/docutils[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( CHANGELOG.md README.md )
-
-distutils_enable_sphinx docs/source dev-python/alabaster
-distutils_enable_tests pytest
-
-python_test() {
- local skipped_tests=(
- # Require the pdftotext module
- "lib/urlwatch/tests/test_filter_documentation.py::test_url[https://example.net/pdf-test.pdf-job12]"
- "lib/urlwatch/tests/test_filter_documentation.py::test_url[https://example.net/pdf-test-password.pdf-job13]"
- # Require the pytesseract module
- "lib/urlwatch/tests/test_filter_documentation.py::test_url[https://example.net/ocr-test.png-job26]"
- "lib/urlwatch/tests/test_filter_documentation.py::test_url[https://example.net/ocr-test.png-job27]"
- # Requires the jq module
- "lib/urlwatch/tests/test_filter_documentation.py::test_url[https://example.net/jobs.json-job28]"
- # Skip code quality check
- "lib/urlwatch/tests/test_handler.py::test_pep8_conformance"
- )
- epytest ${skipped_tests[@]/#/--deselect }
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- if ! has_version dev-python/chump; then
- elog "Install 'dev-python/chump' to enable Pushover" \
- "notifications support"
- fi
- if ! has_version dev-python/pushbullet-py; then
- elog "Install 'dev-python/pushbullet-py' to enable" \
- "Pushbullet notifications support"
- fi
- elog "HTML parsing can be improved by installing one of the following packages"
- elog "and changing the html2text subfilter parameter:"
- elog "dev-python/beautifulsoup4"
- elog "app-text/html2text"
- elog "dev-python/html2text"
- elog "www-client/lynx"
- fi
-}