summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-05-01 12:11:27 +1000
committerMatt Jolly <kangie@gentoo.org>2024-05-01 16:38:01 +1000
commit0e8ca4b4d4675128f0dae4b1d94ed700f7860e2e (patch)
tree959765fd8b339ebcc84c429dc827f7d3c6decfe9 /www-plugins/chrome-binary-plugins/chrome-binary-plugins-124.0.6367.78.ebuild
parentwww-client/google-chrome: automated update (124.0.6367.118) (diff)
downloadgentoo-0e8ca4b4d4675128f0dae4b1d94ed700f7860e2e.tar.gz
gentoo-0e8ca4b4d4675128f0dae4b1d94ed700f7860e2e.tar.bz2
gentoo-0e8ca4b4d4675128f0dae4b1d94ed700f7860e2e.zip
www-plugins/chrome-binary-plugins: automated update (124.0.6367.118)
Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'www-plugins/chrome-binary-plugins/chrome-binary-plugins-124.0.6367.78.ebuild')
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-124.0.6367.78.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-124.0.6367.78.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-124.0.6367.78.ebuild
deleted file mode 100644
index 01e48ea7c665..000000000000
--- a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-124.0.6367.78.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 2012-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit unpacker
-
-DESCRIPTION="Binary plugins from Google Chrome for use in Chromium"
-HOMEPAGE="https://www.google.com/chrome"
-
-case ${PV} in
- *_alpha*)
- SLOT="unstable"
- CHROMEDIR="opt/google/chrome-${SLOT}"
- MY_PV=${PV%_alpha}-1
- ;;
- *_beta*)
- SLOT="beta"
- CHROMEDIR="opt/google/chrome-${SLOT}"
- MY_PV=${PV%_beta}-1
- ;;
- *)
- SLOT="stable"
- CHROMEDIR="opt/google/chrome"
- MY_PV=${PV}-1
- ;;
-esac
-
-MY_PN="google-chrome-${SLOT}"
-MY_P="${MY_PN}_${MY_PV}"
-SRC_URI="https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb"
-S="${WORKDIR}/${CHROMEDIR}"
-
-LICENSE="google-chrome"
-KEYWORDS="-* amd64"
-RESTRICT="bindist mirror strip"
-
-RDEPEND="
- dev-libs/glib:2
- dev-libs/nspr
- dev-libs/nss
- sys-libs/glibc
-"
-
-for x in 0 beta stable unstable; do
- if [[ ${SLOT} != ${x} ]]; then
- RDEPEND+=" !${CATEGORY}/${PN}:${x}"
- fi
-done
-
-QA_PREBUILT="*"
-
-pkg_nofetch() {
- eerror "Please wait 24 hours and sync your portage tree before reporting fetch failures."
-}
-
-src_install() {
- insinto "/usr/$(get_libdir)/chromium-browser"
- doins -r WidevineCdm
-}