summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-servers/axis
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-servers/axis')
-rw-r--r--www-servers/axis/Manifest1
-rw-r--r--www-servers/axis/axis-1.4-r2.ebuild139
-rw-r--r--www-servers/axis/files/axis-1.4-JSSESocketFactory.java.patch342
-rw-r--r--www-servers/axis/files/axis-1.4-build.xml.patch15
-rw-r--r--www-servers/axis/files/axis-1.4-java6.patch16
-rw-r--r--www-servers/axis/files/axis-1.4-path_refs.xml.patch20
-rw-r--r--www-servers/axis/files/axis-1.4-targets.xml.patch86
-rw-r--r--www-servers/axis/files/axis-1.4-tools-build.xml.patch26
-rw-r--r--www-servers/axis/files/build.properties15
-rw-r--r--www-servers/axis/metadata.xml13
10 files changed, 673 insertions, 0 deletions
diff --git a/www-servers/axis/Manifest b/www-servers/axis/Manifest
new file mode 100644
index 000000000000..a574a72dd1b8
--- /dev/null
+++ b/www-servers/axis/Manifest
@@ -0,0 +1 @@
+DIST axis-src-1_4.tar.gz 17041546 SHA256 911b4467f3d6cfe2e50fb7baea7a754e6aa717902d6ed91cef78f8f52bef8572 SHA512 7d08212b04702e76c960ad772a475f5765fef7f9ebe0aea3d4b949c6ba28a62500e8a76a43c7364b7caf36b7f27aee8592744256154670c7a24d29c5c1518258 WHIRLPOOL cf359caa9e645bdefb7c2ff012673dc64af9d4cc4bbe2a082cb64bcb0211d3a844ef797738ae1a3e9f978d0bbd8dc42bac9ecbdf4c734dd30ff52da18bdd7a91
diff --git a/www-servers/axis/axis-1.4-r2.ebuild b/www-servers/axis/axis-1.4-r2.ebuild
new file mode 100644
index 000000000000..a247f2beee12
--- /dev/null
+++ b/www-servers/axis/axis-1.4-r2.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WANT_ANT_TASKS="ant-nodeps ant-trax"
+JAVA_PKG_IUSE="doc source examples"
+
+inherit eutils java-pkg-2 java-ant-2
+
+MY_PV="${PV//./_}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Apache's Axis1 implementation of the SOAP (Simple Object Access Protocol)"
+HOMEPAGE="http://ws.apache.org/axis/index.html"
+SRC_URI="mirror://apache/ws/${PN}/${MY_PV}/${PN}-src-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+CDEPEND="dev-java/commons-discovery:0
+ dev-java/wsdl4j:0
+ dev-java/sun-jaf:0
+ dev-java/commons-logging:0
+ java-virtuals/javamail:0
+ dev-java/ant-core:0
+ dev-java/bsf:2.3
+ dev-java/castor:1.0
+ dev-java/commons-httpclient:3
+ dev-java/commons-net:0
+ dev-java/sun-jimi:0
+ dev-java/servletapi:2.4
+ dev-java/saaj:0
+ dev-java/jax-rpc:0
+ dev-java/log4j:0
+ dev-java/xml-commons:0
+ dev-java/xml-xmlbeans:1"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}"
+
+# uses enum as identifier
+JAVA_PKG_WANT_SOURCE="1.4"
+JAVA_PKG_WANT_TARGET="1.4"
+
+S="${WORKDIR}/${MY_P}"
+
+AXIS_NAME="${PN}-${SLOT}"
+
+# not declared mandatory but fails without it
+# mailapi.jar would be enough but that's only in -bin, mail.jar superseedes
+EANT_GENTOO_CLASSPATH="sun-jaf,javamail,log4j,xml-xmlbeans-1,servletapi-2.4,bsf-2.3,sun-jimi,commons-httpclient-3,castor-1.0,xml-commons,commons-net"
+EANT_EXTRA_ARGS="-Ddeprecation=false -Dbase.path=/opt
+-Dservlet.jar=servlet-api.jar -Dwsdl4j-1.5.1.jar=wsdl4j.jar
+-Dcommons-logging-1.0.4.jar=commons-logging.jar"
+EANT_BUILD_TARGET="compile"
+EANT_DOC_TARGET="javadocs"
+EANT_NEEDS_TOOLS="true"
+
+#TODO-tests require Atlassian clover, need to figure out which ones
+RESTRICT="test"
+
+java_prepare() {
+ # remove some <copy> actions
+ epatch "${FILESDIR}/${P}-build.xml.patch"
+ # remove exact lib paths and global java.classpath from classpath
+ epatch "${FILESDIR}/${P}-path_refs.xml.patch"
+ # add missing target to javac, xml rewriting would break entities
+ epatch "${FILESDIR}/${P}-tools-build.xml.patch"
+ # remove most of <available> checks
+ epatch "${FILESDIR}/${P}-targets.xml.patch"
+ # this clashes with java6 method
+ epatch "${FILESDIR}/${P}-java6.patch"
+
+ # fix CVE-2014-3596 and bug 520304
+ epatch "${FILESDIR}/${P}-JSSESocketFactory.java.patch"
+
+ # and replace them with predefined properties
+ cp "${FILESDIR}/build.properties" . \
+ || die "failed to copy build.properties from ${FILESDIR}"
+
+ rm -rf "${S}"/docs/apiDocs || die
+
+ #Remove test till they are working
+ rm -rf "${S}"/test || die
+ #cd "${S}"/test
+ #mv build_ant.xml build.xml
+ cd "${S}"/webapps/axis/WEB-INF/lib
+ rm -v *.jar || die
+
+ cd "${S}/lib"
+ mv saaj.jar endorsed/ || die
+ rm -v *.jar || die
+ java-pkg_jar-from --build-only ant-core
+ java-pkg_jar-from wsdl4j wsdl4j.jar
+ java-pkg_jar-from commons-logging commons-logging.jar
+ java-pkg_jar-from commons-discovery commons-discovery.jar
+
+ if use debug; then
+ EANT_EXTRA_ARGS+=" -Ddebug=on"
+ else
+ EANT_EXTRA_ARGS+=" -Ddebug=off"
+ fi
+
+ cd "${S}"
+ java-ant_rewrite-classpath
+ java-ant_rewrite-bootclasspath auto build.xml "lib/endorsed/xml-apis-2.6.2.jar:lib/endorsed/xercesImpl-2.6.2.jar:lib/endorsed/saaj.jar"
+ sed -i '/<bootclasspath refid="boot.classpath"/d' build.xml || die
+}
+
+src_install() {
+ dodir /usr/share/${AXIS_NAME}
+ mv build/lib/axis-ant.jar build/lib/ant-axis.jar || die
+ java-pkg_dojar build/lib/axis.jar
+ java-pkg_dojar build/lib/ant-axis.jar
+ java-pkg_dojar build/lib/jaxrpc.jar
+ java-pkg_register-ant-task
+ dodir /usr/share/${AXIS_NAME}/webapps
+
+ cp -pR "${S}"/webapps/axis "${D}"/usr/share/${AXIS_NAME}/webapps || die
+
+ dodoc NOTICE README
+ dohtml release-notes.html changelog.html
+
+ if use doc; then
+ java-pkg_dojavadoc build/javadocs/
+ dohtml -r docs/*
+ dodoc xmls/*
+ fi
+
+ use source && java-pkg_dosrc src
+ use examples && java-pkg_doexamples samples
+}
diff --git a/www-servers/axis/files/axis-1.4-JSSESocketFactory.java.patch b/www-servers/axis/files/axis-1.4-JSSESocketFactory.java.patch
new file mode 100644
index 000000000000..1309115295d1
--- /dev/null
+++ b/www-servers/axis/files/axis-1.4-JSSESocketFactory.java.patch
@@ -0,0 +1,342 @@
+--- src/org/apache/axis/components/net/JSSESocketFactory.java (revision 1618775)
++++ src/org/apache/axis/components/net/JSSESocketFactory.java (working copy)
+@@ -15,12 +15,6 @@
+ */
+ package org.apache.axis.components.net;
+
+-import org.apache.axis.utils.Messages;
+-import org.apache.axis.utils.XMLUtils;
+-import org.apache.axis.utils.StringUtils;
+-
+-import javax.net.ssl.SSLSocket;
+-import javax.net.ssl.SSLSocketFactory;
+ import java.io.BufferedWriter;
+ import java.io.IOException;
+ import java.io.InputStream;
+@@ -28,9 +22,35 @@
+ import java.io.OutputStreamWriter;
+ import java.io.PrintWriter;
+ import java.net.Socket;
++import java.security.cert.Certificate;
++import java.security.cert.CertificateParsingException;
++import java.security.cert.X509Certificate;
++import java.util.ArrayList;
++import java.util.Arrays;
++import java.util.Collection;
+ import java.util.Hashtable;
++import java.util.Iterator;
++import java.util.LinkedList;
++import java.util.List;
++import java.util.Locale;
++import java.util.regex.Pattern;
+
++import javax.naming.InvalidNameException;
++import javax.naming.NamingException;
++import javax.naming.directory.Attribute;
++import javax.naming.directory.Attributes;
++import javax.naming.ldap.LdapName;
++import javax.naming.ldap.Rdn;
++import javax.net.ssl.SSLException;
++import javax.net.ssl.SSLSession;
++import javax.net.ssl.SSLSocket;
++import javax.net.ssl.SSLSocketFactory;
+
++import org.apache.axis.utils.Messages;
++import org.apache.axis.utils.StringUtils;
++import org.apache.axis.utils.XMLUtils;
++
++
+ /**
+ * SSL socket factory. It _requires_ a valid RSA key and
+ * JSSE. (borrowed code from tomcat)
+@@ -41,6 +61,10 @@
+ */
+ public class JSSESocketFactory extends DefaultSocketFactory implements SecureSocketFactory {
+
++ // This is a a sorted list, if you insert new elements do it orderdered.
++ private final static String[] BAD_COUNTRY_2LDS =
++ {"ac", "co", "com", "ed", "edu", "go", "gouv", "gov", "info",
++ "lg", "ne", "net", "or", "org"};
+ /** Field sslFactory */
+ protected SSLSocketFactory sslFactory = null;
+
+@@ -187,6 +211,279 @@
+ if (log.isDebugEnabled()) {
+ log.debug(Messages.getMessage("createdSSL00"));
+ }
++ verifyHostName(host, (SSLSocket) sslSocket);
+ return sslSocket;
+ }
++ /**
++ * Verifies that the given hostname in certicifate is the hostname we are trying to connect to.
++ * This resolves CVE-2012-5784 and CVE-2014-3596
++ * @param host
++ * @param ssl
++ * @throws IOException
++ */
++
++ private static void verifyHostName(String host, SSLSocket ssl)
++ throws IOException {
++ if (host == null) {
++ throw new IllegalArgumentException("host to verify was null");
++ }
++
++ SSLSession session = ssl.getSession();
++ if (session == null) {
++ // In our experience this only happens under IBM 1.4.x when
++ // spurious (unrelated) certificates show up in the server's chain.
++ // Hopefully this will unearth the real problem:
++ InputStream in = ssl.getInputStream();
++ in.available();
++ /*
++ If you're looking at the 2 lines of code above because you're
++ running into a problem, you probably have two options:
++
++ #1. Clean up the certificate chain that your server
++ is presenting (e.g. edit "/etc/apache2/server.crt" or
++ wherever it is your server's certificate chain is
++ defined).
++
++ OR
++
++ #2. Upgrade to an IBM 1.5.x or greater JVM, or switch to a
++ non-IBM JVM.
++ */
++
++ // If ssl.getInputStream().available() didn't cause an exception,
++ // maybe at least now the session is available?
++ session = ssl.getSession();
++ if (session == null) {
++ // If it's still null, probably a startHandshake() will
++ // unearth the real problem.
++ ssl.startHandshake();
++
++ // Okay, if we still haven't managed to cause an exception,
++ // might as well go for the NPE. Or maybe we're okay now?
++ session = ssl.getSession();
++ }
++ }
++
++ Certificate[] certs = session.getPeerCertificates();
++ verifyHostName(host.trim().toLowerCase(Locale.US), (X509Certificate) certs[0]);
++ }
++ /**
++ * Extract the names from the certificate and tests host matches one of them
++ * @param host
++ * @param cert
++ * @throws SSLException
++ */
++
++ private static void verifyHostName(final String host, X509Certificate cert)
++ throws SSLException {
++ // I'm okay with being case-insensitive when comparing the host we used
++ // to establish the socket to the hostname in the certificate.
++ // Don't trim the CN, though.
++
++ String[] cns = getCNs(cert);
++ String[] subjectAlts = getDNSSubjectAlts(cert);
++ verifyHostName(host, cns, subjectAlts);
++
++ }
++
++ /**
++ * Extract all alternative names from a certificate.
++ * @param cert
++ * @return
++ */
++ private static String[] getDNSSubjectAlts(X509Certificate cert) {
++ LinkedList subjectAltList = new LinkedList();
++ Collection c = null;
++ try {
++ c = cert.getSubjectAlternativeNames();
++ } catch (CertificateParsingException cpe) {
++ // Should probably log.debug() this?
++ cpe.printStackTrace();
++ }
++ if (c != null) {
++ Iterator it = c.iterator();
++ while (it.hasNext()) {
++ List list = (List) it.next();
++ int type = ((Integer) list.get(0)).intValue();
++ // If type is 2, then we've got a dNSName
++ if (type == 2) {
++ String s = (String) list.get(1);
++ subjectAltList.add(s);
++ }
++ }
++ }
++ if (!subjectAltList.isEmpty()) {
++ String[] subjectAlts = new String[subjectAltList.size()];
++ subjectAltList.toArray(subjectAlts);
++ return subjectAlts;
++ } else {
++ return new String[0];
++ }
++
++ }
++ /**
++ * Verifies
++ * @param host
++ * @param cn
++ * @param subjectAlts
++ * @throws SSLException
++ */
++
++ private static void verifyHostName(final String host, String[] cns, String[] subjectAlts)throws SSLException{
++ StringBuffer cnTested = new StringBuffer();
++
++ for (int i = 0; i < subjectAlts.length; i++){
++ String name = subjectAlts[i];
++ if (name != null) {
++ name = name.toLowerCase(Locale.US);
++ if (verifyHostName(host, name)){
++ return;
++ }
++ cnTested.append("/").append(name);
++ }
++ }
++ for (int i = 0; i < cns.length; i++) {
++ String cn = cns[i];
++ if (cn != null) {
++ cn = cn.toLowerCase(Locale.US);
++ if (verifyHostName(host, cn)) {
++ return;
++ }
++ cnTested.append("/").append(cn);
++ }
++ }
++ throw new SSLException("hostname in certificate didn't match: <"
++ + host + "> != <" + cnTested + ">");
++ }
++
++ private static boolean verifyHostName(final String host, final String cn){
++ if (doWildCard(cn) && !isIPAddress(host)) {
++ return matchesWildCard(cn, host);
++ }
++ return host.equalsIgnoreCase(cn);
++ }
++ private static boolean doWildCard(String cn) {
++ // Contains a wildcard
++ // wildcard in the first block
++ // not an ipaddress (ip addres must explicitily be equal)
++ // not using 2nd level common tld : ex: not for *.co.uk
++ String parts[] = cn.split("\\.");
++ return parts.length >= 3 &&
++ parts[0].endsWith("*") &&
++ acceptableCountryWildcard(cn) &&
++ !isIPAddress(cn);
++ }
++
++ private static final Pattern IPV4_PATTERN =
++ Pattern.compile("^(25[0-5]|2[0-4]\\d|[0-1]?\\d?\\d)(\\.(25[0-5]|2[0-4]\\d|[0-1]?\\d?\\d)){3}$");
++
++ private static final Pattern IPV6_STD_PATTERN =
++ Pattern.compile("^(?:[0-9a-fA-F]{1,4}:){7}[0-9a-fA-F]{1,4}$");
++
++ private static final Pattern IPV6_HEX_COMPRESSED_PATTERN =
++ Pattern.compile("^((?:[0-9A-Fa-f]{1,4}(?::[0-9A-Fa-f]{1,4})*)?)::((?:[0-9A-Fa-f]{1,4}(?::[0-9A-Fa-f]{1,4})*)?)$");
++
++
++ private static boolean isIPAddress(final String hostname) {
++ return hostname != null
++ && (
++ IPV4_PATTERN.matcher(hostname).matches()
++ || IPV6_STD_PATTERN.matcher(hostname).matches()
++ || IPV6_HEX_COMPRESSED_PATTERN.matcher(hostname).matches()
++ );
++
++ }
++
++ private static boolean acceptableCountryWildcard(final String cn) {
++ // The CN better have at least two dots if it wants wildcard action,
++ // but can't be [*.co.uk] or [*.co.jp] or [*.org.uk], etc...
++ // The [*.co.uk] problem is an interesting one. Should we just
++ // hope that CA's would never foolishly allow such a
++ // certificate to happen?
++
++ String[] parts = cn.split("\\.");
++ // Only checks for 3 levels, with country code of 2 letters.
++ if (parts.length > 3 || parts[parts.length - 1].length() != 2) {
++ return true;
++ }
++ String countryCode = parts[parts.length - 2];
++ return Arrays.binarySearch(BAD_COUNTRY_2LDS, countryCode) < 0;
++ }
++
++ private static boolean matchesWildCard(final String cn,
++ final String hostName) {
++ String parts[] = cn.split("\\.");
++ boolean match = false;
++ String firstpart = parts[0];
++ if (firstpart.length() > 1) {
++ // server∗
++ // e.g. server
++ String prefix = firstpart.substring(0, firstpart.length() - 1);
++ // skipwildcard part from cn
++ String suffix = cn.substring(firstpart.length());
++ // skip wildcard part from host
++ String hostSuffix = hostName.substring(prefix.length());
++ match = hostName.startsWith(prefix) && hostSuffix.endsWith(suffix);
++ } else {
++ match = hostName.endsWith(cn.substring(1));
++ }
++ if (match) {
++ // I f we ’ r e i n s t r i c t mode ,
++ // [ ∗.foo.com] is not allowed to match [a.b.foo.com]
++ match = countDots(hostName) == countDots(cn);
++ }
++ return match;
++ }
++
++ private static int countDots(final String data) {
++ int dots = 0;
++ for (int i = 0; i < data.length(); i++) {
++ if (data.charAt(i) == '.') {
++ dots += 1;
++ }
++ }
++ return dots;
++ }
++
++
++ private static String[] getCNs(X509Certificate cert) {
++ // Note: toString() seems to do a better job than getName()
++ //
++ // For example, getName() gives me this:
++ // 1.2.840.113549.1.9.1=#16166a756c6975736461766965734063756362632e636f6d
++ //
++ // whereas toString() gives me this:
++ // EMAILADDRESS=juliusdavies@cucbc.com
++ String subjectPrincipal = cert.getSubjectX500Principal().toString();
++
++ return getCNs(subjectPrincipal);
++
++ }
++ private static String[] getCNs(String subjectPrincipal) {
++ if (subjectPrincipal == null) {
++ return null;
++ }
++ final List cns = new ArrayList();
++ try {
++ final LdapName subjectDN = new LdapName(subjectPrincipal);
++ final List rdns = subjectDN.getRdns();
++ for (int i = rdns.size() - 1; i >= 0; i--) {
++ final Rdn rds = (Rdn) rdns.get(i);
++ final Attributes attributes = rds.toAttributes();
++ final Attribute cn = attributes.get("cn");
++ if (cn != null) {
++ try {
++ final Object value = cn.get();
++ if (value != null) {
++ cns.add(value.toString());
++ }
++ }
++ catch (NamingException ignore) {}
++ }
++ }
++ }
++ catch (InvalidNameException ignore) { }
++ return cns.isEmpty() ? null : (String[]) cns.toArray(new String[ cns.size() ]);
++ }
++
+ }
diff --git a/www-servers/axis/files/axis-1.4-build.xml.patch b/www-servers/axis/files/axis-1.4-build.xml.patch
new file mode 100644
index 000000000000..92e5116934da
--- /dev/null
+++ b/www-servers/axis/files/axis-1.4-build.xml.patch
@@ -0,0 +1,15 @@
+--- build.xml.orig 2006-04-23 03:57:27.000000000 +0200
++++ build.xml 2006-10-01 21:18:20.000000000 +0200
+@@ -223,10 +223,12 @@
+ </section>
+ </manifest>
+ </jar>
++ <!--
+ <copy file="${wsdl4j.jar}" toDir="${build.lib}"/>
+ <copy file="${commons-logging.jar}" toDir="${build.lib}"/>
+ <copy file="${commons-discovery.jar}" toDir="${build.lib}"/>
+ <copy file="${log4j-core.jar}" toDir="${build.lib}"/>
++ -->
+ <copy file="${src.dir}/log4j.properties"
+ toDir="${build.lib}"/>
+
diff --git a/www-servers/axis/files/axis-1.4-java6.patch b/www-servers/axis/files/axis-1.4-java6.patch
new file mode 100644
index 000000000000..2e9bd4289900
--- /dev/null
+++ b/www-servers/axis/files/axis-1.4-java6.patch
@@ -0,0 +1,16 @@
+--- src/org/apache/axis/i18n/ProjectResourceBundle.java.orig 2006-04-23 03:57:27.000000000 +0200
++++ src/org/apache/axis/i18n/ProjectResourceBundle.java 2009-11-08 19:08:20.000000000 +0100
+@@ -357,13 +357,6 @@
+ return resourceName;
+ }
+
+- /**
+- * Clears the internal cache
+- */
+- public static void clearCache()
+- {
+- bundleCache.clear();
+- }
+
+ public String toString() {
+ return resourceName;
diff --git a/www-servers/axis/files/axis-1.4-path_refs.xml.patch b/www-servers/axis/files/axis-1.4-path_refs.xml.patch
new file mode 100644
index 000000000000..7c0ad2455bd4
--- /dev/null
+++ b/www-servers/axis/files/axis-1.4-path_refs.xml.patch
@@ -0,0 +1,20 @@
+--- xmls/path_refs.xml.orig 2006-04-23 03:56:52.000000000 +0200
++++ xmls/path_refs.xml 2006-10-01 15:31:34.000000000 +0200
+@@ -1,4 +1,5 @@
+ <path id="classpath">
++ <!--
+ <pathelement location="${xercesImpl.jar}"/>
+ <pathelement location="${xmlParserAPIs.jar}"/>
+ <pathelement location="${xalan.jar}"/>
+@@ -14,10 +15,10 @@
+ <pathelement location="${j2ee.jar}"/>
+ <pathelement location="${junit.jar}"/>
+ <pathelement location="${servlet.jar}"/>
++ -->
+ <fileset dir="${lib.dir}">
+ <include name="**/*.jar"/>
+ </fileset>
+- <pathelement path="${java.class.path}"/>
+ <pathelement location="${build.dest}" />
+ <pathelement location="${build.dir}/tools" />
+ <pathelement location="${build.lib}/axis-ant.jar" />
diff --git a/www-servers/axis/files/axis-1.4-targets.xml.patch b/www-servers/axis/files/axis-1.4-targets.xml.patch
new file mode 100644
index 000000000000..1f5f63ee1831
--- /dev/null
+++ b/www-servers/axis/files/axis-1.4-targets.xml.patch
@@ -0,0 +1,86 @@
+--- xmls/targets.xml.orig 2006-10-01 15:08:41.000000000 +0200
++++ xmls/targets.xml 2006-10-01 15:14:27.000000000 +0200
+@@ -84,6 +84,7 @@
+ <mkdir dir="${build.lib}"/>
+ <mkdir dir="${build.dir}/work"/>
+
++ <!--
+ <available property="servlet.present"
+ classname="javax.servlet.Servlet"
+ classpathref="classpath"/>
+@@ -135,18 +136,18 @@
+ <available property="httpunit.present"
+ classname="com.meterware.httpunit.GetMethodWebRequest"
+ classpathref="classpath"/>
+-
++ -->
+ <available property="jsse.present"
+ classname="javax.net.ssl.SSLSocketFactory"
+ classpathref="classpath"/>
+-
++ <!--
+ <condition property="jetty.present" >
+ <and>
+ <available classname="javax.servlet.Servlet" classpathref="classpath" />
+ <available classname="org.mortbay.http.HttpServer" classpathref="classpath" />
+ </and>
+ </condition>
+-
++ -->
+ <condition property="jdk14.jsse.present" >
+ <and>
+ <available classname="javax.net.ssl.X509TrustManager" classpathref="classpath" />
+@@ -185,7 +186,7 @@
+ <condition property="sun.codec.present" >
+ <available classname="sun.awt.image.codec.JPEGImageEncoderImpl" classpathref="classpath" />
+ </condition>
+-
++ <!--
+ <condition property="jimi.present" >
+ <available classname="com.sun.jimi.core.Jimi" classpathref="classpath" />
+ </condition>
+@@ -193,7 +194,7 @@
+ <condition property="merlinio.present" >
+ <available classname="javax.imageio.ImageIO" classpathref="classpath" />
+ </condition>
+-
++ -->
+ <condition property="axis-ant.present" >
+ <available classname="org.apache.axis.tools.ant.foreach.ForeachTask">
+ <classpath>
+@@ -201,7 +202,7 @@
+ </classpath>
+ </available>
+ </condition>
+-
++ <!--
+ <condition property="jimiAndAttachments.present">
+ <and>
+ <available classname="javax.activation.DataHandler" classpathref="classpath" />
+@@ -220,7 +221,7 @@
+ <available classname="progress.message.jclient.Message" classpathref="classpath" />
+ </and>
+ </condition>
+-
++ -->
+ <available property="post-compile.present" file="post-compile.xml" />
+
+ <property environment="env"/>
+@@ -229,7 +230,7 @@
+ <equals arg1="on" arg2="${env.debug}"/>
+ </and>
+ </condition>
+-
++ <!--
+ <condition property="castor.present" >
+ <available classname="org.exolab.castor.xml.MarshalException" classpathref="classpath" />
+ </condition>
+@@ -248,7 +249,7 @@
+ <condition property="combridge.present" >
+ <available classname="org.apache.axis.components.bridge.COMBridge" classpathref="classpath" />
+ </condition>
+-
++ -->
+ <!-- look for WSDL support on the platform -->
+ <condition property="wsdl.found">
+ <or>
diff --git a/www-servers/axis/files/axis-1.4-tools-build.xml.patch b/www-servers/axis/files/axis-1.4-tools-build.xml.patch
new file mode 100644
index 000000000000..ce9759264eda
--- /dev/null
+++ b/www-servers/axis/files/axis-1.4-tools-build.xml.patch
@@ -0,0 +1,26 @@
+--- tools/build.xml.orig 2006-10-02 10:18:43.000000000 +0200
++++ tools/build.xml 2006-10-02 10:21:34.000000000 +0200
+@@ -66,6 +66,7 @@
+ <javac srcdir="${tools.dir}"
+ debug="${debug}"
+ source="${source}"
++ target="${target}"
+ nowarn="${nowarn}"
+ destdir="${tools.build.dir}">
+ <classpath refid="classpath"/>
+@@ -77,6 +78,7 @@
+ <javac srcdir="${tools.dir}"
+ debug="${debug}"
+ source="${source}"
++ target="${target}"
+ nowarn="${nowarn}"
+ destdir="${tools.build.dir}">
+ <classpath refid="classpath"/>
+@@ -88,6 +90,7 @@
+ <javac srcdir="${tools.dir}"
+ debug="${debug}"
+ source="${source}"
++ target="${target}"
+ nowarn="${nowarn}"
+ destdir="${tools.build.dir}">
+ <classpath>
diff --git a/www-servers/axis/files/build.properties b/www-servers/axis/files/build.properties
new file mode 100644
index 000000000000..9387391ab441
--- /dev/null
+++ b/www-servers/axis/files/build.properties
@@ -0,0 +1,15 @@
+source=1.4
+target=1.4
+
+activation.present=true
+commons-discovery.present=true
+commons-logging.present=true
+wsdl4j.present=true
+mailapi.present=true
+
+bsf.present=true
+castor.present=true
+commons-httpclient.present=true
+commons-net.present=true
+jimi.present=true
+servlet.present=true
diff --git a/www-servers/axis/metadata.xml b/www-servers/axis/metadata.xml
new file mode 100644
index 000000000000..d75e8a6c1c56
--- /dev/null
+++ b/www-servers/axis/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+
+<longdescription>
+Apache Axis is an implementation of the SOAP ("Simple Object Access Protocol") submission to W3C.
+
+From the draft W3C specification:
+
+SOAP is a lightweight protocol for exchange of information in a decentralized, distributed environment. It is an XML based protocol that consists of three parts: an envelope that defines a framework for describing what is in a message and how to process it, a set of encoding rules for expressing instances of application-defined datatypes, and a convention for representing remote procedure calls and responses.
+</longdescription>
+</pkgmetadata>