summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2016-01-29 11:08:59 -0600
committerWilliam Hubbs <williamh@gentoo.org>2016-01-29 11:11:05 -0600
commitd853297bef8a0f8b816863f7584b9a5d243bc188 (patch)
treeeeadbb15497fc7f9ae7bbc28110802f00ee9850d /www-servers/boa/boa-0.94.14_rc21-r2.ebuild
parentprofiles: games-strategy/xbattle is gone (diff)
downloadgentoo-d853297bef8a0f8b816863f7584b9a5d243bc188.tar.gz
gentoo-d853297bef8a0f8b816863f7584b9a5d243bc188.tar.bz2
gentoo-d853297bef8a0f8b816863f7584b9a5d243bc188.zip
www-servers/boa: revision bump to fix OpenRC script
https://bugs.gentoo.org/show_bug.cgi?id=571448
Diffstat (limited to 'www-servers/boa/boa-0.94.14_rc21-r2.ebuild')
-rw-r--r--www-servers/boa/boa-0.94.14_rc21-r2.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/www-servers/boa/boa-0.94.14_rc21-r2.ebuild b/www-servers/boa/boa-0.94.14_rc21-r2.ebuild
new file mode 100644
index 000000000000..9c9a390565a0
--- /dev/null
+++ b/www-servers/boa/boa-0.94.14_rc21-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd
+
+MY_P=${P/_/}
+DESCRIPTION="A very small and very fast http daemon"
+SRC_URI="http://www.boa.org/${MY_P}.tar.gz"
+HOMEPAGE="http://www.boa.org/"
+
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="sys-devel/bison
+ sys-devel/flex
+ doc? ( virtual/latex-base )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-texi.patch
+ epatch "${FILESDIR}"/${P}-ENOSYS.patch
+}
+
+src_compile() {
+ default
+
+ use doc || sed -i -e '/^all:/s/boa.dvi //' docs/Makefile
+ emake docs
+}
+
+src_install() {
+ dosbin src/boa
+ doman docs/boa.8
+ doinfo docs/boa.info
+ if use doc; then
+ dodoc docs/boa.html
+ dodoc docs/boa_banner.png
+ dodoc docs/boa.dvi
+ fi
+
+ keepdir /var/log/boa
+ keepdir /var/www/localhost/htdocs
+ keepdir /var/www/localhost/cgi-bin
+ keepdir /var/www/localhost/icons
+
+ newinitd "${FILESDIR}"/boa.initd boa
+ newconfd "${FILESDIR}"/boa.conf.d boa
+
+ systemd_dounit "${FILESDIR}"/boa.service
+
+ exeinto /usr/lib/boa
+ doexe src/boa_indexer
+
+ insinto /etc/boa
+ doins "${FILESDIR}"/boa.conf
+ doins "${FILESDIR}"/mime.types
+}