summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-03-18 18:53:28 +1100
committerMichael Palimaka <kensington@gentoo.org>2017-03-18 18:53:34 +1100
commit0cc34faf9c5e8519d3e63cb6ffc4d2dc0d2c90cd (patch)
tree035e4ed1b64a24122dd32bdce80a452aa0d22ff4 /www-servers/bozohttpd/bozohttpd-20170201.ebuild
parentnet-libs/liboauth: remove 1.0.1 (diff)
downloadgentoo-0cc34faf9c5e8519d3e63cb6ffc4d2dc0d2c90cd.tar.gz
gentoo-0cc34faf9c5e8519d3e63cb6ffc4d2dc0d2c90cd.tar.bz2
gentoo-0cc34faf9c5e8519d3e63cb6ffc4d2dc0d2c90cd.zip
www-servers/bozohttpd: version bump 20170201
Gentoo-bug: 592832 Gentoo-bug: 611398 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'www-servers/bozohttpd/bozohttpd-20170201.ebuild')
-rw-r--r--www-servers/bozohttpd/bozohttpd-20170201.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/www-servers/bozohttpd/bozohttpd-20170201.ebuild b/www-servers/bozohttpd/bozohttpd-20170201.ebuild
new file mode 100644
index 000000000000..1044a7a84412
--- /dev/null
+++ b/www-servers/bozohttpd/bozohttpd-20170201.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="bozohttpd is a small and secure http server"
+HOMEPAGE="http://www.eterna.com.au/bozohttpd/"
+SRC_URI="http://www.eterna.com.au/bozohttpd/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="libressl"
+
+DEPEND="!libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )"
+RDEPEND="${DEPEND}
+ virtual/logger"
+
+src_prepare() {
+ default
+ mv Makefile{.boot,} || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" OPT="${CFLAGS}"
+}
+
+src_install() {
+ dobin bozohttpd
+ doman bozohttpd.8
+
+ newconfd "${FILESDIR}"/${PN}.conffile bozohttpd
+ newinitd "${FILESDIR}"/${PN}.initscript bozohttpd
+}