summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-servers/fnord/files/fnord-1.10-gentoo.diff
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-servers/fnord/files/fnord-1.10-gentoo.diff')
-rw-r--r--www-servers/fnord/files/fnord-1.10-gentoo.diff99
1 files changed, 99 insertions, 0 deletions
diff --git a/www-servers/fnord/files/fnord-1.10-gentoo.diff b/www-servers/fnord/files/fnord-1.10-gentoo.diff
new file mode 100644
index 000000000000..3e2f1f5fc7c4
--- /dev/null
+++ b/www-servers/fnord/files/fnord-1.10-gentoo.diff
@@ -0,0 +1,99 @@
+diff -Naur fnord-1.10.orig/fnord-conf fnord-1.10/fnord-conf
+--- fnord-1.10.orig/fnord-conf 2010-10-22 17:31:41.000000000 +0200
++++ fnord-1.10/fnord-conf 2010-10-22 19:57:28.000000000 +0200
+@@ -17,7 +17,7 @@
+ mkdir -p $dir
+ echo "#!/bin/sh" > $dir/run
+ echo "cd $webroot" >> $dir/run
+-echo "exec envuidgid $acct tcpserver -RHl localhost ${myip:-0} 80 fnord 2>&1" >> $dir/run
++echo "exec envuidgid $acct tcpserver -RHl localhost ${myip:-0} 80 /usr/bin/fnord 2>&1" >> $dir/run
+ chmod 755 $dir/run
+
+ # tell old daemontools that it should spawn a log process, too
+diff -Naur fnord-1.10.orig/httpd.c fnord-1.10/httpd.c
+--- fnord-1.10.orig/httpd.c 2010-10-22 17:31:41.000000000 +0200
++++ fnord-1.10/httpd.c 2010-10-22 19:57:28.000000000 +0200
+@@ -25,7 +25,9 @@
+ #include "scan.h"
+
+ /* uncomment the following line to enable support for CGI */
+-// #define CGI
++#ifndef CGI
++# define CGI
++#endif
+
+ #ifdef CGI
+ /* uncomment the following line to enable support for "index.cgi"
+@@ -39,7 +41,9 @@
+
+ /* uncomment the following line to enable support for autogenerated
+ * directory-listings for directories without index */
+-/* #define DIR_LIST */
++#ifndef DIR_LIST
++# define DIR_LIST
++#endif
+
+ #ifdef DIR_LIST
+ /* uncomment the following line to enable support for system symlink
+diff -Naur fnord-1.10.orig/Makefile fnord-1.10/Makefile
+--- fnord-1.10.orig/Makefile 2010-10-22 17:31:41.000000000 +0200
++++ fnord-1.10/Makefile 2010-10-22 19:58:56.000000000 +0200
+@@ -1,28 +1,19 @@
+-CC=gcc
+-CXX=g++
+-
+-#LIBOWFAT=../libowfat/
+-DIET=diet -Os
+-
+-CFLAGS=-Os -fomit-frame-pointer
+-#CFLAGS=-g
++CC:=gcc
++CXX:=g++
+
+ all: fnord fnord-cgi fnord-idx
+
+ fnord: httpd
+ cp -p $^ $@
+- -strip -R .note -R .comment $@
+
+ httpd: httpd.o libowfat.a
+- $(DIET) $(CC) -o $@ $^ $(CFLAGS)
++ $(DIET) $(CC) $(LDFLAGS) -o $@ $^ $(CFLAGS)
+
+ fnord-cgi: httpd-cgi.o libowfat.a
+- $(DIET) $(CC) -o $@ $^ $(CFLAGS)
+- -strip -R .note -R .comment $@
++ $(DIET) $(CC) $(LDFLAGS) -o $@ $^ $(CFLAGS)
+
+ fnord-idx: httpd-idx.o libowfat.a
+- $(DIET) $(CC) -o $@ $^ $(CFLAGS)
+- -strip -R .note -R .comment $@
++ $(DIET) $(CC) $(LDFLAGS) -o $@ $^ $(CFLAGS)
+
+ libowfat.a: httpd.o buffer_1.o buffer_puts.o buffer_flush.o buffer_put.o \
+ buffer_putulong.o buffer_2.o buffer_putspace.o buffer_stubborn.o \
+@@ -32,19 +23,19 @@
+ -ranlib $@
+
+ httpd.o: httpd.c
+- $(DIET) $(CC) -pipe $(CFLAGS) -c $^ -DFNORD=\"fnord/$(shell head -n 1 CHANGES|sed 's/://')\"
++ $(DIET) $(CC) $(CFLAGS) -c $^ -DFNORD=\"fnord/$(shell head -n 1 CHANGES|sed 's/://')\"
+
+ httpd-cgi.o: httpd.c
+- $(DIET) $(CC) -pipe $(CFLAGS) -c httpd.c -o $@ -DCGI -DFNORD=\"fnord/$(shell head -n 1 CHANGES|sed 's/://')\"
++ $(DIET) $(CC) $(CFLAGS) -c httpd.c -o $@ -DCGI -DFNORD=\"fnord/$(shell head -n 1 CHANGES|sed 's/://')\"
+
+ httpd-idx.o: httpd.c
+- $(DIET) $(CC) -pipe $(CFLAGS) -c httpd.c -o $@ -DDIR_LIST -DFNORD=\"fnord/$(shell head -n 1 CHANGES|sed 's/://')\"
++ $(DIET) $(CC) $(CFLAGS) -c httpd.c -o $@ -DDIR_LIST -DFNORD=\"fnord/$(shell head -n 1 CHANGES|sed 's/://')\"
+
+ %.o: %.c
+- $(DIET) $(CC) -pipe $(CFLAGS) -c $^
++ $(DIET) $(CC) $(CFLAGS) -c $^
+
+ %.o: %.cpp
+- $(DIET) $(CXX) -pipe $(CFLAGS) -c $^
++ $(DIET) $(CXX) $(CFLAGS) -c $^
+
+ .PHONY: rename clean install server
+ server: fnord